Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: mkvtoolnix not working

  1. #1

    Default mkvtoolnix not working

    I cannot get mkvtoolnix to work due broken dependencies. Also, the package is old: v6.3 where as 13.1 already have v6.7 which have a lot of fixes. I've tried to install 13.1 version but unfortunately it uses more recent libs compared to tumbleweed thus no luck.

    mkvmerge: error while loading shared libraries: libboost_regex.so.1.49.0: cannot open shared object file: No such file or directory
    installed lib: libboost_regex1_53_0-1.53.0-4.1.2.x86_64

    Hopefully someone can either fix this in tumbleweed or provide help to solve the problem.

  2. #2

    Default Re: mkvtoolnix not working

    Quote Originally Posted by paju2000 View Post
    I cannot get mkvtoolnix to work due broken dependencies. Also, the package is old: v6.3 where as 13.1 already have v6.7 which have a lot of fixes. I've tried to install 13.1 version but unfortunately it uses more recent libs compared to tumbleweed thus no luck.
    Sorry, I don't understand that completely.
    13.1 does actually have 6.3 included. And this should install fine, as Tumbleweed is based on 13.1. at the moment.
    Where do you see 6.7 in 13.1?

    mkvmerge: error while loading shared libraries: libboost_regex.so.1.49.0: cannot open shared object file: No such file or directory
    installed lib: libboost_regex1_53_0-1.53.0-4.1.2.x86_64
    The last distribution where "libboost_regex.1.49.0" was included is 12.3.
    If it was included in 13.1, you would have it when using Tumbleweed.
    The package you are trying to install is obviously intended for 12.3 therefore.

    So could you please post the full link where you downloaded the package from? (or the repo URL if you added a repo)
    And please post your repo list in any case:
    Code:
    zypper lr -d
    Last edited by wolfi323; 01-Mar-2014 at 07:38.

  3. #3

    Default Re: mkvtoolnix not working

    Hmm.. I don't have 13.1 installed thus cannot confirm it from there but according to this link there is 6.7: http://download.opensuse.org/factory...s/suse/x86_64/

    zypper lr -d:

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+----------------------------------+----------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------------+--------
    1 | LibreOffice_STABLE_ | LibreOffice STABLE | No | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
    2 | home:subchaser | home:subchaser | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/ |
    3 | openSUSE-12.2-1.6 | openSUSE-12.2-1.6 | No | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/usb-Slimtype_eNAU608_5_107050237116-0:0,/dev/sr0 |
    4 | openSUSE-current-update-non-oss_ | openSUSE-current-update-non-oss | Yes | Yes | 94 | rpm-md | http://download.opensuse.org/update/...n-oss-current/ |
    5 | openSUSE:Stable_OSS | openSUSE-current-oss | Yes | Yes | 95 | yast2 | http://download.opensuse.org/distrib...rent/repo/oss/ |
    6 | openSUSE:Stable_Updates | openSUSE-current-update-oss | Yes | Yes | 93 | rpm-md | http://download.opensuse.org/update/openSUSE-current/ |
    7 | openSUSE:Stable_non-OSS | openSUSE-current-non-oss | Yes | Yes | 96 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    8 | openSUSE:Tumbleweed | openSUSE-Tumbleweed-standard | Yes | Yes | 92 | rpm-md | http://download.opensuse.org/reposit...weed/standard/ |
    9 | packman-essentials | openSUSE-Tumbleweed-Packman Essentials | Yes | Yes | 90 | rpm-md | http://packman.inode.at/suse/openSUS...eed/Essentials |
    10 | pacman | openSUSE-Tumbleweed-Packman | Yes | Yes | 91 | rpm-md | http://packman.inode.at/suse/openSUSE_Tumbleweed |
    11 | repo-update-non-oss | openSUSE-12.3-Update-Non-Oss | No | Yes | 99 | rpm-md | http://download.opensuse.org/update/12.3-non-oss/ |
    12 | utilities | utilities | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...SE_Tumbleweed/
    |

    yast and zypper cannot find more recent version of mkvtoolnix under tumbleweed. Don't know for which openSUSE version 6.3 is meant for.

  4. #4

    Default Re: mkvtoolnix not working

    Quote Originally Posted by paju2000 View Post
    Hmm.. I don't have 13.1 installed thus cannot confirm it from there
    Of course you have. OpenSUSE-current _is_ 13.1 at the moment.

    but according to this link there is 6.7:

    http://download.opensuse.org/factory...s/suse/x86_64/
    No, that's Factory, i.e the future 13.2.

    zypper lr -d:
    ...
    Looks ok, mostly.

    You could remove the 12.2 CD (#3) and the 12.3-Update-Non-Oss repo (#11) if you want.
    You have the corresponding openSUSE-current repos anyway.

    yast and zypper cannot find more recent version of mkvtoolnix under tumbleweed. Don't know for which openSUSE version 6.3 is meant for.
    Again, that's what's included in 13.1, i.e. openSUSE-current.

    If you want version 6.7 you could try to install the 13.1 package from the multimedia:apps repo. This should work fine on Tumbleweed, but I wouldn't necessarily recommend to add the whole repo.
    http://software.opensuse.org/package/mkvtoolnix
    (click on "Show other versions" and "Show possibly unstable packages")
    The package would be downgraded to 6.3 on every "zypper dup" though.
    I will create a Tumbleweed package for you.
    Last edited by wolfi323; 01-Mar-2014 at 09:37.

  5. #5

    Default Re: mkvtoolnix not working

    So, it seems that there are then some issues with the mkvtoolnix version available as it requires obsolete library.

    I'll wait for a while if you manage to get mkvtoolnix updated for tumbleweed. I'd rather not mix stable and unstable because this PC operates as home server as well.

    Anyway, thanks for helping out!

  6. #6

    Default Re: mkvtoolnix not working

    Quote Originally Posted by paju2000 View Post
    So, it seems that there are then some issues with the mkvtoolnix version available as it requires obsolete library.
    No the 6.3.0 version from openSUSE-Current is fine.
    Which one do you mean exactly?
    As I said, if it requires libboost 1.49.0, it is for 12.3, not 13.1 or Tumbleweed.

    The one from Factory may have requirements of course that are not in openSUSE-Current or Tumbleweed.

    I'll wait for a while if you manage to get mkvtoolnix updated for tumbleweed. I'd rather not mix stable and unstable because this PC operates as home server as well.
    It's building atm, I 'll report back when it's finished.

  7. #7

    Default Re: mkvtoolnix not working

    Quote Originally Posted by wolfi323 View Post
    It's building atm, I 'll report back when it's finished.
    The updated package is available here now:
    http://software.opensuse.org/downloa...age=mkvtoolnix
    I hope it's working, I haven't tested it myself, but it's the exact same package as in multimedia:apps and Factory, just built for Tumbleweed.

    You should add the repo, so "zypper dup" doesn't downgrade the package again.
    That repo only contains hydrogen as well and I don't plan to add anything, so it's safe to do it.

  8. #8

    Default Re: mkvtoolnix not working

    Quote Originally Posted by wolfi323 View Post
    The updated package is available here now:
    http://software.opensuse.org/downloa...age=mkvtoolnix
    I hope it's working, I haven't tested it myself, but it's the exact same package as in multimedia:apps and Factory, just built for Tumbleweed.

    You should add the repo, so "zypper dup" doesn't downgrade the package again.
    That repo only contains hydrogen as well and I don't plan to add anything, so it's safe to do it.
    Apparently there is something else wrong in my tumbleweed installation. I added the repo and installed mkvtoolnix (version 6.7, thx for that) but when I try to run mkvmerge I get the same error as before:

    mkvmerge: error while loading shared libraries: libboost_regex.so.1.49.0: cannot open shared object file: No such file or directory

    For some reason the dependency is incorrect. How can I find out what is the problem and then how to fix that?

  9. #9

    Default Re: mkvtoolnix not working

    Could the problem be linked to following?

    zypper ve results:

    The following NEW package is going to be installed:
    kernel-desktop-3.11.10-7.1

    The following package is going to be REMOVED:
    microcode_ctl

    This is old package but apparently zypper thinks this is new.

    How can I remove this package to avoid installing?

  10. #10

    Default Re: mkvtoolnix not working

    Quote Originally Posted by paju2000 View Post
    Could the problem be linked to following?
    No.

    zypper ve results:

    The following NEW package is going to be installed:
    kernel-desktop-3.11.10-7.1
    That's the kernel from openSUSE-Current-Updates.
    Apparently you have the kernel 3.11.6 from openSUSE-Current installed, so zypper wants to update it.
    If you uninstall kernel-desktop-3.11.6, it shouldn't want to install 3.11.10 anymore I think.

    The following package is going to be REMOVED:
    microcode_ctl

    This is old package but apparently zypper thinks this is new.
    No. This package doesn't exist anymore, so zypper wants to REMOVE it.

    To your dependency problem: Maybe you have some self-compiled mkvmerge somewhere in your path?
    Please post the output of:
    Code:
    which mkvmerge
    rpm -qfi `which mkvmerge`

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •