Results 1 to 5 of 5

Thread: 13.1 - Problem connecting to a software origin

  1. #1

    Default 13.1 - Problem connecting to a software origin

    Hi to you all,

    new Linux user here. I bought an OS-free laptop from MSI and just installed OpenSuse 13.1 64bits on it. It worked perfectly well! Wifi access, screen, touchpad, everything is working smoothly, I'm impressed!

    My only problem is with upgrading/software update: I get notifications with the following message:

    File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/13.1/repo/non-oss/'

    I get the same message when doing `sudo zypper dup`.

    And indeed, going the above address, there is no /repodata directory nor repomd.xml file.

    Since I did not change any built-in repo list, what's happening and how can I change this? zypper complains with a lot of missing dependencies and that might come from this...

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,488
    Blog Entries
    15

    Default Re: 13.1 - Problem connecting to a software origin

    On Fri 28 Feb 2014 07:36:03 PM CST, PhilippeSigaud wrote:


    Hi to you all,

    new Linux user here. I bought an OS-free laptop from MSI and just
    installed OpenSuse 13.1 64bits on it. It worked perfectly well! Wifi
    access, screen, touchpad, everything is working smoothly, I'm impressed!

    My only problem is with upgrading/software update: I get notifications
    with the following message:

    File '/repodata/repomd.xml' not found on medium
    'http://download.opensuse.org/distribution/13.1/repo/non-oss/'

    I get the same message when doing `sudo zypper dup`.

    And indeed, going the above address, there is no /repodata directory nor
    repomd.xml file.

    Since I did not change any built-in repo list, what's happening and how
    can I change this? zypper complains with a lot of missing dependencies
    and that might come from this...


    Hi
    You could be redirected to an incomplete mirror with respect to your
    location. Plus you don't need to use dup, that's for a distribution
    upgrade, not an update.

    Can you as root user force a cache rebuild and see if that helps;
    Code:
    zypper ref -f
    zypper lu
    zypper up

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3

    Default Re: 13.1 - Problem connecting to a software origin

    Thanks Malcolm for the swift answer,

    that did not change anything. Still the same kind of message:

    Code:
    File '/repodata/repomd.xml' not found on medium 'http://download.opensuse.org/distribution/13.1/repo/non-oss/'
    But indeed going at http://download.opensuse.org/distrib.../repo/non-oss/, there is no /repodata dir.

    Ah, found it: it's in the /suse directory.

    So the web address zypper is using is false. How can I add /suse after non-oss and oss?

  4. #4

    Default Re: 13.1 - Problem connecting to a software origin

    Quote Originally Posted by PhilippeSigaud View Post
    So the web address zypper is using is false. How can I add /suse after non-oss and oss?
    That should not be necessary. zypper should append the /suse itself autmatically if needed.
    Not sure why it's not working for you, but maybe there's a different problem.

    If you do want to try to append it, either edit the corresponding text file in /etc/zypp/repos.d/, or change the URL in YaST->Software Repositories.

  5. #5

    Default Re: 13.1 - Problem connecting to a software origin

    Quote Originally Posted by wolfi323 View Post
    That should not be necessary. zypper should append the /suse itself autmatically if needed.
    Not sure why it's not working for you, but maybe there's a different problem.

    If you do want to try to append it, either edit the corresponding text file in /etc/zypp/repos.d/, or change the URL in YaST->Software Repositories.
    I did it. Strangely, on the 8 repos listed in YaST, only 5 needed an added /suse at the end. But now everything works!
    I really wonder why there is such a difference with everybody else, particularly since I did not change any option while installing.

    Anyway...

    Thanks guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •