Page 1 of 5 123 ... LastLast
Results 1 to 10 of 46

Thread: Printer connection doesn't survive reboot

  1. #1
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,451

    Default Printer connection doesn't survive reboot

    I've read many threads on this problem and, so far, none have worked to resolve this problem. I have a wireless HP printer with a DHCP assigned ip. I'm running 13.1 and KDE with current updates installed.

    After a reboot, I attempt to print and get a communication error. This morning I tried
    Code:
    systemctl restart cups.service
    When that didn't work, I tried
    Code:
    systemctl restart cups
    but that didn't work either. I tried to open the cups web page but got a permissions error, so I opened it as root. My user has always been in the lp group, but yesterday I tried
    Code:
    lppasswd -a
    and added my user. That obviously didn't give me access to the cups page. When I get to cups, nothing I try gets the printer communicating. I end up re-installing it through yast and it begins to work.

    My computer has a wired connection to my wireless router. I looked at the firewall. There are 2 interfaces displayed. The first is eth0 and that was in the External Zone. The other is the actual card and that has a device name and also an interface designation of enp2s8. That had no zone assigned and I put it into the Internal Zone for no other reason than to see if it worked to get communication established. It did not.

    A separate problem: I can't get boinc to connect to the localhost, even after today's update. When boinc was running, I left my computer on 24/7 for months at a time. Now that boinc isn't working, I shut the thing off every night and am faced with the communication error when I reboot in the morning. It's only a few clicks to reinstall the printer but doing it everyday is very annoying. Please help me sort this out.
    Last edited by Prexy; 28-Feb-2014 at 09:35. Reason: add info
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Printer connection doesn't survive reboot

    Quote Originally Posted by Prexy View Post
    I've read many threads on this problem and, so far, none have worked to resolve this problem. I have a wireless HP printer with a DHCP assigned ip. I'm running 13.1 and KDE with current updates installed.
    Since the printer has a dynamically assigned IP address, I assume you have CUPS configured to use the printer's hostname? Anyway, I suggest you provide your working /etc/cups/printers.conf here. (BTW, it is more usual to configure printers to use static IP addresses, so that printers configured by IP address can be reached consistently. However, if you're using a printer name, then this should present a problem.)

    This will summarize the URI configuration too
    Code:
    lpstat -v
    After a reboot, I attempt to print and get a communication error. This morning I tried
    Code:
    systemctl restart cups.service
    When that didn't work, I tried
    Code:
    systemctl restart cups
    but that didn't work either.
    Well, depending on the issue, simply restarting the CUPS server will not fix the problem.

    I tried to open the cups web page but got a permissions error, so I opened it as root. My user has always been in the lp group, but yesterday I tried
    Code:
    lppasswd -a
    and added my user. That obviously didn't give me access to the cups page. When I get to cups, nothing I try gets the printer communicating. I end up re-installing it through yast and it begins to work.
    For administrative purposes, CUPS requires root privileges by default. (This is all defined in cupsd.conf)

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Printer connection doesn't survive reboot

    Add your user to the lp (you already did) and the sys group. Re-login and use either
    Code:
    kdesu hp-setup
    or the Printer module in KDE's system settings.

    After configuring the user will be able to start and stop the printer etc.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Printer connection doesn't survive reboot

    Yes, good advice to use hp-setup for HP printers. It will correctly set up the print queue etc

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Printer connection doesn't survive reboot

    On Fri 28 Feb 2014 04:36:01 PM CST, Prexy wrote:


    I've read many threads on this problem and, so far, none have worked to
    resolve this problem. I have a wireless HP printer with a DHCP assigned
    ip. I'm running 13.1 and KDE with current updates installed.

    After a reboot, I attempt to print and get a communication error. This
    morning I tried
    Code:
    --------------------
    systemctl restart cups.service
    --------------------
    When that didn't work, I tried
    Code:
    --------------------
    systemctl restart cups
    --------------------
    but that didn't work either. I tried to open the cups web page but got
    a permissions error, so I opened it as root. My user has always been in
    the lp group, but yesterday I tried
    Code:
    --------------------
    lppasswd -a
    --------------------
    and added my user. That obviously didn't give me access to the cups
    page. When I get to cups, nothing I try gets the printer communicating.
    I end up re-installing it through yast and it begins to work.

    My computer has a wired connection to my wireless router. I looked at
    the firewall. There are 2 interfaces displayed. The first is eth0 and
    that was in the External Zone. The other is the actual card and that has
    a device name and also an interface designation of enp2s8. That had no
    zone assigned and I put it into the Internal Zone for no other reason
    than to see if it worked to get communication established. It did not.

    A separate problem: I can't get boinc to connect to the localhost, even
    after today's update. When boinc was running, I left my computer on 24/7
    for months at a time. Now that boinc isn't working, I shut the thing off
    every night and am faced with the communication error when I reboot in
    the morning. It's only a few clicks to reinstall the printer but doing
    it everyday is very annoying. Please help me sort this out.


    Hi
    What model HP printer?

    I now have a HP LaserJet Pro P1102w (works fine) but you need to setup a
    static ip address after connecting to the printer via the printers web
    interface, or does it have it's own configuration panel?

    Once that's done, configure via hp-setup as root user.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Printer connection doesn't survive reboot

    On Fri 28 Feb 2014 11:55:32 PM CST, malcolmlewis wrote:

    On Fri 28 Feb 2014 04:36:01 PM CST, Prexy wrote:


    I've read many threads on this problem and, so far, none have worked to
    resolve this problem. I have a wireless HP printer with a DHCP assigned
    ip. I'm running 13.1 and KDE with current updates installed.

    After a reboot, I attempt to print and get a communication error. This
    morning I tried
    Code:
    --------------------
    systemctl restart cups.service
    --------------------
    When that didn't work, I tried
    Code:
    --------------------
    systemctl restart cups
    --------------------
    but that didn't work either. I tried to open the cups web page but got
    a permissions error, so I opened it as root. My user has always been in
    the lp group, but yesterday I tried
    Code:
    --------------------
    lppasswd -a
    --------------------
    and added my user. That obviously didn't give me access to the cups
    page. When I get to cups, nothing I try gets the printer communicating.
    I end up re-installing it through yast and it begins to work.

    My computer has a wired connection to my wireless router. I looked at
    the firewall. There are 2 interfaces displayed. The first is eth0 and
    that was in the External Zone. The other is the actual card and that has
    a device name and also an interface designation of enp2s8. That had no
    zone assigned and I put it into the Internal Zone for no other reason
    than to see if it worked to get communication established. It did not.

    A separate problem: I can't get boinc to connect to the localhost, even
    after today's update. When boinc was running, I left my computer on 24/7
    for months at a time. Now that boinc isn't working, I shut the thing off
    every night and am faced with the communication error when I reboot in
    the morning. It's only a few clicks to reinstall the printer but doing
    it everyday is very annoying. Please help me sort this out.


    Hi
    What model HP printer?

    I now have a HP LaserJet Pro P1102w (works fine) but you need to setup a
    static ip address after connecting to the printer via the printers web
    interface, or does it have it's own configuration panel?

    Once that's done, configure via hp-setup as root user.

    Hi
    Another thought, on my router I can define static ip's based on MAC
    address as well, although I don't do that, just have a small pool for
    dhcp and set static ip's via hosts file and NetworkManager.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  7. #7
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,451

    Default Re: Printer connection doesn't survive reboot

    @deano_ferrari The printer is connected now. So, I don't know if lpstat -v will tell you anything. But, here it is

    Code:
    lpstat -v
    device for Officejet_6700: hp:/net/Officejet_6700?ip=192.168.1.130
    device for Officejet_6700_fax: hpfax:/net/Officejet_6700?ip=192.168.1.130
    Although I do not have it set up by a static ip, it always comes up with that .130 even though the next highest ip is 192.168.1.6 If I read you correctly, you think I should switch to static? In the router page? yast? hp-setup?
    Here is /etc/cups/printers.conf
    Code:
    # Printer configuration file for CUPS v1.5.4# Written by cupsd on 2014-03-01 00:00
    # DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING
    <Printer Officejet_6700>
    UUID urn:uuid:10122186-6f8d-33ac-5def-217c049b9f99
    Info Officejet_6700
    MakeModel HP Officejet 6700 hpijs, 3.13.10
    DeviceURI hp:/net/Officejet_6700?ip=192.168.1.130
    State Idle
    StateTime 1393603114
    Type 8425500
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer
    </Printer>
    <Printer Officejet_6700_2>
    UUID urn:uuid:1114f0c5-28d4-3e9e-5643-1283b4136786
    Info 
    Location 
    MakeModel HP Officejet 6700 hpijs, 3.13.10
    DeviceURI hp:/net/Officejet_6700?ip=192.168.1.130
    State Idle
    StateTime 1393649994
    Type 8425500
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer
    </Printer>
    <Printer Officejet_6700_fax>
    UUID urn:uuid:e65de39e-abaf-3b0a-4aa5-7117f15f64cd
    Info Officejet_6700_fax
    MakeModel HP Fax4 hpcups
    DeviceURI hpfax:/net/Officejet_6700?ip=192.168.1.130
    State Idle
    StateTime 1393340107
    Type 4108
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer
    </Printer>
    <Printer Officejet_6700_fax_2>
    UUID urn:uuid:15a61314-d010-33cd-6760-696c381aadf1
    Info 
    Location 
    MakeModel HP Fax4 hpcups
    DeviceURI hpfax:/net/Officejet_6700?ip=192.168.1.130
    State Idle
    StateTime 1393649994
    Type 4108
    Accepting Yes
    Shared Yes
    JobSheets none none
    QuotaPeriod 0
    PageLimit 0
    KLimit 0
    OpPolicy default
    ErrorPolicy stop-printer
    </Printer>
    @Knurpht I ran hp-setup and got the familiar install program. As usual, it cannot find a printer and I back up a screen to the "manual discovery" option where I enter the ip (shown above) and it finds the printer with correct driver from HP. And, I added myself to the sys group.

    @malcolm_lewis I have an HP Officejet 6700 and it works well once it is connected.

    It is after midnight here. I am going to shut down and reboot in the morning. I tried to change to static via the printer web page and HP Device Manager but there was no way to do so.

    Also, what should I do about the firewall?

    Thank you all for your help.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Printer connection doesn't survive reboot

    Quote Originally Posted by Prexy View Post
    @deano_ferrari The printer is connected now. So, I don't know if lpstat -v will tell you anything. But, here it is

    Code:
    lpstat -v
    device for Officejet_6700: hp:/net/Officejet_6700?ip=192.168.1.130
    device for Officejet_6700_fax: hpfax:/net/Officejet_6700?ip=192.168.1.130
    Yes, that tells us the printer URIs (connected or not). From that, we can see you have the printers defined via IP address.

    Although I do not have it set up by a static ip, it always comes up with that .130 even though the next highest ip is 192.168.1.6 If I read you correctly, you think I should switch to static? In the router page? yast? hp-setup?
    Configuring a static IP address lies with the device itself. As Malcolm suggested, many newer printers have an Embedded Web Server (EWS). You just enter the IP address into a browser, and it should come up.

  9. #9
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,451

    Default Re: Printer connection doesn't survive reboot

    I couldn't connect to the printer's web page because of the communication error! But, the printer has a touch screen and I set it to static ip from there. A reboot lost communications again.

    It seems to me this is a cups problem. When I sent a doc to print, the HP software tells me a print job has been sent and shortly thereafter it tells me the job is complete. But there is no printing going on. I open the HP device manager and check the status of the printer to see the printer is stopped with a pending job. When I click on the button to start the printer, I get an error box that says I don't have permission to contact the cups server. Filling in my user and password, I get an error message that I don't have sufficient privileges. Filling in root allows me to click the start printer button and the job is released and the printer works.

    My user is in both lp and sys. Going to the cups server page, I see how to add a printer but not a user. As stated earlier, I tried lppasswd -a to get sufficient privileges. Is that the wrong syntax? What should I have done?
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Printer connection doesn't survive reboot

    Hi
    I never had to add myself to any additional user groups etc for the printer here to work? Just ran hp-setup (setup via wireless) and then logged into cups as the root user. Now some wireless printers need to be setup via usb first.... If you can see the device on the network, running an nmap scan should show ports open to see what services it will use.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 5 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •