Results 1 to 9 of 9

Thread: Deepin player issue: won't start

  1. #1
    Join Date
    Feb 2014
    Location
    India
    Posts
    21

    Default Deepin player issue: won't start

    Hi community,

    I'm an average Linux user. I migrated to Suse 13.1 last month and been working around with it ever since.
    I recently installed Deepin Music player from the YaST repository.
    When I start up Deepin, it tries to load (I can tell because of the bouncy deepin icon & deepin mp in the panel) and quits after 10-15 seconds.
    Please let me know if I can provide any further info. (This is my first post, so please bear with me.)
    Will be glad if the community can shed some light on my issue.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,966

    Default Re: Deepin player issue: won't start

    When an application started from the GUI (and you did not tell which one KDE, Gnome, ....???) does not realy open a window, the first thing to do is start it from a terminal window to see if it gives any error messages.
    Henk van Velden

  3. #3
    Join Date
    Feb 2014
    Location
    India
    Posts
    21

    Default Re: Deepin player issue: won't start

    Quote Originally Posted by hcvv View Post
    When an application started from the GUI (and you did not tell which one KDE, Gnome, ....???) does not realy open a window, the first thing to do is start it from a terminal window to see if it gives any error messages.
    Thanks for the response!
    I use the 64bit KDE version.
    When i run deepin-music-player from the terminal, this block of code pops shows up:

    Code:
    ** Message: pygobject_register_sinkfunc is deprecated (GstObject)
    INFO     Loading settings...
    RuntimeError: module compiled against API version 9 but this version of numpy is 7
    Traceback (most recent call last):
      File "/usr/bin/deepin-music-player", line 266, in <module>
        DeepinMusicApp()
      File "/usr/bin/deepin-music-player", line 65, in __init__
        self.__init()
      File "/usr/bin/deepin-music-player", line 192, in __init
        self.__show_splash()
      File "/usr/bin/deepin-music-player", line 261, in __show_splash
        import widget
      File "/usr/share/deepin-music-player/src/widget/__init__.py", line 24, in <module>
        from widget.skin import app_theme
      File "/usr/share/deepin-music-player/src/widget/skin.py", line 1, in <module>
        from dtk.ui.theme import Theme, ui_theme
      File "/usr/lib/python2.7/site-packages/dtk/ui/theme.py", line 23, in <module>
        from skin_config import skin_config
      File "/usr/lib/python2.7/site-packages/dtk/ui/skin_config.py", line 23, in <module>
        from dominant_color import get_dominant_color
      File "/usr/lib/python2.7/site-packages/dtk/ui/dominant_color.py", line 29, in <module>
        import scipy.cluster
      File "/usr/lib64/python2.7/site-packages/scipy/cluster/__init__.py", line 27, in <module>
        from . import vq, hierarchy
      File "/usr/lib64/python2.7/site-packages/scipy/cluster/hierarchy.py", line 175, in <module>
        from . import _hierarchy_wrap
    ImportError: numpy.core.multiarray failed to import

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,181
    Blog Entries
    15

    Default Re: Deepin player issue: won't start

    Hi
    Is python-numpy installed?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Feb 2014
    Location
    India
    Posts
    21

    Default Re: Deepin player issue: won't start

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Is python-numpy installed?
    Hi Malcolm,

    Yes it is installed, just checked in YaST.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,181
    Blog Entries
    15

    Default Re: Deepin player issue: won't start

    Quote Originally Posted by sammysuse View Post
    Hi Malcolm,

    Yes it is installed, just checked in YaST.
    Hi
    Hmmm, what about python-scipy
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Feb 2014
    Location
    India
    Posts
    21

    Default Re: Deepin player issue: won't start

    Yes, that is installed too.
    When I tried to run deepin from the terminal, this error code showed up:

    RuntimeError: module compiled against API version 9 but this version of numpy is 7

    Can this be of any significance?

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,181
    Blog Entries
    15

    Default Re: Deepin player issue: won't start

    On Fri 28 Feb 2014 02:46:01 PM CST, sammysuse wrote:


    Yes, that is installed too.
    When I tried to run deepin from the terminal, this error code showed up:

    RUNTIMEERROR: MODULE COMPILED AGAINST API VERSION 9 BUT THIS VERSION OF
    NUMPY IS 7
    Can this be of any significance?


    Hi
    You might have to upgrade python-numpy to 1.8 then;
    http://software.opensuse.org/package/python-numpy

    Download the version for your arch (64bit) from
    the devel:languagesython repository and install that.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  9. #9
    Join Date
    Feb 2014
    Location
    India
    Posts
    21

    Default Re: Deepin player issue: won't start

    Quote Originally Posted by malcolmlewis View Post
    Hi
    You might have to upgrade python-numpy to 1.8 then;
    http://software.opensuse.org/package/python-numpy

    Download the version for your arch (64bit) from
    the devel:languagesython repository and install that.

    Yes! That solved the issue.
    I installed the python-numpy 1.8 & python-numpy-devel and deepin mp is running now.
    Thank you so much malcolm. Proud to be a part of such a helpful community.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •