Results 1 to 5 of 5

Thread: sshfs can connect from lan but cannot connect from wan

  1. #1

    Post sshfs can connect from lan but cannot connect from wan

    I have been using sshfs for a long time, but after upgrading my file server to opensuse 13.1 I cannot mount a directory on the server from outside the lan , for instance, from my house. I can use sshfs to mount the given directory from the lan which is at my office. I also use opensuse 13.1 on my home computer and it was upgraded several weeks before the office server. prior to upgrading the office machine sshfs worked from the home machine running 13.1
    I am also able to access the office server from home using ssh with no problem.

    the error is 'operation not permitted'
    so far , I have checked that I have the same user on both machines, have the group fuse with the user as a member on both machines.
    I have uninstalled and re-installed both fuse and sshfs on both machines

    I tried mounting the server with the debug option

    # sshfs -o sshfs_debug  -p 1234  /home/joe/dataSSHFS version 2.4
    fusermount: mount failed: Operation not permitted
    I do not know where to begin looking for the problem, I looked in the logs but there was nothing pertaining to this issue or I did not understand what was there.

    If someone can help point me in the right direction to look for the trouble I will be very grateful

    Thanks to everyone who is willing to help those of us with computer issues


  2. #2
    Join Date
    Mar 2010
    UTC +1

    Default Re: sshfs can connect from lan but cannot connect from wan

    Hmmm. Just a guess:

    I do not have any experience with sshfs myself, but it seems that your problem is when mounting something:
    • In 13.1 fstab (that is /etc/fstab) had some entries removed when compared with 12.3. That changed some mounting requirements and would be meaningful in your case if the mount problem is experienced when executing a script on your office computer. This script worked when the office computer had e.g. 12.3. Your upgrading the home computer wouldn't change anything in that case.
    • Also, mount itself had its syntax changed between 12.3 and 13.1, but my understanding is that it shouldn't impact mount use in general but help improve precision and flexibility - IOW: The new mount syntax is backwards compatible. Even though I do not think that the syntax change is your source of error, you may want to investigate and make use of the new improved syntax - if my guessing/suggestion of a remote script is correct.

    fstab entries and mount is connected in that entries in fstab can be used by mount to complete mount commands that otherwise would be ambiguous or inaccurate - both resulting in mount being incapable of doing a mount. However, you can do anything mount can do with the help of fstab by specifying on mount's command line all that is necessary to do. Check out mount's man page for more details (issue a 'man mount' from the command line in a terminal window).

    My suggestion is to compare the old and new fstab (if possible) on your office computer and do one of the two below, the latter being the preferred one:
    • Add the missing entries from the old fstab one at a time in the new fstab until the script start to work again. Then keep the one entry that makes the script work.
    • Debug your script and determine which mount command is failing and supply the information missing on the command line for mount to succeed where the mount is failing (info that previously probably was part of your old fstab).

    How can this be different from LAN and WAN? Hard to say without more details, but it could be as simple as there are two different scripts in use in the two cases... Like I said: I'm guessing here

    Good luck!


  3. #3
    Join Date
    Nov 2009
    West Virginia Sector 13

    Default Re: sshfs can connect from lan but cannot connect from wan

    Maybe a firewall issue??

  4. #4

    Default Re: sshfs can connect from lan but cannot connect from wan

    Thank you for responding, I am looking at the mount options and also trying to see if it is a permissions issue, My firewall is in the router and not affected by os upgrades, I have software firewall turned off.

    Will post if I find anything


  5. #5

    Thumbs up Re: sshfs can connect from lan but cannot connect from wan ( SOLVED )

    While I cannot say exactly why my laptop from home would not mount a remote file with SSHFS, I do have an idea and a solution

    I think that my sshfs files were corrupted on my home laptop. I narrowed down the problem by using another computer from home to use sshfs to mount my file server and it worked.

    I could not come up with a fix , and, I had tried unstalling sshfs and reinstalling it , so I did a new install of opensuse 13.1 from the cd using new install, DO NOT format home directory

    I had to install sshfs using software installer. then when I tried mounting the remote file server it worked.

    Thank everyone for your assistance

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts