Results 1 to 3 of 3

Thread: smartd startup missing from init.d or systemd

  1. #1
    Join Date
    Jun 2008
    Location
    Cambridge, UK
    Posts
    76

    Default smartd startup missing from init.d or systemd

    This is on opensuse 13.1x64, an install done only weeks ago.

    I was checking for smartd running and realised it wasn't.

    smartmontools-6.2-2.1.2.x86_64 is installed, there's an /etc/smartd.conf file, but there's no /etc/init.d/smartd or similar, nor a systemd configuration.



    Is this just me? I googled, then searched this sub forum and didn't find an obvious fix.

    thanks
    Paul
    --
    Cambridge geek, will code for gadgets

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,527
    Blog Entries
    15

    Default Re: smartd startup missing from init.d or systemd

    Hi
    It's there, not enable by default...
    Code:
    systemctl status smartd.service
    smartd.service - Self Monitoring and Reporting Technology (SMART) Daemon
       Loaded: loaded (/usr/lib/systemd/system/smartd.service; disabled)
       Active: inactive (dead)
    
    systemctl start smartd.service
    
    systemctl status smartd.service
    smartd.service - Self Monitoring and Reporting Technology (SMART) Daemon
       Loaded: loaded (/usr/lib/systemd/system/smartd.service; disabled)
       Active: active (running) since Thu 2014-02-27 19:58:32 CST; 1s ago
     Main PID: 15471 (smartd)
       CGroup: /system.slice/smartd.service
               └─15471 /usr/sbin/smartd -n
    
    systemctl enable smartd.service
    ln -s '/usr/lib/systemd/system/smartd.service' '/etc/systemd/system/multi-user.target.wants/smartd.service'
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Cambridge, UK
    Posts
    76

    Default Re: smartd startup missing from init.d or systemd

    oh gosh, that easy...

    I'd used "systemctl | grep smart" and not seen it, then "find /etc -name "smart*". Stupid me, I should have tried find /usr/lib/systemd -name "smart*"

    thanks very much!

    Paul
    --
    Cambridge geek, will code for gadgets

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •