Results 1 to 7 of 7

Thread: upgrade of Nvidia driver crashed Blender in 12.3

  1. #1

    Default upgrade of Nvidia driver crashed Blender in 12.3

    I'm running OpenSuse 12.3, 64 bit
    Yesterday I accepted an update to the Nvidia drivers. At the end of the day I shut down my system.
    Today, while most everything else seems to work, Blender (3-D graphics program) won't launch. I have several versions of Blender on my system NONE of them will launch, all of them worked fine before the update.

    HELP!

    nvidia go2= 304.119-31.1
    go3 = 331.49-29.1
    blender versions: 2.64a, 2.65a, 2.67b, 2.68a, 2.69
    all were working prior to update
    OpenSuse 12.3, 64 bit
    KDE 4.10.5
    HP Pavilion P6000- quad core
    16G RAM
    NVidia GeForce 210

  2. #2

    Default AW: upgrade of Nvidia driver crashed Blender in 12.3

    Quote Originally Posted by n_hand View Post
    I'm running OpenSuse 12.3, 64 bit
    Yesterday I accepted an update to the Nvidia drivers. At the end of the day I shut down my system.
    Today, while most everything else seems to work, Blender (3-D graphics program) won't launch. I have several versions of Blender on my system NONE of them will launch, all of them worked fine before the update.

    HELP!
    Please post the file /var/log/Xorg.0.log via http://susepaste.org.

    And the output of the following please:
    Code:
    rpm -qa | egrep "(kernel|nvidia)"
    uname -a
    glxinfo | grep render
    For the last one to work you need to have "Mesa-demo-x" installed. So install it if it isn't already.

  3. #3

    Default Re: AW: upgrade of Nvidia driver crashed Blender in 12.3

    Quote Originally Posted by wolfi323 View Post
    Please post the file /var/log/Xorg.0.log via http://susepaste.org.

    And the output of the following please:
    Code:
    rpm -qa | egrep "(kernel|nvidia)"
    uname -a
    glxinfo | grep render
    For the last one to work you need to have "Mesa-demo-x" installed. So install it if it isn't already.
    I posted the log under name=NancyHand var.log

    output of the commands:

    Code:
    ######:~> rpm -qa | egrep "(kernel|nvidia)"
    kernel-desktop-3.7.10-1.28.1.x86_64
    kernel-source-3.7.10-1.4.1.noarch
    kernel-source-3.7.10-1.24.1.noarch
    kernel-source-3.7.10-1.11.1.noarch
    nvidia-computeG03-331.49-29.1.x86_64
    kernel-syms-3.7.10-1.28.1.x86_64
    kernel-xen-devel-3.7.10-1.4.1.x86_64
    kernel-syms-3.7.10-1.24.1.x86_64
    kernel-xen-devel-3.7.10-1.11.1.x86_64
    kernel-xen-devel-3.7.10-1.1.1.x86_64
    kernel-default-devel-3.7.10-1.16.1.x86_64
    kernel-devel-3.7.10-1.1.1.noarch
    kernel-source-3.7.10-1.28.1.noarch
    kernel-desktop-3.7.10-1.4.1.x86_64
    x11-video-nvidiaG03-331.49-29.1.x86_64
    kernel-desktop-3.7.10-1.16.1.x86_64
    kernel-default-devel-2.6.37.6-24.1.x86_64
    nvidia-gfxG03-kmp-desktop-331.49_k3.7.10_1.1-29.1.x86_64
    kernel-default-devel-3.7.10-1.28.1.x86_64
    kernel-source-3.7.10-1.16.1.noarch
    nvidia-gfxG02-kmp-desktop-304.119_k3.7.10_1.1-30.1.x86_64
    kernel-devel-3.7.10-1.4.1.noarch
    kernel-desktop-2.6.37.6-24.1.x86_64
    kernel-syms-2.6.37.6-24.1.x86_64
    kernel-xen-devel-3.7.10-1.24.1.x86_64
    kernel-syms-3.7.10-1.11.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.108_k3.7.10_1.1-31.1.x86_64
    nvidia-computeG02-304.119-31.1.x86_64
    kernel-default-devel-3.7.10-1.24.1.x86_64
    kernel-desktop-devel-2.6.37.6-24.1.x86_64
    nvidia-glG03-331.49-29.1.x86_64
    kernel-firmware-20130714git-1.9.1.noarch
    kernel-devel-3.7.10-1.28.1.noarch
    kernel-xen-devel-3.7.10-1.28.1.x86_64
    kernel-default-devel-3.7.10-1.4.1.x86_64
    kernel-syms-3.7.10-1.4.1.x86_64
    kernel-desktop-3.7.10-1.24.1.x86_64
    nvidia-gfxG03-kmp-desktop-331.38_k3.7.10_1.1-23.1.x86_64
    kernel-devel-3.7.10-1.16.1.noarch
    kernel-xen-devel-3.7.10-1.16.1.x86_64
    kernel-default-devel-3.7.10-1.1.1.x86_64
    kernel-devel-2.6.37.6-24.1.noarch
    kernel-desktop-3.7.10-1.1.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.88_k3.7.10_1.1-25.1.x86_64
    kernel-default-devel-3.7.10-1.11.1.x86_64
    x11-video-nvidiaG02-304.119-31.1.x86_64
    kernel-source-3.7.10-1.1.1.noarch
    kernel-syms-3.7.10-1.16.1.x86_64
    kernel-source-2.6.37.6-24.1.noarch
    kernel-desktop-devel-3.7.10-1.28.1.x86_64
    kernel-xen-devel-2.6.37.6-24.1.x86_64
    kernel-desktop-devel-3.7.10-1.4.1.x86_64
    kernel-devel-3.7.10-1.24.1.noarch
    kernel-desktop-devel-3.7.10-1.11.1.x86_64
    kernel-desktop-devel-3.7.10-1.16.1.x86_64
    nvidia-gfxG02-kmp-desktop-304.117_k3.7.10_1.1-28.1.x86_64
    kernel-desktop-devel-3.7.10-1.24.1.x86_64
    kernel-devel-3.7.10-1.11.1.noarch
    kernel-syms-3.7.10-1.1.1.x86_64
    kernel-desktop-3.7.10-1.11.1.x86_64
    kernel-desktop-devel-3.7.10-1.1.1.x86_64
    
    
    ######:~> uname -a
    Linux linux-wcaf.site 3.7.10-1.28-desktop #1 SMP PREEMPT Mon Feb 3 14:11:15 UTC 2014 (c9a2c6c) x86_64 x86_64 x86_64 GNU/Linux   
    
    ######:~> glxinfo | grep render
    Xlib:  extension "GLX" missing on display ":0".
    Xlib:  extension "GLX" missing on display ":0".
    Xlib:  extension "GLX" missing on display ":0".
    Xlib:  extension "GLX" missing on display ":0".
    Xlib:  extension "GLX" missing on display ":0".
    Error: couldn't find RGB GLX visual or fbconfig
    Xlib:  extension "GLX" missing on display ":0".  - this line repeats another 50+ times

  4. #4

    Default Re: upgrade of Nvidia driver crashed Blender in 12.3

    On 02/27/2014 09:46 PM, n hand pecked at the keyboard and wrote:
    > wolfi323;2627536 Wrote:
    >> Please post the file /var/log/Xorg.0.log via http://susepaste.org.
    >>
    >> And the output of the following please:

    > Code:
    > --------------------
    > > > rpm -qa | egrep "(kernel|nvidia)"

    > > uname -a
    > > glxinfo | grep render

    > --------------------
    >> For the last one to work you need to have "Mesa-demo-x" installed. So
    >> install it if it isn't already.

    > I posted the log under name=NancyHand var.log
    >
    > output of the commands:
    >
    >
    > Code:
    > --------------------
    > nvidia-computeG03-331.49-29.1.x86_64


    > x11-video-nvidiaG03-331.49-29.1.x86_64


    > nvidia-gfxG03-kmp-desktop-331.49_k3.7.10_1.1-29.1.x86_64


    > nvidia-gfxG02-kmp-desktop-304.119_k3.7.10_1.1-30.1.x86_64
    > nvidia-gfxG02-kmp-desktop-304.108_k3.7.10_1.1-31.1.x86_64
    > nvidia-computeG02-304.119-31.1.x86_64
    > nvidia-glG03-331.49-29.1.x86_64
    > nvidia-gfxG03-kmp-desktop-331.38_k3.7.10_1.1-23.1.x86_64
    > nvidia-gfxG02-kmp-desktop-304.88_k3.7.10_1.1-25.1.x86_64
    > x11-video-nvidiaG02-304.119-31.1.x86_64
    > nvidia-gfxG02-kmp-desktop-304.117_k3.7.10_1.1-28.1.x86_64
    >


    You have two Nvidia drivers installed (G02 & G03), I suggest you remove
    one of them as having two installed can cause problems.

    Ken

  5. #5

    Default Re: upgrade of Nvidia driver crashed Blender in 12.3

    Quote Originally Posted by n_hand View Post
    I posted the log under name=NancyHand var.log
    The next time please post a link, this would make it easier to find...

    Code:
     ######:~> glxinfo | grep render
    
     Xlib:  extension "GLX" missing on display ":0".
    
     Xlib:  extension "GLX" missing on display ":0".
    
     Xlib:  extension "GLX" missing on display ":0".
    
     Xlib:  extension "GLX" missing on display ":0".
    
     Xlib:  extension "GLX" missing on display ":0".
    
     Error: couldn't find RGB GLX visual or fbconfig
    
     Xlib:  extension "GLX" missing on display ":0".  - this line repeats another 50+ times
    As you can see here, GLX is not working and that causes blender to crash.
    And the reason is this:
    Code:
    [    21.338] (EE) NVIDIA(0): Version mismatch detected between the NVIDIA X driver and the
    [    21.338] (EE) NVIDIA(0):     NVIDIA GLX module.  X driver version: 331.49; GLX module
    [    21.338] (EE) NVIDIA(0):     version: 304.119.  Please try reinstalling the NVIDIA
    [    21.338] (EE) NVIDIA(0):     driver.
    ...
    [    22.109] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    Quote Originally Posted by kensch View Post
    On 02/27/2014 09:46 PM, n hand pecked at the keyboard and wrote:
    > wolfi323;2627536 Wrote:
    >> Please post the file /var/log/Xorg.0.log via http://susepaste.org.
    >>
    >> And the output of the following please:

    > Code:
    > --------------------
    > > > rpm -qa | egrep "(kernel|nvidia)"

    > > uname -a
    > > glxinfo | grep render

    > --------------------
    >> For the last one to work you need to have "Mesa-demo-x" installed. So
    >> install it if it isn't already.

    > I posted the log under name=NancyHand var.log
    >
    > output of the commands:
    >
    >
    > Code:
    > --------------------
    > nvidia-computeG03-331.49-29.1.x86_64


    > x11-video-nvidiaG03-331.49-29.1.x86_64


    > nvidia-gfxG03-kmp-desktop-331.49_k3.7.10_1.1-29.1.x86_64


    > nvidia-gfxG02-kmp-desktop-304.119_k3.7.10_1.1-30.1.x86_64
    > nvidia-gfxG02-kmp-desktop-304.108_k3.7.10_1.1-31.1.x86_64
    > nvidia-computeG02-304.119-31.1.x86_64
    > nvidia-glG03-331.49-29.1.x86_64
    > nvidia-gfxG03-kmp-desktop-331.38_k3.7.10_1.1-23.1.x86_64
    > nvidia-gfxG02-kmp-desktop-304.88_k3.7.10_1.1-25.1.x86_64
    > x11-video-nvidiaG02-304.119-31.1.x86_64
    > nvidia-gfxG02-kmp-desktop-304.117_k3.7.10_1.1-28.1.x86_64
    >


    You have two Nvidia drivers installed (G02 & G03), I suggest you remove
    one of them as having two installed can cause problems.
    That's right, but better remove _both_ and then install only the G03 one:
    Code:
    sudo zypper rm nvidia-gfxG02-kmp-desktop x11-video-nvidiaG02 nvidia-computeG02 nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-computeG03 nvidia-glG03
    sudo zypper in nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-computeG03 nvidia-glG03
    To elaborate a bit more:
    The G02 and the G03 driver packages contain the same files but in different versions (of course).
    If you have both installed, they overwrite each others files, so the result can be a not-working mixture of versions (depending on the order in which the packages get installed).

    This is actually a bug/missing feature in libzypp (the package management system) which has been fixed recently. The latest one in Factory now checks if there are file conflicts and reports an error in this case.
    So, something like this should not happen anymore in 13.2. (no idea whether this update will get released for 12.3/13.1 as well though)
    Last edited by wolfi323; 28-Feb-2014 at 03:07.

  6. #6

    Default Re: upgrade of Nvidia driver crashed Blender in 12.3

    As you can see here, GLX is not working and that causes blender to crash.
    And the reason is this:
    Code:
    [    21.338] (EE) NVIDIA(0): Version mismatch detected between the NVIDIA X driver and the
    [    21.338] (EE) NVIDIA(0):     NVIDIA GLX module.  X driver version: 331.49; GLX module
    [    21.338] (EE) NVIDIA(0):     version: 304.119.  Please try reinstalling the NVIDIA
    [    21.338] (EE) NVIDIA(0):     driver.
    ...
    [    22.109] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

    That's right, but better remove _both_ and then install only the G03 one:
    Code:
    sudo zypper rm nvidia-gfxG02-kmp-desktop x11-video-nvidiaG02 nvidia-computeG02 nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-computeG03 nvidia-glG03
    sudo zypper in nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-computeG03 nvidia-glG03
    [/QUOTE]

    THANK YOU! Thank you! Thank you! Blender is working again!

    obviously - a little knowledge is a dangerous thing

  7. #7

    Default Re: upgrade of Nvidia driver crashed Blender in 12.3

    On 02/28/2014 07:36 PM, n hand pecked at the keyboard and wrote:
    > As you can see here, GLX is not working and that causes blender to
    > crash.
    > And the reason is this:
    >
    > Code:
    > --------------------
    > [ 21.338] (EE) NVIDIA(0): Version mismatch detected between the NVIDIA X driver and the
    > [ 21.338] (EE) NVIDIA(0): NVIDIA GLX module. X driver version: 331.49; GLX module
    > [ 21.338] (EE) NVIDIA(0): version: 304.119. Please try reinstalling the NVIDIA
    > [ 21.338] (EE) NVIDIA(0): driver.
    > ...
    > [ 22.109] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
    > --------------------
    >
    >
    >
    > That's right, but better remove _both_ and then install only the G03
    > one:
    >
    > Code:
    > --------------------
    > sudo zypper rm nvidia-gfxG02-kmp-desktop x11-video-nvidiaG02 nvidia-computeG02 nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-computeG03 nvidia-glG03
    > sudo zypper in nvidia-gfxG03-kmp-desktop x11-video-nvidiaG03 nvidia-computeG03 nvidia-glG03
    > --------------------
    >
    >
    >
    >
    > THANK YOU! Thank you! Thank you! Blender is working again!
    >
    > obviously - a little knowledge is a dangerous thing
    >
    >


    Glad you got it sorted. I always tell people that I know just enough to
    be dangerous. :-)

    Ken

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •