Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

  1. #1

    Default Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    HI,

    Finally got Opensuse to work from a Live CD from a magazine.

    I have changed the display using the gamma settings - even system wide with root password - yet when the pc is started from cold next day the settings have reverted.

    This is KDE also.

    Any ideas - can i manually chnage for permanent setting of gamma requirements - or are these settings updated to default after a reboot ?.

    Thanks and regards,

    Shadders.

  2. #2

    Default Re: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    Hi,

    Opensuse 13.1 seems to be reverting to the original gamma settings.

    I searched for gamma in the file system and located my home directory settings which do change.

    /home/user/.kde4/share/config/kgammarc

    This seems to be the global setting which is changing when i use the desktop access to change, but is reverting to a default, even when selecting system wide setting previously and saving.

    Any ideas on how to resolve ?.

    Thanks and regards,

    Shadders.

  3. #3

    Default Re: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    Hi,

    In searching this seems to be a bug that has crept back into to KDE

    https://bugzilla.redhat.com/show_bug.cgi?id=139942

    Regards,

    Shadders.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    Did you notice the date on that bug report. A bit old I'd say

    Also though you can use a xorg.conf file that is not required any more.

    So tell use what video card and what driver??

  5. #5

    Default Re: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    Hi,

    Thanks for the reply.

    It is a Dell 660 and Intel Core i5 3330 with internal Intel graphics, driver i915.

    So i assume that i need to locate the correct configuration file and modify manually ?

    Thanks and regards,

    Shadders.

  6. #6

    Default Re: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    I guess the problem is that apparently xf86gammacfg doesn't work at all:
    Code:
    xf86gammacfg .9 .9 .9
    Usage: xf86gammacfg RGAMMA GGAMMA BGAMMA [RGAMMA GGAMMA BGAMMA [...]]
    Probably because it doesn't find the xorg.conf.

    Quote Originally Posted by shadders View Post
    So i assume that i need to locate the correct configuration file and modify manually ?
    This would be a possibility, yes.

    You should add the "Gamma" option to the "Monitor" section.
    To do that without an xorg.conf, create a file /etc/X11/xorg.conf.d/50-mymonitor.conf (or edit the existing /etc/X11/xorg.conf.d/50-monitor.conf) like this:
    Code:
    Section "Monitor"
      Identifier "Default Monitor"
      Gamma 1.0 1.0 1.0
    EndSection
    You should specify your desired values there of course, you can either use one value or 3 values.
    From "man xorg.conf":
    Code:
           Gamma  gamma-value
    
           Gamma  red-gamma green-gamma blue-gamma
    
                  This is an optional entry that can be used to specify the  gamma
                  correction  for  the  monitor.   It may be specified as either a
                  single value or as three separate RGB values.  The values should
                  be  in  the  range 0.1 to 10.0, and the default is 1.0.  Not all
                  drivers are capable of using this information.
    Then you also need to reference this from a "Screen" section, so create /etc/X11/xorg.conf.d/50-myscreen.conf (or edit the existing /etc/X11/xorg.conf.d/50-screen.conf) like this:
    Code:
    Section "Screen"
      Identifier "Default Screen"
      Device "Default Device"
      Monitor "Default Monitor"
    EndSection
    Last edited by wolfi323; 01-Mar-2014 at 02:58.

  7. #7

    Default Re: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    Quote Originally Posted by wolfi323 View Post
    I guess the problem is that apparently xf86gammacfg doesn't work at all:
    Code:
    xf86gammacfg .9 .9 .9
    Usage: xf86gammacfg RGAMMA GGAMMA BGAMMA [RGAMMA GGAMMA BGAMMA [...]]
    Probably because it doesn't find the xorg.conf.
    I verified that the missing xorg.conf is the reason for xf86gammacfg to not work.

    If you create an xorg.conf (with "X --configure" f.e.) xfgammacfg correctly adds that "Gamma" option there:
    Code:
       Gamma   .9  .9  .9  # created by KGamma
    So either edit xorg.conf.d files manually like explained in the previous post, or create an xorg.conf and use KDE's settings module.

    PS: You can set the gamma value with xrandr as well. But this does only apply for the current session then of course.
    Last edited by wolfi323; 01-Mar-2014 at 03:09.

  8. #8

    Default Re: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    Hi wolfi323

    Thank you for this information - i checked the KDE web pages - but it was not there.

    I edited the 50-monitor.conf file - seemed to be fully commented out - so i added the relevant section at the end.

    I will reboot the PC later to ensure that it has worked.

    Thanks again for this - much appreciated.

    Regards,

    Shadders.

  9. #9

    Default Re: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    Quote Originally Posted by shadders View Post
    I edited the 50-monitor.conf file - seemed to be fully commented out - so i added the relevant section at the end.

    I will reboot the PC later to ensure that it has worked.
    But you need a "Screen" section as well, see my previous post.

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Opensuse 132.1 Display Gamma Settings Not Saving after reboot

    Generally you can adjust gamma at the monitor itself.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •