Results 1 to 7 of 7

Thread: Latest update breaks Broadcom BCM43227?

  1. #1

    Default Latest update breaks Broadcom BCM43227?

    Have had an Acer laptop with this chipset running 13.1 happily for many months, .. suddenly last week Network Manager [Gnome] no longer sees a wireless adapter and no device shows in ifconfig, even though the driver shows installed.

    I suspect the last set of updates broke something? The installed broadcom-wl shows 5.100.82.112-78 and does not appear to have changed, .. the BCM57780 GigE adapter works fine.

    Thanks!

    Lee

  2. #2

    Default Re: Latest update breaks Broadcom BCM43227?

    Quote Originally Posted by omnitec View Post
    Have had an Acer laptop with this chipset running 13.1 happily for many months, .. suddenly last week Network Manager [Gnome] no longer sees a wireless adapter and no device shows in ifconfig, even though the driver shows installed.

    I suspect the last set of updates broke something? The installed broadcom-wl shows 5.100.82.112-78 and does not appear to have changed, .. the BCM57780 GigE adapter works fine.
    The most likely cause for this would be the kernel update.

    Maybe you just need to update the broadcom-wl-kmp-xxx package, but this should have happened automatically as well.
    Do you actually have the Packman repo added to your system?
    Code:
    zypper lr -d
    OTOH the Packman repo only contains broadcom-wl-6.30.223.141-2.7, so how did you actually install it in the first place?

    Which kernel and broadcom-wl packages do you have installed?
    Code:
    rpm -qa | egrep "(kernel|broadcom)"
    Does it work if you boot to the older kernel ("Advanced Options" in the boot menu)?

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: Latest update breaks Broadcom BCM43227?

    Quote Originally Posted by omnitec View Post
    Have had an Acer laptop with this chipset running 13.1 happily for many months, .. suddenly last week Network Manager [Gnome] no longer sees a wireless adapter and no device shows in ifconfig, even though the driver shows installed.

    I suspect the last set of updates broke something? The installed broadcom-wl shows 5.100.82.112-78 and does not appear to have changed, .. the BCM57780 GigE adapter works fine.
    You should be able to boot with the older kernel. On the boot menu, select the "Advanced options" line. You should have a choice between:
    1. boot with kernel 3.11.10-7
    2. boot with 3.11.10-7 (recovery mode)
    3. boot with 3.11.6-4
    4. boot with 3.11.6-4 (recovery mode)

    You want the third of those. You should be able to use WiFi when booted to that kernel.

    I have a 13.1 system using broadcom-wl. It did update the driver, and is working fine with the newer kernel. I'm pretty sure that I used Yast online update, though my memory might be faulty. It offered to update the broadcom-wl driver.

    In any case, the updated driver is in the packman repo. If the repo is properly configured, you should be able to go to Yast online updates, and install the updated driver. You will have to do that while running the older kernel, since you don't have network access with the newer kernel.

    How did you install opensuse?

    I ask, because I earlier installed the opensuse linux for education "openSUSE-Edu-li-f-e.i686-13.1.1.iso". That used the broadcom-wl driver, but did not configure the packman repo. It would have had exactly the same problem. Since then, I replaced that with an install of the 64bit version "openSUSE-Edu-li-f-e.x86_64-13.1.1.iso" which did configure the packman repo (maybe they read the complaint on my blog). And that's the one that update successfully.

    You can check which repos you have configured with Yast --> Software Repositories

    I've just booted my system that uses broadcom-wl. I notice that it has installed two versions of broadcom-wl-kmp-desktop, one for each kernel. If you happen to instead be using the "default" terminal, you would instead want to look for broadcom-wl-kmp-default.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4

    Default Re: Latest update breaks Broadcom BCM43227?

    I had originally pulled it from ludmiloff, ..

    Code:
    # zypper lr
    # | Alias                     | Name                               | Enabled | Refresh
    --+---------------------------+------------------------------------+---------+--------
    1 | home:ludmiloff            | home:ludmiloff                     | Yes     | Yes    
    2 | repo-debug                | openSUSE-13.1-Debug                | No      | Yes    
    3 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | Yes    
    4 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes    
    5 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes    
    6 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes    
    7 | repo-source               | openSUSE-13.1-Source               | No      | Yes    
    8 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes    
    9 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes
    Tried to install broadcom-wl-kmp-default, but it failed:

    Problem: nothing provides ksym(default:warn_slowpath_null) = 16305289 needed by broadcom-wl-kmp-default-5.100.82.112_k3.7.10_1.1-78.x86_64

    Will try a reboot and report shortly.

    Thanks!

    Lee

  5. #5

    Default Re: Latest update breaks Broadcom BCM43227?

    The 3.11.6-4-desktop kernel *DOES* work, .. so the problem definitely lies with the 3.11.10-7-desktop kernel update.

    Can I assist in troubleshooting, .. or should I just stay on this kernel for a while?

    Thanks!

    Lee

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: Latest update breaks Broadcom BCM43227?

    Quote Originally Posted by omnitec View Post
    The 3.11.6-4-desktop kernel *DOES* work, .. so the problem definitely lies with the 3.11.10-7-desktop kernel update.

    Can I assist in troubleshooting, .. or should I just stay on this kernel for a while?

    Thanks!

    Lee
    I suggest that you add the packman repo.

    Start Yast. Click on "Software Repositories"

    It will show a list of repos.

    Click the "Add" button near the bottom.

    Check the box "Community Repositories", then click "Next".

    The list should show the "packman" repo. (I am not seeing it when I check, but that's probably because I already have that repo configured). Check the box. Then follow the obvious steps to proceed.

    Once that is done, start Yast Software management, and search for "broadcom-wl". Look for the "broadcom-wl-kmp" line(s).
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: Latest update breaks Broadcom BCM43227?

    Quote Originally Posted by nrickert View Post
    Once that is done, start Yast Software management, and search for "broadcom-wl". Look for the "broadcom-wl-kmp" line(s).
    And don't forget to install "broadcom-wl" itself as well.

    Btw, I just noticed that that home:ludmilloff repo is not even available for openSUSE 13.1. So you should remove it in any case.
    And then update both "broadcom-wl" and "broadcom-wl-kmp-desktop" to the Packman version 6.30.223.141 (you might have to choose "Update Unconditionally" in the right-click menu).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •