Results 1 to 6 of 6

Thread: MAILMAN not showing

  1. #1

    Question MAILMAN not showing

    Hey guys,

    I'm trying to setup Mailman on my OpenSUSE 12.3, I'm following these steps:


    1. Install mailman
    2. run 'a2enflag MAILMAN'
    3. Restart Apache


    But I keep getting a 404 page not found when I go to http://localhost/mailman

    I checked /etc/apache2/conf.d/mailman.conf and it has this:

    Code:
    # the <IfDefine MAILMAN> block means that the contained configuration is not
    # active unless apache is started with '-D MAILMAN'. This server flag
    # is passed at start time if it is set in /etc/sysconfig/apache2 -- which can
    # be set by running the command 'a2enflag MAILMAN'.
    
    <IfDefine MAILMAN>
    
    ScriptAlias     /mailman/       /usr/lib/mailman/cgi-bin/
    Alias           /mailmanicons/  /usr/lib/mailman/icons/
    Alias           /pipermail/     /var/lib/mailman/archives/public/
    
    <Directory /usr/lib/mailman/cgi-bin>
            order allow,deny
            allow from all
    </Directory>
    
    <Directory /usr/lib/mailman/icons>
            order allow,deny
            allow from all
    </Directory>
    
    <Directory /var/lib/mailman/archives/>
            Options +FollowSymLinks
            order allow,deny
            allow from all
    </Directory>
    
    </IfDefine>
    I checked the status of Apache and it shows this:

    Code:
    apache2.service - apache
              Loaded: loaded (/lib/systemd/system/apache2.service; enabled)
              Active: active (running) since Tue, 2014-02-25 15:39:55 EST; 5min ago
             Process: 13465 ExecStop=/usr/sbin/httpd2 -D SYSTEMD -k stop (code=exited, status=0/SUCCESS)
             Process: 11842 ExecReload=/bin/kill -HUP $MAINPID (code=exited, status=0/SUCCESS)
             Process: 11822 ExecReload=/usr/sbin/start_apache2 -D SYSTEMD -t (code=exited, status=0/SUCCESS)
             Process: 13469 ExecStart=/usr/sbin/start_apache2 -D SYSTEMD -k start (code=exited, status=0/SUCCESS)
            Main PID: 13488 (/usr/sbin/httpd)
              CGroup: name=systemd:/system/apache2.service
                      ├ 13488 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL -DMAILMAN -D SYSTEMD -k start
                      ├ 13490 /usr/bin/mono /usr/lib/mono/2.0/mod-mono-server2.exe --filename /tmp/mod_mono_server_global --nonstop --maste...
                      ├ 13491 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL -DMAILMAN -D SYSTEMD -k start
                      ├ 13499 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL -DMAILMAN -D SYSTEMD -k start
                      ├ 13502 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL -DMAILMAN -D SYSTEMD -k start
                      ├ 13503 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL -DMAILMAN -D SYSTEMD -k start
                      ├ 13504 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL -DMAILMAN -D SYSTEMD -k start
                      └ 13509 /usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf -DSSL -DMAILMAN -D SYSTEMD -k start
    Which tells me that MAILMAN is defined so it should be working.

    Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: MAILMAN not showing

    Mybe I am wrong, but when your URL is http://localhost/mailman and your congig says
    Code:
    ScriptAlias     /mailman/       /usr/lib/mailman/cgi-bin/
    that means imho that Apache will look into the directory /usr/lib/mailman/cgi-bin/.

    I can not find in your post any proof that
    1. that directory does exist;
    2. that that directory contains any file that Apache would serve as default (you not specifying any file in the URL).
    Henk van Velden

  3. #3

    Default Re: MAILMAN not working

    More info:

    I also followed the install steps from:

    http://en.opensuse.org/Mailman

    I created a list using /usr/lib/mailman/bin/newlist mailman but I get this when I try to start the daemon:

    Starting mailmanSite list is missing mailman

    And it fails.

    Any ideas?

  4. #4

    Default Re: MAILMAN not showing

    Quote Originally Posted by hcvv View Post
    Mybe I am wrong, but when your URL is http://localhost/mailman and your congig says
    Code:
    ScriptAlias     /mailman/       /usr/lib/mailman/cgi-bin/
    that means imho that Apache will look into the directory /usr/lib/mailman/cgi-bin/.

    I can not find in your post any proof that
    1. that directory does exist;
    2. that that directory contains any file that Apache would serve as default (you not specifying any file in the URL).
    The folder exist, it contains:

    admin
    admindb
    confirm
    create
    editarch
    edithtml
    listinfo
    options
    private
    rmlist
    roster
    subscribe

    They are scripts, not HTML files, but since the mailman daemon is not starting I don't think this the reason why.

  5. #5

    Default Re: MAILMAN not showing

    Never mind, I found the problem, I added add_virtualhost('localhost','localhost') to /usr/lib/mailman/Mailman/mm_cfg.py, then I went to http://localhost/mailman/create, created mailman, started the service and this time it came up.

    I also learned that the URL to visit is http://localhost/mailman/admin, not just http://localhost/mailman

    Thanks anyway.

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: MAILMAN not showing

    Quote Originally Posted by jurgen73 View Post
    Never mind, I found the problem, I added add_virtualhost('localhost','localhost') to /usr/lib/mailman/Mailman/mm_cfg.py, then I went to http://localhost/mailman/create, created mailman, started the service and this time it came up.
    Thank you for reporting how you managed. It may help others.
    Quote Originally Posted by jurgen73 View Post
    I also learned that the URL to visit is http://localhost/mailman/admin, not just http://localhost/mailman
    That is what I tried to find out. You have to specify a file, either explicit (like you do now), or implicit (like you did earlier). But in the last case, that implicit file (like index.html) should be there.

    BTW, please next time when you report the existence and contents of a directory (or any other comupter text), please do so by copy/past from the terminal of prompt, command, output and next prompt between CODE tags in a post here. You get the CODE tags by clicking on the # button in the tool bar of the post editor.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •