Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: wine virtual desktop in 1.7.13-329

  1. #1

    Default wine virtual desktop in 1.7.13-329

    It doesn't seem to work properly, application windows escape the virtual desktop border regardless of settings.
    I tried switching registry settings for wm decoration, wm control and it still doesn't work as expected.
    1.7.2 from oss repo works fine, they never leave the desktop border.

  2. #2

    Default Re: wine virtual desktop in 1.7.13-329

    What do you mean by "escape"? Can you post a screenshot?

  3. #3

    Default Re: wine virtual desktop in 1.7.13-329

    Quote Originally Posted by dimesio View Post
    What do you mean by "escape"? Can you post a screenshot?
    I would post one, but I had downgraded to 1.7.2 where it doesn't happen.
    I'll make an example with some gimp magic - image

    On the left, winecfg window behaves correctly, draws within virtual desktop limits.
    On the right, it doesn't respect the border, and draws outside the virtual desktop.

  4. #4

    Default Re: wine virtual desktop in 1.7.13-329

    Quote Originally Posted by finders View Post
    I would post one, but I had downgraded to 1.7.2 where it doesn't happen.
    I'll make an example with some gimp magic - image

    On the left, winecfg window behaves correctly, draws within virtual desktop limits.
    On the right, it doesn't respect the border, and draws outside the virtual desktop.
    I don't see any virtual desktop at all in the image you created.

    FWIW, I am not having any problems with the virtual desktop on my system in 1.7.13.

  5. #5

    Default Re: wine virtual desktop in 1.7.13-329

    Quote Originally Posted by dimesio View Post
    I don't see any virtual desktop at all in the image you created.

    FWIW, I am not having any problems with the virtual desktop on my system in 1.7.13.
    Sorry, I forced decoration off in kwin settings, but it does happen with or without the decoration.
    In 1.7.2 there's no way to move a window outside the border, while in 1.7.13 it acts like this.

  6. #6

    Default Re: wine virtual desktop in 1.7.13-329

    What window manager are you using, and have you tried disabling desktop effects?

  7. #7

    Default Re: wine virtual desktop in 1.7.13-329

    I have tried it under xfwm, kwin, openbox and lxdm. Also tried different decoration settings inside winecfg.
    Switching kwin effects on doesn't make it any better, but I normally keep them disabled.

  8. #8

    Default Re: wine virtual desktop in 1.7.13-329

    I'm using kwin, with desktop effects disabled, and I can't reproduce the problem. Have you tried a clean wineprefix? Other than that, I don't know what else to suggest.

  9. #9

    Default Re: wine virtual desktop in 1.7.13-329

    It's downloading some huge packages right now, not sure I want to interrupt it.
    But I will download 1.7.13 again, make a clean kde profile and a new prefix as soon as it's finished, to see if it happens again.
    The problem showed up right after updating default wineprefix post upgrade, then temporarily went away after setting Decorated REG_SZ "N" and Managed REG_SZ "N"
    After running winecfg and wine regedit couple of times, the problem showed up again. Then I decided to downgrade, which made it go away permanently.

  10. #10

    Default Re: wine virtual desktop in 1.7.13-329

    Ok, I did a clean prefix, clean kde user and it worked for a short while.
    As soon as I opened winecfg a couple of times in a row, it started again.

    image

    Some info that could be relevant:

    openSUSE 13.1 - 3.11.10-7-desktop x86_64
    KDE 4.11.5
    nvidia binary 331.49
    wine - 1.7.13-329.1 i586
    wine-gecko - 2.24-43.1 noarch
    xorg-x11-server - 7.6_1.14.3.901-4.1 x86_64

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •