Results 1 to 10 of 10

Thread: Syncing to public time server is always 4-5 minutes slow

  1. #1

    Default Syncing to public time server is always 4-5 minutes slow

    I have my clock set to sync with "Public Time Server (pool.ntp.org)". It is always 4-5 minute behind. The odd piece:

    * If I switch which server I am syncing with, the time will show correctly right after

    * After a while (or on reboot) it will show 4-5 minutes slow

    This happens no matter which public server I sync with. I switch back and forth and this still occurs.

  2. #2
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Syncing to public time server is always 4-5 minutes slow

    On 2/24/2014 3:06 PM, 6tr6tr wrote:
    >
    > I have my clock set to sync with "Public Time Server (pool.ntp.org)". It
    > is always 4-5 minute behind. The odd piece:
    >
    > * If I switch which server I am syncing with, the time will show
    > correctly right after
    >
    > * After a while (or on reboot) it will show 4-5 minutes slow
    >
    > This happens no matter which public server I sync with. I switch back
    > and forth and this still occurs.
    >
    >

    When the clock is slow, what is the result of:
    Code:
    /usr/sbin/ntpq -p
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  3. #3

    Default Re: Syncing to public time server is always 4-5 minutes slow

    Quote Originally Posted by venzkep View Post
    On 2/24/2014 3:06 PM, 6tr6tr wrote:
    >
    > I have my clock set to sync with "Public Time Server (pool.ntp.org)". It
    > is always 4-5 minute behind. The odd piece:
    >
    > * If I switch which server I am syncing with, the time will show
    > correctly right after
    >
    > * After a while (or on reboot) it will show 4-5 minutes slow
    >
    > This happens no matter which public server I sync with. I switch back
    > and forth and this still occurs.
    >
    >

    When the clock is slow, what is the result of:
    Code:
    /usr/sbin/ntpq -p
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green
    Code:
    /usr/sbin/ntpq: read: Connection refused
    what does that mean?

  4. #4
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Syncing to public time server is always 4-5 minutes slow

    On 2/26/2014 7:56 PM, 6tr6tr wrote:
    >
    > venzkep;2627038 Wrote:

    <snip>
    >>>
    >>>

    >> When the clock is slow, what is the result of:
    >>>

    > Code:
    > --------------------
    > > >

    > > /usr/sbin/ntpq -p
    > >

    > --------------------
    >>>

    >>
    >> --
    >> P.V.
    >> "We're all in this together, I'm pulling for you" Red Green

    >
    >
    > Code:
    > --------------------
    > /usr/sbin/ntpq: read: Connection refused
    > --------------------
    >
    > what does that mean?
    >
    >

    This sounds like ntp is not running. What is the result of:
    Code:
    systemctl status ntp.service
    If it is not running, try setting the time to something close to the correct time (YaST or the date command) and then
    execute:
    [code]
    systemctl start ntp.service
    [code]

    You can check /var/log/ntp to see if anything interesting is logged.

    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  5. #5

    Default Re: Syncing to public time server is always 4-5 minutes slow

    Quote Originally Posted by venzkep View Post
    This sounds like ntp is not running. What is the result of:
    Code:
    systemctl status ntp.service
    Code:
    ntp.service - LSB: Network time protocol daemon (ntpd)
              Loaded: loaded (/etc/init.d/ntp)
              Active: inactive (dead)
              CGroup: name=systemd:/system/ntp.service
    Quote Originally Posted by venzkep View Post
    If it is not running, try setting the time to something close to the correct time (YaST or the date command) and then
    This might be the problem! There are two different places to set the date/time and they're done differently!

    1. Right click on the clock (on taskbar) and choose "Adjust Date and Time". I have this set to "set date and time automatically" with "pool.ntp.org".

    2. YAST->Date and Time. This was set to "manually", NOT ntp. (However, after choosing NTP, the clock is still 4 minutes slow)

    Why are there two places to set it, each with different options and not in sync with each other?! And now that both are set to ntp (and "systemctl status ntp.service" now shows it running), why is the clock still 4 minutes slow?

    When I say 4 minutes slow, I'm judging it against multiple sources:

    1. My Cell phone (logged in to the carrier)

    2. Google "Current Time"

    3. timeanddate.com

    All are 4 minutes ahead of the reported time on my taskbar.

    What could be going on?

    EDIT: I went back into YAST, and this time chose "NTP Configuration" and chose "us.pool.ntp.org" and "synchronize now and on boot" and now the clock is set correctly. BUT, I won't know if this will hold until I restart later

    I also still don't understand why there are multiple places to set NTP and not all of them actually work.

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Syncing to public time server is always 4-5 minutes slow

    On 2014-02-27 17:26, 6tr6tr wrote:

    > This might be the problem! There are two different places to set the
    > date/time and they're done differently!
    >
    > 1. Right click on the clock (on taskbar) and choose "Adjust Date and
    > Time". I have this set to "set date and time automatically" with
    > "pool.ntp.org".


    This is up to the desktop to do. Why this works, or not, is up to that
    desktop developers, not to openSUSE.

    > 2. YAST->Date and Time. This was set to "manually", NOT ntp. (However,
    > after choosing NTP, the clock is still 4 minutes slow)


    This is the correct place to do it on openSUSE. That, and the "NTP
    configuration" yast module.

    Forget about the applet you were using.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  7. #7

    Default Re: Syncing to public time server is always 4-5 minutes slow

    Quote Originally Posted by robin_listas View Post
    On 2014-02-27 17:26, 6tr6tr wrote:

    > This might be the problem! There are two different places to set the
    > date/time and they're done differently!
    >
    > 1. Right click on the clock (on taskbar) and choose "Adjust Date and
    > Time". I have this set to "set date and time automatically" with
    > "pool.ntp.org".


    This is up to the desktop to do. Why this works, or not, is up to that
    desktop developers, not to openSUSE.
    Apologies but this is incorrect. The KDE desktop I'm using is the one that came with openSUSE. It is customized by openSUSE (in a lot of areas) and they very well could have customized that clock widget to either remove that NTP configuration or synchronize it with the one in YAST (or even make it a button that simply opens the YAST NTP/Clock configuration). To not do that is a big missed opportunity in making a consistent distro. (And a distro is not just the kernel and background apps, the desktop is a big part of it, and openSUSE is a distro)

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Syncing to public time server is always 4-5 minutes slow

    On 2014-02-27 18:16, 6tr6tr wrote:
    >
    > robin_listas;2627468 Wrote:



    >> This is up to the desktop to do. Why this works, or not, is up to that
    >> desktop developers, not to openSUSE.

    >
    > Apologies but this is incorrect. The KDE desktop I'm using is the one
    > that came with openSUSE. It is customized by openSUSE (in a lot of
    > areas) and they very well could have customized that clock widget to
    > either remove that NTP configuration or synchronize it with the one in
    > YAST (or even make it a button that simply opens the YAST NTP/Clock
    > configuration). To not do that is a big missed opportunity in making a
    > consistent distro. (And a distro is not just the kernel and background
    > apps, the desktop is a big part of it, and openSUSE is a distro)


    Distros do not customize everything. It has bee known for years that
    trying to adjust clock via KDE breaks things in openSUSE.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

  9. #9
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Syncing to public time server is always 4-5 minutes slow

    On 2/27/2014 10:26 AM, 6tr6tr wrote:
    <snip>
    And now that both are set to ntp (and
    > "systemctl status ntp.service" now shows it running), why is the clock
    > still 4 minutes slow?
    >

    <snip>
    >
    > What could be going on?
    >
    >

    6tr6tr;

    Make sure to assign the ntp server in Yast (Date and Time). Check the two boxes for NTP to run as a daemon and save NTP
    configuration. If NTP is not running it cannot update the time. Not sure how the KDE application works, never played
    with it.
    --
    P.V.
    "We're all in this together, I'm pulling for you" Red Green

  10. #10
    Join Date
    Jan 2014
    Location
    Idaho
    Posts
    77

    Default Re: Syncing to public time server is always 4-5 minutes slow

    Quote Originally Posted by 6tr6tr View Post
    I have my clock set to sync with "Public Time Server (pool.ntp.org)". It is always 4-5 minute behind. The odd piece:

    * If I switch which server I am syncing with, the time will show correctly right after

    * After a while (or on reboot) it will show 4-5 minutes slow
    I know you found the solution to always being out of sync. However, if the computer you are using is a few years old the reason for your running 4-5 minutes slow in less than a day could mean that the "watch" battery on the mother board needs to be replaced.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •