Results 1 to 5 of 5

Thread: Upgrade to KDE 412 fails on opensuse 13.1 (Problem: nothing provides libIlmImf.so.7()(64bit) needed)

  1. #1

    Default Upgrade to KDE 412 fails on opensuse 13.1 (Problem: nothing provides libIlmImf.so.7()(64bit) needed)

    zypper up
    Loading repository data...
    Reading installed packages...

    The following 105 package updates will NOT be installed:
    NetworkManager-kde4-libs NetworkManager-openvpn-kde4 NetworkManager-pptp-kde4
    NetworkManager-vpnc-kde4 akonadi akonadi-runtime akregator ark choqok dolphin gwenview jovie k3b
    kactivities4 kaddressbook kaffeine kcalc kcharselect kcolorchooser kde-gtk-config
    kde4-kgreeter-plugins kde4-print-manager kdeartwork4-screensaver kdebase4-libkonq
    kdebase4-nsplugin kdebase4-runtime kdebase4-workspace kdebase4-workspace-ksysguardd
    kdebase4-workspace-liboxygenstyle kdebase4-workspace-plasma-calendar kdelibs4 kdelibs4-core
    kdenetwork4-filesharing kdepasswd kdepim4 kdepim4-runtime kdepimlibs4 kdialog kdm kdnssd
    keditbookmarks kgamma kget kio_audiocd kio_iso kio_kamera kmag kmail kmix kmousetool knotes
    kompare konqueror konqueror-plugins konsole kontact konversation konversation-lang kopete
    korganizer krdc krfb kruler kscd ksnapshot ksshaskpass ktorrent kvkbd kwalletmanager kwin kwrite
    libakonadi4 libakonadiprotocolinternals1 libkcddb4 libkcompactdisc4 libkde4 libkdecore4
    libkdepim4 libkdepimlibs4 libkonq5 libktexteditor libopencv2_4 marble marble-data nepomuk-core
    okular plasma-addons plasma-addons-akonadi plasma-addons-lancelot plasma-addons-marble
    plasmoid-folderview plasmoid-networkmanagement plasmoid-quickaccess polkit-kde-agent-1
    python-kde4 python-kde4-akonadi python-kde4-khtml python-kde4-knewstuff python-kde4-nepomuk
    python-kde4-phonon python-kde4-plasma python-kde4-soprano python-kdebase4 sweeper synaptiks

    zypper install kdebase4-runtime-4.12.2-485.1.x86_64
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: nothing provides libIlmImf.so.7()(64bit) needed by kdebase4-runtime-4.12.2-485.1.x86_64
    Solution 1: do not install kdebase4-runtime-4.12.2-485.1.x86_64
    Solution 2: break kdebase4-runtime-4.12.2-485.1.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or cancel [1/2/c] (c):


    zypper lr -u |grep -i kde
    1 | KDE_Extra | Additional packages maintained by the KDE team (KDE_Release_412_openSUSE_12.3) | Yes | No | http://download.opensuse.org/reposit...openSUSE_12.3/
    2 | KDE_Release_412 | KDE SC 4.12 Core packages (openSUSE_12.3) | Yes | No | http://download.opensuse.org/reposit...openSUSE_12.3/
    3 | KDE_Unstable_Extra | Unstable KDE Applications (KDE_Release_412_openSUSE_12.3) | Yes | No | http://download.opensuse.org/reposit...openSUSE_12.3/

    What could the solution be?

    Thanks in advantage!

    Peter

  2. #2

    Default Re: Upgrade to KDE 412 fails on opensuse 13.1 (Problem: nothing provides libIlmImf.so.7()(64bit) nee

    Quote Originally Posted by peterterpstra View Post
    zypper lr -u |grep -i kde
    1 | KDE_Extra | Additional packages maintained by the KDE team (KDE_Release_412_openSUSE_12.3) | Yes | No | http://download.opensuse.org/reposit...openSUSE_12.3/
    2 | KDE_Release_412 | KDE SC 4.12 Core packages (openSUSE_12.3) | Yes | No | http://download.opensuse.org/reposit...openSUSE_12.3/
    3 | KDE_Unstable_Extra | Unstable KDE Applications (KDE_Release_412_openSUSE_12.3) | Yes | No | http://download.opensuse.org/reposit...openSUSE_12.3/

    What could the solution be?
    Well, isn't it obvious?

    Those repos are for openSUSE 12.3 and you are using 13.1.
    Change the repo URLs to ...openSUSE_13.1 and it should work.

    And you should maybe enable Refresh as well.

  3. #3

    Default Re: Upgrade to KDE 412 fails on opensuse 13.1 (Problem: nothing provides libIlmImf.so.7()(64bit) nee

    Thank you so much, so silly of me

    Have overlooked that, already studying for weeks on this.

    Thanks, Peter

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,124

    Default Re: Upgrade to KDE 412 fails on opensuse 13.1 (Problem: nothing provides libIlmImf.so.7()(64bit) nee

    And please, next time use CODE tags around your copied/pasted computer text. It is the # button in the toolbar of the post editor.

    BTW I am glad wolfi323 did take the trouble to decipher this. Saves me some headache
    Henk van Velden

  5. #5

    Default Re: Upgrade to KDE 412 fails on opensuse 13.1 (Problem: nothing provides libIlmImf.so.7()(64bit)

    Quote Originally Posted by hcvv View Post
    BTW I am glad wolfi323 did take the trouble to decipher this. Saves me some headache
    Well, actually I skipped most of it.
    The wrong URLs were too obvious, anyway...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •