Results 1 to 4 of 4

Thread: Problem with opening ports at firewall.

  1. #1
    Join Date
    Dec 2013
    Location
    Patras, Greece.
    Posts
    66

    Question Problem with opening ports at firewall.

    Hi!
    I opened two ports (40000 for tcp and 40001 for udp) at suse firewall, in order my torrent client to work properly.
    (I have Azureus and KTorrent at OpenSUSE v13.1 x64 with KDE).



    However, sometimes the client works without any problems, while some others seems to be firewalled and can't communicate properly with the outside world.
    Seems to be a random effect.

    I disabled the firewall and everything is OK now.
    (I have always enabled the router's (build-in, hardware) firewall.
    Just out of curiosity, is there any way to keep suse firewall enabled?

  2. #2

    Default Re: Problem with opening ports at firewall.

    >
    > I disabled the firewall and everything is OK now.
    > (I have always enabled the router's (build-in, hardware) firewall.
    > Just out of curiosity, is there any way to keep suse firewall enabled?


    You're assuming that the firewall is somehow being enabled. Chances are
    much higher that, while enabled, something about the traffic is different
    enough to cause a problem in those cases where there is a failure.

    To see your current firewall state, run the follow command(s) (either will
    work, they just show things differently):

    Code:
    --------------------
    sudo /usr/sbin/iptables-save
    sudo /usr/sbin/iptables -nvL
    --------------------

    Do this when things work, and then do it again when it breaks. Compare,
    and I'll bet you see no difference in the iptables-save output, though you
    may see some in the iptables output because of additional statistical
    information presented.

    To see lots from the firewall:
    Code:
    --------------------
    sudo tail -f /var/log/firewall
    #perform test after running the command above
    #ctrl+c to stop tailing the firewall log file
    --------------------

    If you see something in the log file output above when your torrent client
    is failing to do something, post that output. This generally implies you
    run this 'tail' command, do the test, then post what showed up.

    If the torrent client can specify what is going on that too may be
    helpful; they are the ones trying to use the network, so they should be in
    a good position to tell you what is failing.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below...

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Problem with opening ports at firewall.

    Whatever torrent client you use,
    A common app config is to randomize the incoming port each time the app starts up.

    Be sure to disable that.

    TSU

  4. #4
    Join Date
    Dec 2013
    Location
    Patras, Greece.
    Posts
    66

    Default Απ: Problem with opening ports at firewall.

    THANKS guys!

    @ab
    Let me try it and I'll be back with the details.

    @tsu2
    I always set the client to use two specific ports all the time (in order the port forwarding to be successful).

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •