Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Video MP4v format problem

  1. #1

    Default Video MP4v format problem

    Hi, dear SuSE community!
    Few days ago I wanted to watch at a movie, and I had a problem with audio and mp4 codec. With audio one, I've solved and the sound works perfectly now.
    But, there's the next problem, which I searched for its solving, I tried a lot of method and official SuSE articles, but without a good result.

    Also I tried a lot of versions and media player, but I got same error at all. I prefer VLC.

    The sounds works, but I get this:

    Code:
     VLC does not support the audio or video format "mp4v"
    I tried to get the codec from Packman repository, but same.

    I'll be glad if you help me to solve it.

    Thanks.

    ~ devna

  2. #2

    Default Re: Video MP4v format problem

    Please post your repo list:
    Code:
    zypper lr -d
    Most likely you either did not change all necessary packages to the Packman or VLC repo versions, or you even have both repos active.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,811

    Default Re: Video MP4v format problem

    And as allways, when you want an answer applicable to your openSUSE version, please inform us what that version is.
    Henk van Velden

  4. #4

    Default Re: Video MP4v format problem

    My OpenSuSE version is 13.1

    @wolfi323

    Code:
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                          | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------+--------
     1 | SuSE                      | SuSE                               | Yes     | Yes     |   99     | rpm-md | http://download.videolan.org/SuSE/12.2/                                      |        
     2 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-HL-DT-STDVDRAM_GT31N_KZABAO81500,/dev/sr0 |        
     3 | packman                   | packman                            | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_12.2/                                  |        
     4 | repo-debug                | openSUSE-13.1-Debug                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/13.1/repo/oss/               |        
     5 | repo-debug-update         | openSUSE-13.1-Update-Debug         | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/debug/update/13.1/                              |        
     6 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                      |        
     7 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/                 |        
     8 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                     |        
     9 | repo-source               | openSUSE-13.1-Source               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/13.1/repo/oss/              |        
    10 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                    |        
    11 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/

  5. #5

    Default Re: Video MP4v format problem

    Quote Originally Posted by devna View Post
    My OpenSuSE version is 13.1

    @wolfi323

    Code:
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                          | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------+--------
     1 | SuSE                      | SuSE                               | Yes     | Yes     |   99     | rpm-md | http://download.videolan.org/SuSE/12.2/                                      |        
      2 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | Yes     | No      |   99     | yast2  | cd:///?devices=/dev/disk/by-id/ata-HL-DT-STDVDRAM_GT31N_KZABAO81500,/dev/sr0 |        
     3 | packman                   | packman                            | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_12.2/                                  |        
    ...
    Right, as I suspected.
    You should never use both of those repos, as they are not compatible and contain different versions of the same packages. So having both WILL most likely BREAK your multimedia stuff.

    As VLC is available from Packman anyway (the stable version at least, vlc-beta is only contained in the vlc repo), I would suggest to remove the vlc repo and switch everything to Packman:

    ...code removed... see the following post...

    Then your problem should be solved.
    Last edited by wolfi323; 23-Feb-2014 at 04:33.

  6. #6

    Default Re: Video MP4v format problem

    PS: I just noticed that you have the 12.2 versions of _both_ repos!

    This will give you problems for sure on 13.1!

    Remove both, add the 13.1 version of the Packman repo, and then switch all packages:
    Code:
    sudo zypper rr 1 3
    sudo zypper ar http://packman.inode.at/suse/openSUSE_13.1/ packman
    sudo zypper dup --from packman

  7. #7

    Default Re: Video MP4v format problem

    Thanks a lot. It works!

    +1 reputation.

    ~ devna.

  8. #8
    Join Date
    Oct 2010
    Location
    Lancaster, Lancashire
    Posts
    176

    Default Re: Video MP4v format problem

    I am actually having the same problem. And not sure where the problem comes from:

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
    1 | Education | Education | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    2 | Games | Games | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    3 | KDE_Extra | KDE Extra | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    4 | WINE | WINE | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    5 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386 |
    6 | google-talkplugin | google-talkplugin | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/talkplugin/rpm/stable/i386 |
    7 | home Revan86 | home Revan86 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    8 | home Revan86:non-free | home Revan86:non-free | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    9 | home bleser:staging | home bleser:staging | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_13.1/ |
    10 | libdvdcss | libdvdcss | Yes | Yes | 99 | rpm-md | http://opensuse-guide.org/repo/13.1/ |
    11 | packman | packman | Yes | Yes | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_13.1/ |
    12 | repo-debug | openSUSE-13.1-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/d...13.1/repo/oss/ |
    13 | repo-debug-update | openSUSE-13.1-Update-Debug | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1/ |
    14 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No | Yes | 99 | NONE | http://download.opensuse.org/debug/update/13.1-non-oss/ |
    15 | repo-non-oss | openSUSE-13.1-Non-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    16 | repo-oss | openSUSE-13.1-Oss | Yes | Yes | 99 | yast2 | http://download.opensuse.org/distrib...13.1/repo/oss/ |
    17 | repo-source | openSUSE-13.1-Source | No | Yes | 99 | NONE | http://download.opensuse.org/source/...13.1/repo/oss/ |
    18 | repo-update | openSUSE-13.1-Update | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1/ |
    19 | repo-update-non-oss | openSUSE-13.1-Update-Non-Oss | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/update/13.1-non-oss/

  9. #9

    Default Re: Video MP4v format problem

    Quote Originally Posted by JudasDisciple View Post
    I am actually having the same problem. And not sure where the problem comes from:
    Well, do you have "vlc-codecs" installed?

    If yes and it still doesn't work, run:
    Code:
    sudo zypper dup --from 11
    That should fix it.

    If that still doesn't help, please post a list of all installed vlc packages:
    Code:
    rpm -qa | grep vlc

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,811

    Default Re: Video MP4v format problem

    And please JudasDisciple,
    Use CODE tags, not QUOTE tags around your copied/pasted commputer text. It is the # button in the tool bar.
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •