Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Unable to shutdown in 13.1 (x86_64)

  1. #11

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Quote Originally Posted by mikesol View Post
    Ok this a start, but it's a kind weird, isn't it? Anyway, I discovered that if I restart, go to the grub console (F2 in the grub screen) and type "halt", it shutdowns and poweroffs completely the laptop.
    F2 in grub? That's the language setting, isn't it?
    Are you using grub legacy or grub2?

    I tried these options but nothing "reboot=kbd", or =pci, efi, triple, bios. Could you please suggest me something else to try?
    I thought about "acpi_osi=Windows" or something like that. But I'm not really experienced with those either.


    I'd wish! I installed Opensuse using UEFI with secure boot (The only way to make all work). In fact my first option with this new machine was to use Tumbleweed, but I failed miserably because the newer kernels aren't signed and I can't boot with them.
    Well, you should be able to turn off secure boot in the BIOS settings (with UEFI turned ON of course).
    But I have absolutely no expierence with that UEFI/secure boot stuff, as all of my systems still have a legacy BIOS.

    There is another thread going on at the moment regarding that kernel signing issue, see here:
    http://forums.opensuse.org/showthread.php/495681-Grub2-Invalid-signature-error-when-multi-booting

    Here someone else was successful in turning off secure boot and was able to use the 3.13.3 kernel then (and even Windows 8.1 was still working apparently):
    http://forums.opensuse.org/showthrea...12#post2625612

    Maybe in another related issue. If I suspend my machine, it keeps freeze when I try to start it back.
    Is it the same issue or I have to report it in another thread?
    No idea, could be the same issue, could be not.
    Does it really freeze? There is an issue in KDE in which the screen locker would not show a password dialog even when a password is required to unlock after resume. So, do you have a black screen or something, or is there a wallpaper and the mouse cursor?

    But let's try to fix the shutdown issue first.

  2. #12

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Quote Originally Posted by wolfi323 View Post
    Here someone else was successful in turning off secure boot and was able to use the 3.13.3 kernel then (and even Windows 8.1 was still working apparently):
    http://forums.opensuse.org/showthrea...12#post2625612
    Thanks Wolfi! To deactivate the secure boot It was only necessary set a supervisor password. I installed the Kernel 3.13 and I can shutdown without problems. Maybe this bug has to be backported to 3.11 or something. In any case, thanks again!

    Does it really freeze? There is an issue in KDE in which the screen locker would not show a password dialog even when a password is required to unlock after resume. So, do you have a black screen or something, or is there a wallpaper and the mouse cursor?
    In fact there are two different behaviors. If I explicitly click the button "Suspend to Ram" and then tried to recover the session, I get only a black screen.
    But, if I leave it for 10 minutes unplugged, the machine get sleep and when i tried to recover the session I see only the wallpaper and the mouse cursor.

    Regards.

  3. #13

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Quote Originally Posted by mikesol View Post
    Thanks Wolfi! To deactivate the secure boot It was only necessary set a supervisor password. I installed the Kernel 3.13 and I can shutdown without problems. Maybe this bug has to be backported to 3.11 or something. In any case, thanks again!
    So this was indeed your issue.

    There won't be any 3.11 kernels any more, as 3.11 has been EOLed in November.
    But you might want to file a bug report at http://bugzilla.novell.com (don't forget to link to that upstream bug report and mention that kernel 3.13 works for you).
    Maybe they would backport the patch and include it in an update. I have no idea though, if it would be even possible to backport it.

    In fact there are two different behaviors. If I explicitly click the button "Suspend to Ram" and then tried to recover the session, I get only a black screen.
    Have you tried with kernel 3.13 already?

    I find that strange since suspend/resume does apparently seem to work:
    But, if I leave it for 10 minutes unplugged, the machine get sleep and when i tried to recover the session I see only the wallpaper and the mouse cursor.
    Well, this is a KDE issue.
    See here for packages that should fix it:
    https://bugzilla.novell.com/show_bug.cgi?id=864305

    You can also change the power management settings to not require a password after resume (in the "Advanced" tab), or to not suspend at all automatically.
    Enabling "Require Passwort after" in the screen locker/screen saver settings should fix this also, but you would need the password everytime the screen locker kicks in then of course.
    Anyway, no need to open a new thread for _this_ problem, there are quite few recent ones already (and the bug report)...
    Last edited by wolfi323; 23-Feb-2014 at 08:34.

  4. #14

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Have you tried with kernel 3.13 already?

    I find that strange since suspend/resume does apparently seem to work:
    I'm using the kernel 3.13 and that happens. I workaround this changing all the instances of suspension by hibernation in the power manager settings. It isn't very elegant but works for me (while I remember don't click to the "Suspend to Ram" button)

    Well, this is a KDE issue.
    See here for packages that should fix it:
    https://bugzilla.novell.com/show_bug.cgi?id=864305
    I installed the packages that you provided. I'll leave my laptop a while unplugged to see what happens and I'll report it back.


    Best Regards.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •