Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Unable to shutdown in 13.1 (x86_64)

  1. #1

    Default Unable to shutdown in 13.1 (x86_64)

    I installed Opensuse in a Acer Aspire V5-473 and I can't shutdown properly the system. When I press the shutdown button in KDE (or doing # shutdown -h now) all the system freezes and I can't access any tty or reboot with the REISUB trick. The only solution is doing a hard shutdown (pressing the ac/power button for a couple of seconds, not the best idea IMHO)

    I read this thread about a similar problem but it seems that affects only 32 bits machines.

    My situation:

    Fully updated with 'zypper up'

    Code:
    $ uname -a
    Linux linux-zo89.site 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e) x86_64 x86_64 x86_64 GNU/Linux
    Code:
    $ sudo /sbin/lspci
    00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
    00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
    00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
    00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
    00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
    00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
    00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 1 (rev e4)
    00:1c.2 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 3 (rev e4)
    00:1c.3 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 4 (rev e4)
    00:1d.0 USB controller: Intel Corporation Lynx Point-LP USB EHCI #1 (rev 04)
    00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
    00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
    00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
    04:00.0 Network controller: Qualcomm Atheros AR9462 Wireless Network Adapter (rev 01)
    05:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5287 (rev 01)
    05:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 14)
    I appreciate any help.

    Regards.

  2. #2

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Quote Originally Posted by mikesol View Post
    I installed Opensuse in a Acer Aspire V5-473 and I can't shutdown properly the system. When I press the shutdown button in KDE (or doing # shutdown -h now) all the system freezes and I can't access any tty or reboot with the REISUB trick. The only solution is doing a hard shutdown (pressing the ac/power button for a couple of seconds, not the best idea IMHO)
    Hm. A few thoughts:
    Try to disable plymouth (by adding "plymouth.enable=0" to the boot options). You should see the messages during shutdown then. Maybe there's something obvious there?
    Or maybe /var/log/messages shows something?

    Do you have any nfs shares mounted?
    Maybe the network gets shut down before the shares are unmounted, causing a hang.

    Do you have acpid installed? Try to remove it, I have heard this could cause hangs on shutdown. But it should not be installed by default on 13.1 anyway.

    See here for how to debug shutdown problems with systemd:
    http://freedesktop.org/wiki/Software...ging/#index2h1

    I read this thread about a similar problem but it seems that affects only 32 bits machines.
    That kernel bug that affected only 32bit systems was related to suspend AFAIK, and should be fixed in 3.11.10.

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to shutdown in 13.1 (x86_64)

    On 2014-02-22 09:26, mikesol wrote:
    > I read 'this thread'
    > (http://lists.opensuse.org/opensuse/2.../msg00285.html) about a
    > similar problem but it seems that affects only 32 bits machines.


    No, that's a very specific problem, that indeed only happens on 32 bit
    hardware, and it triggers _after_ hibernation.

    This is the relevant section in that thread:

    >> Yes, it was suspended before I woke it up and realized the wireless
    >> lan did not reconnect.

    ....
    > the "Failed to open /dev/initctl: No such device or address" thing, and
    > "wireless connections not coming up again", and others, are indeed the same kernel issue I was talking about in previous mails, it is triggered by suspend/resume in 32 bit machines.
    >
    > fixed in:
    >
    > https://git.kernel.org/cgit/linux/ke...6a948299692e6b
    >
    > and
    >
    > https://git.kernel.org/cgit/linux/ke...cca6e8e169580c
    >
    > In short epoll() and select() may do stupid things after resume.



    And this particular issue has been solved in the recent kernel update.
    At least so they told me, that the patch has been backported:

    http://lists.opensuse.org/opensuse-s.../msg00005.html

    But I had no occasion to test this yet. In a week or two, I hope.


    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  4. #4

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Try to disable plymouth (by adding "plymouth.enable=0" to the boot options). You should see the messages during shutdown then. Maybe there's something obvious there?
    Or maybe /var/log/messages shows something?
    The only message that I got was ''Reboot: power down''. I post my message log file from my last shutdown: /var/log/messages

    Do you have any nfs shares mounted?
    Maybe the network gets shut down before the shares are unmounted, causing a hang.
    No I don't have any. It's a single personal machine.

    Do you have acpid installed? Try to remove it, I have heard this could cause hangs on shutdown. But it should not be installed by default on 13.1 anyway.
    I installed, but read this in another place and remove it immediately.

    See here for how to debug shutdown problems with systemd:
    http://freedesktop.org/wiki/Software...ging/#index2h1
    I'm a not so expert, but I'll try this later.

    Regards.

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to shutdown in 13.1 (x86_64)

    On 2014-02-22 11:46, mikesol wrote:

    > The only message that I got was ''Reboot: power down''. I post my
    > message log file from my last shutdown: '/var/log/messages
    > ' (http://pastebin.com/Ek1UKAbV)



    Nothing there. A normal shutdown, then it starts again.

    Code:
    
    > 2014-02-22T10:54:26.712581+01:00 linux-zo89 polkitd[2152]: Unregistered Authentication Agent for unix-session:1 (system bus name :1.36, object path /org/kde/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
    > 2014-02-22T10:54:27.203567+01:00 linux-zo89 bluetoothd[2071]: Failed to remove UUID: Invalid Parameters (0x0d)
    > 2014-02-22T10:54:27.301433+01:00 linux-zo89 kdm: :0[2203]: pam_unix(xdm:session): session closed for user myusername
    > 2014-02-22T10:54:27.450476+01:00 linux-zo89 systemd[1]: Stopping Session 1 of user myusername.
    > 2014-02-22T10:54:27.450823+01:00 linux-zo89 systemd[1]: Stopped Session 1 of user myusername.
    > 2014-02-22T10:54:27.451043+01:00 linux-zo89 systemd[1]: Stopping Bluetooth.
    > 2014-02-22T10:54:27.451281+01:00 linux-zo89 systemd[1]: Stopped target Bluetooth.
    > 2014-02-22T10:54:27.451864+01:00 linux-zo89 systemd[1]: Stopping Sound Card.
    > 2014-02-22T10:54:27.452154+01:00 linux-zo89 systemd[1]: Stopped target Sound Card.
    > 2014-02-22T10:54:27.452396+01:00 linux-zo89 systemd[1]: Stopping Stop Read-Ahead Data Collection 10s After Completed Startup.
    > 2014-02-22T10:54:27.452560+01:00 linux-zo89 systemd[1]: Stopped Stop Read-Ahead Data Collection 10s After Completed Startup.
    > 2014-02-22T10:54:27.452728+01:00 linux-zo89 systemd[1]: Stopping User Manager for 0...
    > 2014-02-22T10:54:27.452996+01:00 linux-zo89 systemd[1]: Stopping User Manager for 1000...
    > 2014-02-22T10:54:27.453293+01:00 linux-zo89 systemd[1]: Stopping Graphical Interface.
    > 2014-02-22T10:54:27.453580+01:00 linux-zo89 systemd[1]: Stopped target Graphical Interface.
    > 2014-02-22T10:54:27.453841+01:00 linux-zo89 systemd[1]: Stopping LSB: X Display Manager...
    > 2014-02-22T10:54:27.454144+01:00 linux-zo89 systemd[1]: Stopping Multi-User System.
    > 2014-02-22T10:54:27.454865+01:00 linux-zo89 systemd[1]: Stopped target Multi-User System.
    > 2014-02-22T10:54:27.455587+01:00 linux-zo89 systemd[1]: Stopping Command Scheduler...
    > 2014-02-22T10:54:27.456509+01:00 linux-zo89 systemd[1]: Stopping OpenSSH Daemon...
    > 2014-02-22T10:54:27.458857+01:00 linux-zo89 rsyslogd: [origin software="rsyslogd" swVersion="7.4.7" x-pid="2124" x-info="http://www.rsyslog.com"] exiting on signal 15.
    > 2014-02-22T10:55:17.451601+01:00 linux-zo89 rsyslogd: [origin software="rsyslogd" swVersion="7.4.7" x-pid="1505" x-info="http://www.rsyslog.com"] start
    If something happens, it does after the syslog daemon is stopped, thus
    nothing can be recorded on log.


    Try disable Plymouth, as wolfi323 said.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Quote Originally Posted by robin_listas View Post

    Try disable Plymouth, as wolfi323 said.
    Yes I did it, and the only message that I see is "Reboot: Power down".


  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Unable to shutdown in 13.1 (x86_64)

    On 2014-02-22 12:26, mikesol wrote:
    >
    > robin_listas;2626457 Wrote:
    >>
    >>
    >> Try disable Plymouth, as wolfi323 said.
    >>

    >
    > Yes I did it, and the only message that I see is "Reboot: Power down".
    >
    > [image:
    > https://dl.dropboxusercontent.com/u/...22_121322.jpg]


    Ok, try something else (with plymouth disabled).

    Log out from KDE or whatever you use.

    Switch to a text console: type ctrl-alt-f1.

    Log in there as root.

    Enter "halt -p".

    And watch what happens...

    If it gets stuck, make a photo of the messages. Sometimes you still can
    press ctrl-alt-f10 and see some messages in there.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  8. #8

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Quote Originally Posted by robin_listas View Post
    On 2014-02-22 12:26, mikesol wrote:
    Ok, try something else (with plymouth disabled).

    Log out from KDE or whatever you use.

    Switch to a text console: type ctrl-alt-f1.

    Log in there as root.

    Enter "halt -p".

    And watch what happens...

    If it gets stuck, make a photo of the messages. Sometimes you still can
    press ctrl-alt-f10 and see some messages in there.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

    Nop, I get the same. And I can't acces to any tty with ctrl-alt-f10.

    Regards.


  9. #9

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Quote Originally Posted by mikesol View Post
    The only message that I got was ''Reboot: power down''. I post my message log file from my last shutdown: /var/log/messages
    OK, so the system does in fact shut down successfully. What doesn't work is turning off power, which is most likely ACPI related I'd guess.

    Just to reassure you: a hard shutdown (by pressing the power button for a few seconds) doesn't cause any harm in that state, as the system is already shut down.

    Maybe some playing with the BIOS's ACPI settings might help?
    Or specifying some ACPI boot options?

    But I think you're actually experiencing this kernel bug:
    https://bugzilla.kernel.org/show_bug.cgi?id=63861

    So try to upgrade to the latest 3.13 kernel from here to see if it helps:
    http://download.opensuse.org/reposit...able/standard/

  10. #10

    Default Re: Unable to shutdown in 13.1 (x86_64)

    Quote Originally Posted by wolfi323 View Post
    OK, so the system does in fact shut down successfully. What doesn't work is turning off power, which is most likely ACPI related I'd guess.

    Just to reassure you: a hard shutdown (by pressing the power button for a few seconds) doesn't cause any harm in that state, as the system is already shut down.
    Ok this a start, but it's a kind weird, isn't it? Anyway, I discovered that if I restart, go to the grub console (F2 in the grub screen) and type "halt", it shutdowns and poweroffs completely the laptop.

    Maybe some playing with the BIOS's ACPI settings might help?
    Or specifying some ACPI boot options?

    But I think you're actually experiencing this kernel bug:
    https://bugzilla.kernel.org/show_bug.cgi?id=63861
    I tried these options but nothing "reboot=kbd", or =pci, efi, triple, bios. Could you please suggest me something else to try?

    So try to upgrade to the latest 3.13 kernel from here to see if it helps:
    http://download.opensuse.org/reposit...able/standard/
    I'd wish! I installed Opensuse using UEFI with secure boot (The only way to make all work). In fact my first option with this new machine was to use Tumbleweed, but I failed miserably because the newer kernels aren't signed and I can't boot with them.

    Maybe in another related issue. If I suspend my machine, it keeps freeze when I try to start it back.
    Is it the same issue or I have to report it in another thread?

    Regards.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •