Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25

Thread: Nearly 100% CPU usage when writing to disk

  1. #21

    Default re: Nearly 100% CPU usage when writing to disk

    My problem is not the write-access rate. It is fast enough. My problem is that if I perform these write actions, then the system slows down and becomes almost unusable. When the write action finishes, the system will be usable again. This problem exists only if I write a large file or large amount of files.

  2. #22
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Nearly 100% CPU usage when writing to disk

    On 2014-02-25 21:46, helmet91 wrote:
    >
    > My problem is not the write-access rate. It is fast enough. My problem
    > is that if I perform these write actions, then the system slows down and
    > becomes almost unusable. When the write action finishes, the system will
    > be usable again. This problem exists only if I write a large file or
    > large amount of files.


    Well, if the disk system is busy writing a big file, it can not attend
    to other petitions from other programs fast, so they have to wait. The
    result is a sluggish system.

    On some setups this is very noticeable.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #23
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,001

    Default Re: Nearly 100% CPU usage when writing to disk

    You used to be able to set nice but I'm not sure that is still an option

  4. #24

    Default re: Nearly 100% CPU usage when writing to disk

    I think, it should not slow down this much. Even the mouse cursor is also lagging. I don't know, since when is this happening, but earlier I did not have this problem. And also I think my hardware (Phenom II 965 CPU, 1066 MHz 4 GB RAM, SATA-II HDD) is quite adequate for not beeing slow when I just copy some files in the background.

  5. #25
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Nearly 100% CPU usage when writing to disk

    On 2014-02-26 05:56, gogalthorp wrote:
    >
    > You used to be able to set nice but I'm not sure that is still an option


    Yes, you can.

    You can also use "ionice", which you can use to force a process to be
    nice on disk demands (instead of 'nice' which acts on cpu priority)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 12.3 x86_64 "Dartmouth" at Telcontar)

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •