Results 1 to 9 of 9

Thread: Nvidia card (GTX660M) "not supported"??!?

  1. #1

    Default Nvidia card (GTX660M) "not supported"??!?

    Hi all,
    Am curious to see whether anyone else has this same problem. I've got an Optimus based system with intel and nvidia graphics.

    Bumblebee installed, was previously working. Went to launch a GL application today and it failed, investigation revealed the following output:

    Code:
    >dmesg | tail 
    [106089.402142] nvidia 0000:01:00.0: power state changed by ACPI to D0
    [106089.402233] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=none
    [106089.402296] NVRM: The NVIDIA GPU 0000:01:00.0 (PCI ID: 10de:0fd4)
    NVRM: installed in this system is not supported by the 331.38
    NVRM: NVIDIA Linux driver release.  Please see 'Appendix
    NVRM: A - Supported NVIDIA GPU Products' in this release's
    NVRM: README, available on the Linux driver download page
    NVRM: at www.nvidia.com.
    [106089.402370] nvidia: probe of 0000:01:00.0 failed with error -1
    [106089.402998] NVRM: The NVIDIA probe routine failed for 1 device(s).
    [106089.403001] NVRM: None of the NVIDIA graphics adapters were initialized!
    [106089.403003] [drm] Module unloaded
    [106089.403170] NVRM: NVIDIA init module failed!
    ooookay? My PCI ID resolves to the GeForce GTX 660M, and it's listed as a supported product in said README here: http://www.nvidia.com/Download/drive...px/72250/en-us

    Code:
    # hwinfo --gfxcard
    10: PCI 02.0: 0300 VGA compatible controller (VGA)              
      [Created at pci.319]
      Unique ID: _Znp.3H63STgg632
      SysFS ID: /devices/pci0000:00/0000:00:02.0
      SysFS BusID: 0000:00:02.0
      Hardware Class: graphics card
      Model: "Intel VGA compatible controller"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x0166 
      SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
      SubDevice: pci 0x10d8 
      Revision: 0x09
      Driver: "i915"
      Driver Modules: "drm"
      Memory Range: 0xf6400000-0xf67fffff (rw,non-prefetchable)
      Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
      I/O Ports: 0xf000-0xf03f (rw)
      IRQ: 46 (3374062 events)
      Module Alias: "pci:v00008086d00000166sv00001462sd000010D8bc03sc00i00"
      Driver Info #0:
        Driver Status: i915 is active
        Driver Activation Cmd: "modprobe i915"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
    
    23: PCI 100.0: 0300 VGA compatible controller (VGA)
      [Created at pci.319]
      Unique ID: VCu0.D+hrRxa8XJ9
      Parent ID: vSkL.LtivxUYcBVC
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "nVidia VGA compatible controller"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x0fd4 
      SubVendor: pci 0x1462 "Micro-Star International Co., Ltd."
      SubDevice: pci 0x10d8 
      Revision: 0xff
      Memory Range: 0xf5000000-0xf5ffffff (rw,non-prefetchable)
      Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
      Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
      I/O Ports: 0xe000-0xefff (rw)
      Memory Range: 0xf6000000-0xf607ffff (ro,non-prefetchable)
      IRQ: 16 (856101 events)
      Module Alias: "pci:v000010DEd00000FD4sv00001462sd000010D8bc03sc00i00"
      Driver Info #0:
        Driver Status: nvidiafb is not active
        Driver Activation Cmd: "modprobe nvidiafb"
      Driver Info #1:
        Driver Status: nouveau is not active
        Driver Activation Cmd: "modprobe nouveau"
      Driver Info #2:
        Driver Status: nvidia is not active
        Driver Activation Cmd: "modprobe nvidia"
      Config Status: cfg=new, avail=yes, need=no, active=unknown
      Attached to: #9 (PCI bridge)
    
    Primary display adapter: #10
    System is up to date with latest patches. Any idea what might be going on? Just 'modprobe nvidia' also fails and yields the same error in the kernel log.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,734

    Default Re: Nvidia card (GTX660M) "not supported"??!?

    Quote Originally Posted by VintagePC View Post
    System is up to date with latest patches.
    Which system?
    Henk van Velden

  3. #3

    Default Re: Nvidia card (GTX660M) "not supported"??!?

    Quote Originally Posted by hcvv View Post
    Which system?
    DERP.

    OpenSuSE 13.1 x86_64, I mean all patches offered by the update notifier have been installed.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,285

    Default Re: Nvidia card (GTX660M) "not supported"??!?

    perhaps you had a kernel upgrade and may need to reinstall the NVIDIA driver

  5. #5

    Default Re: Nvidia card (GTX660M) "not supported"??!?

    Quote Originally Posted by gogalthorp View Post
    perhaps you had a kernel upgrade and may need to reinstall the NVIDIA driver
    Worth a shot. Will report back.

  6. #6

    Default Re: Nvidia card (GTX660M) "not supported"??!?

    Seems something may have gone wrong with my system upgrade when I went from 12.3->13.1, noticed some missing files for kernel development despite the packages being marked as installed. Am re-installing all packages to correct this using YaST's 'Update Unconditionally' option on all my installed packages.

    Seems weird that it would cause the nvidia module to load but report that it doesn't support the hardware. We'll see what happens.

  7. #7

    Default Re: Nvidia card (GTX660M) "not supported"??!?

    Global re-install/reboot seems to have fixed the issue.

    Have to say OpenSuse is one of the most resilient OSes I've seen to date... Flaky memory, flaky drives, missing system files.. it just keeps on chugging away but you occasionally get odd behaviour like this

  8. #8

    Exclamation Re: Nvidia card (GTX660M) "not supported"??!?

    HI,I have the same issue!!
    Code:
    hwinfo --gfxcard
    10: PCI 02.0: 0300 VGA compatible controller (VGA)              
      [Created at pci.319]
      Unique ID: _Znp.sup1nu1whb0
      SysFS ID: /devices/pci0000:00/0000:00:02.0
      SysFS BusID: 0000:00:02.0
      Hardware Class: graphics card
      Model: "Intel VGA compatible controller"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x0166 
      SubVendor: pci 0x17aa "Lenovo"
      SubDevice: pci 0x3977 
      Revision: 0x09
      Driver: "i915"
      Driver Modules: "drm"
      Memory Range: 0xd3000000-0xd33fffff (rw,non-prefetchable)
      Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
      I/O Ports: 0x4000-0x403f (rw)
      IRQ: 43 (85148 events)
      Module Alias: "pci:v00008086d00000166sv000017AAsd00003977bc03sc00i00"
      Driver Info #0:
        Driver Status: i915 is active
        Driver Activation Cmd: "modprobe i915"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
    
    22: PCI 100.0: 0300 VGA compatible controller (VGA)
      [Created at pci.319]
      Unique ID: VCu0.TNaaKfbGXi6
      Parent ID: vSkL.8VQuGwvrm1B
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "nVidia VGA compatible controller"
      Vendor: pci 0x10de "nVidia Corporation"
      Device: pci 0x0fd1 
      SubVendor: pci 0x17aa "Lenovo"
      SubDevice: pci 0x3977 
      Revision: 0xff
      Memory Range: 0xd2000000-0xd2ffffff (rw,non-prefetchable)
      Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
      Memory Range: 0xd0000000-0xd1ffffff (ro,non-prefetchable)
      I/O Ports: 0x3000-0x3fff (rw)
      IRQ: 16 (68264 events)
      Module Alias: "pci:v000010DEd00000FD1sv000017AAsd00003977bc03sc00i00"
      Driver Info #0:
        Driver Status: nvidiafb is not active
        Driver Activation Cmd: "modprobe nvidiafb"
      Driver Info #1:
        Driver Status: nouveau is not active
        Driver Activation Cmd: "modprobe nouveau"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #9 (PCI bridge)
    
    Primary display adapter: #10
    i am using GT650M and HD4000 optimus

  9. #9

    Default Re: Nvidia card (GTX660M) "not supported"??!?

    Quote Originally Posted by swift1911 View Post
    i am using GT650M and HD4000 optimus
    The standard nvidia driver does not work on Optimus system AFAIK.

    Either you can switch off the intel card in the BIOS settings, or you have to use Bumblebee.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •