Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: USB Stick does not show up in Device Manager in KDE

  1. #1

    Default USB Stick does not show up in Device Manager in KDE

    Hello,

    I have an openSuSE 12.1 server running fine but the day before yesterday some things stopped and a complete reboot was needed. After the reboot the file system on the primary disk needed to be repaired (ext4). I hoped everything is well but I discovered that some small things are not running well.

    This is one: If I plug-in a USB stick it is recognized according to /var/log/messages but the device manager in KDE does not pop up and does not offer to show the device in Dolphin etc. as this was in the past.

    Please can You give me some advice?

    Thank You!

    Bye

    honterus0

  2. #2

    Default AW: USB Stick does not show up in Device Manager in KDE

    Quote Originally Posted by honterus0 View Post
    Hello,

    I have an openSuSE 12.1 server running fine but the day before yesterday some things stopped and a complete reboot was needed. After the reboot the file system on the primary disk needed to be repaired (ext4). I hoped everything is well but I discovered that some small things are not running well.

    This is one: If I plug-in a USB stick it is recognized according to /var/log/messages but the device manager in KDE does not pop up and does not offer to show the device in Dolphin etc. as this was in the past.

    Please can You give me some advice?
    Does it show up in Dolphin? (there should be an icon in the panel, or just run it from the start menu, System->File Management).

    Could you please post the lines from /var/log/messages that indicate that the stick is recognized?

  3. #3

    Default Re: USB Stick does not show up in Device Manager in KDE

    Hello,

    this is a copy of the /var/log/messages after I inserted an USB stick:


    Feb 21 16:07:00 athlon kernel: [76832.982035] usb 1-5: new high speed USB device number 7 using ehci_hcd
    Feb 21 16:07:00 athlon kernel: [76833.097079] usb 1-5: New USB device found, idVendor=1845, idProduct=0104
    Feb 21 16:07:00 athlon kernel: [76833.097085] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    Feb 21 16:07:00 athlon kernel: [76833.097088] usb 1-5: Product: USB 2.0
    Feb 21 16:07:00 athlon kernel: [76833.097090] usb 1-5: SerialNumber: 2008101617312607839
    Feb 21 16:07:00 athlon kernel: [76833.098789] scsi14 : usb-storage 1-5:1.0
    Feb 21 16:07:01 athlon kernel: [76834.099673] scsi 14:0:0:0: Direct-Access USB 2.0 1.0 PQ: 0 ANSI: 4
    Feb 21 16:07:01 athlon kernel: [76834.101343] sd 14:0:0:0: Attached scsi generic sg7 type 0
    Feb 21 16:07:01 athlon kernel: [76834.101646] sd 14:0:0:0: [sdg] 2043904 512-byte logical blocks: (1.04 GB/998 MiB)
    Feb 21 16:07:01 athlon kernel: [76834.102142] sd 14:0:0:0: [sdg] Write Protect is off
    Feb 21 16:07:01 athlon kernel: [76834.102147] sd 14:0:0:0: [sdg] Mode Sense: 0b 00 00 08
    Feb 21 16:07:01 athlon kernel: [76834.102645] sd 14:0:0:0: [sdg] No Caching mode page present
    Feb 21 16:07:01 athlon kernel: [76834.102648] sd 14:0:0:0: [sdg] Assuming drive cache: write through
    Feb 21 16:07:01 athlon kernel: [76834.105399] sd 14:0:0:0: [sdg] No Caching mode page present
    Feb 21 16:07:01 athlon kernel: [76834.105406] sd 14:0:0:0: [sdg] Assuming drive cache: write through
    Feb 21 16:07:01 athlon kernel: [76834.106338] sdg: sdg1 sdg2
    Feb 21 16:07:01 athlon kernel: [76834.108400] sd 14:0:0:0: [sdg] No Caching mode page present
    Feb 21 16:07:01 athlon kernel: [76834.108407] sd 14:0:0:0: [sdg] Assuming drive cache: write through
    Feb 21 16:07:01 athlon kernel: [76834.108411] sd 14:0:0:0: [sdg] Attached SCSI removable disk

    I have some other disks installed in the server so /dev/sdg is true.
    In Dolphin the USB Stick is also not shown. I understand what You mean because I know it from other openSuSE 12.1 PCs.
    In the "Systemeinstellung / Geräteaktion" which would be something like "Systemsettings / Devices" or so there are some entries for optical media like CDROM and they are conected to Dolphin. Here I never changed anything and would not know what to do.

    BTW, I forgot to mention that I am able to mount the stick manually as root using shell commands, so the stick is there.

    Thanks

    honterus0


  4. #4

    Default AW: Re: USB Stick does not show up in Device Manager in KDE

    Quote Originally Posted by honterus0 View Post
    Hello,

    this is a copy of the /var/log/messages after I inserted an USB stick:


    Feb 21 16:07:00 athlon kernel: [76832.982035] usb 1-5: new high speed USB device number 7 using ehci_hcd
    Feb 21 16:07:00 athlon kernel: [76833.097079] usb 1-5: New USB device found, idVendor=1845, idProduct=0104
    Feb 21 16:07:00 athlon kernel: [76833.097085] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    Feb 21 16:07:00 athlon kernel: [76833.097088] usb 1-5: Product: USB 2.0
    Feb 21 16:07:00 athlon kernel: [76833.097090] usb 1-5: SerialNumber: 2008101617312607839
    Feb 21 16:07:00 athlon kernel: [76833.098789] scsi14 : usb-storage 1-5:1.0
    Feb 21 16:07:01 athlon kernel: [76834.099673] scsi 14:0:0:0: Direct-Access USB 2.0 1.0 PQ: 0 ANSI: 4
    Feb 21 16:07:01 athlon kernel: [76834.101343] sd 14:0:0:0: Attached scsi generic sg7 type 0
    Feb 21 16:07:01 athlon kernel: [76834.101646] sd 14:0:0:0: [sdg] 2043904 512-byte logical blocks: (1.04 GB/998 MiB)
    Feb 21 16:07:01 athlon kernel: [76834.102142] sd 14:0:0:0: [sdg] Write Protect is off
    Feb 21 16:07:01 athlon kernel: [76834.102147] sd 14:0:0:0: [sdg] Mode Sense: 0b 00 00 08
    Feb 21 16:07:01 athlon kernel: [76834.102645] sd 14:0:0:0: [sdg] No Caching mode page present
    Feb 21 16:07:01 athlon kernel: [76834.102648] sd 14:0:0:0: [sdg] Assuming drive cache: write through
    Feb 21 16:07:01 athlon kernel: [76834.105399] sd 14:0:0:0: [sdg] No Caching mode page present
    Feb 21 16:07:01 athlon kernel: [76834.105406] sd 14:0:0:0: [sdg] Assuming drive cache: write through
    Feb 21 16:07:01 athlon kernel: [76834.106338] sdg: sdg1 sdg2
    Feb 21 16:07:01 athlon kernel: [76834.108400] sd 14:0:0:0: [sdg] No Caching mode page present
    Feb 21 16:07:01 athlon kernel: [76834.108407] sd 14:0:0:0: [sdg] Assuming drive cache: write through
    Feb 21 16:07:01 athlon kernel: [76834.108411] sd 14:0:0:0: [sdg] Attached SCSI removable disk
    Yes, this looks fine (otherwise you wouldn't be able to mount it with mount either).

    KDE uses udisks2 for detecting and mounting removeable media. So maybe something's wrong there?
    Can you mount it manually with udisksctl? (as user)
    Code:
    udisksctl mount -b /dev/sdg1
    Can you try to create a new user and login as this? Does it work there?

    Since this started after a filesystem corruption, you should maybe try to reinstall some packages, in this case udisks2 and kdelibs4:
    Code:
    sudo zypper in -f udisks2 kdelibs4

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,673
    Blog Entries
    3

    Default Re: USB Stick does not show up in Device Manager in KDE

    Quote Originally Posted by honterus0 View Post
    This is one: If I plug-in a USB stick it is recognized according to /var/log/messages but the device manager in KDE does not pop up and does not offer to show the device in Dolphin etc. as this was in the past.
    What's on that USB?

    For me, device notifier pops up for a data USB, or for a live boot USB. But it does not pop up for a USB containing the install DVD image. Presumably some software does not recognize what is on the USB. I think it started behaving this way in opensuse 12.2. Earlier versions would also pop up to announce the DVD image on a USB.

    Although the device notifier does not announce the install DVD image, I can still manually mount it (with the "mount" command).
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  6. #6

    Default Re: AW: Re: USB Stick does not show up in Device Manager in KDE

    Quote Originally Posted by wolfi323 View Post
    Yes, this looks fine (otherwise you wouldn't be able to mount it with mount either).

    KDE uses udisks2 for detecting and mounting removeable media. So maybe something's wrong there?
    Can you mount it manually with udisksctl? (as user)
    Code:
    udisksctl mount -b /dev/sdg1
    Can you try to create a new user and login as this? Does it work there?

    Since this started after a filesystem corruption, you should maybe try to reinstall some packages, in this case udisks2 and kdelibs4:
    Code:
    sudo zypper in -f udisks2 kdelibs4
    Now we come closer. udisks --mount works in the shell for the user. But even more positive is that the problem is only related to the user I normally. I created a completely new user and it worked fine. So it has something to do with the personal settings of the user, where it is not working. If those settings are wrong it's because of the corrupted FS because I did not change things intentionally.

    Do You know, which while is controlling this stuff?

    Reinstalling the libs You proposed did not help but I think the problem lies in my personal corrupt settings.

    Thanks again

    honterus0

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,702
    Blog Entries
    1

    Default Re: AW: Re: USB Stick does not show up in Device Manager in KDE

    Quote Originally Posted by honterus0 View Post
    Now we come closer. udisks --mount works in the shell for the user. But even more positive is that the problem is only related to the user I normally. I created a completely new user and it worked fine. So it has something to do with the personal settings of the user, where it is not working. If those settings are wrong it's because of the corrupted FS because I did not change things intentionally.

    Do You know, which while is controlling this stuff?
    Well, the device notifier settings can be set (to notify or not) by right-clicking on the the notifier icon. (Mine is set to 'Removable devices only')

  8. #8

    Default Re: USB Stick does not show up in Device Manager in KDE

    Quote Originally Posted by honterus0 View Post
    Now we come closer. udisks --mount works in the shell for the user.
    No, "udisks --mount" uses udisks1, but KDE uses udisks2.
    Please try:
    Code:
    udisksctl mount -b /dev/sdg1
    That's the correct command for udisks2.


    Do You know, which while is controlling this stuff?
    Hm, I'm not sure what user settings could prevent the showing of the stick.
    Maybe ~/.kde4/share/config/kded_device_automounterrc?

    And check that the "Removable Device Automounter" service is enabled in "Configure Desktop"->"Startup and Shutdown"->"Service Management"

  9. #9

    Default Re: USB Stick does not show up in Device Manager in KDE

    Hello wolfi323,

    unfortunatelly there is no command like You mentioned and tried to look for a package udisk* but in openSuSE 12.1 here is only udisks and no udisks2.

    I looked in the kde config file You mentioned and at the bottom there is the following entry:

    [General]
    AutomountEnabled=true


    I guess the other entries refer to some device I used in the past.

    If we don't find the bug I will create a new user for me (instead I did this in the evening) and one works fine. Then I will move my data files over there.

    Thank you!

    honterus0

  10. #10

    Default Re: AW: Re: USB Stick does not show up in Device Manager in KDE

    Quote Originally Posted by deano_ferrari View Post
    Well, the device notifier settings can be set (to notify or not) by right-clicking on the the notifier icon. (Mine is set to 'Removable devices only')
    Hello,

    i checked both settings "Removable devices only" and "All devices" (I have the German KDE but this should be the meaning and both do not work.

    Thanks

    honterus0

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •