Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: How to Get HDMI Audio Output?

  1. #1
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question How to Get HDMI Audio Output?

    I tried a hardwire HDMI connection between my OSS 12.3 PC and a TV. The video comes through, but there is no audio. The audio from regular TV works fine. I would like to know how to setup the HDMI audio. Here are outputs from aplay:

    Code:
    randolph@linux-ppnb:~> aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 2: Microphone [Yeti Stereo Microphone], device 0: USB Audio [USB Audio]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    
    randolph@linux-ppnb:~> aplay -L
    null
        Discard all samples (playback) or generate zero samples (capture)
    default
        Default ALSA Output (currently PulseAudio Sound Server)
    sysdefault:CARD=SB
        HDA ATI SB, ALC892 Analog
        Default Audio Device
    front:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        Front speakers
    surround40:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Digital
        IEC958 (S/PDIF) Digital Audio Output
    hdmi:CARD=HDMI,DEV=0
        HDA ATI HDMI, HDMI 0
        HDMI Audio Output
    sysdefault:CARD=Microphone
        Yeti Stereo Microphone, USB Audio
        Default Audio Device
    front:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        Front speakers
    surround40:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        IEC958 (S/PDIF) Digital Audio Output
    Thanks in advance

  2. #2
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: How to Get HDMI Audio Output?

    Quote Originally Posted by HealingMindNOS View Post
    I tried a hardwire HDMI connection between my OSS 12.3 PC and a TV. The video comes through, but there is no audio. The audio from regular TV works fine. I would like to know how to setup the HDMI audio. Here are outputs from aplay:

    Code:
    randolph@linux-ppnb:~> aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 2: Microphone [Yeti Stereo Microphone], device 0: USB Audio [USB Audio]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    
    randolph@linux-ppnb:~> aplay -L
    null
        Discard all samples (playback) or generate zero samples (capture)
    default
        Default ALSA Output (currently PulseAudio Sound Server)
    sysdefault:CARD=SB
        HDA ATI SB, ALC892 Analog
        Default Audio Device
    front:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        Front speakers
    surround40:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Analog
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=SB,DEV=0
        HDA ATI SB, ALC892 Digital
        IEC958 (S/PDIF) Digital Audio Output
    hdmi:CARD=HDMI,DEV=0
        HDA ATI HDMI, HDMI 0
        HDMI Audio Output
    sysdefault:CARD=Microphone
        Yeti Stereo Microphone, USB Audio
        Default Audio Device
    front:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        Front speakers
    surround40:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    iec958:CARD=Microphone,DEV=0
        Yeti Stereo Microphone, USB Audio
        IEC958 (S/PDIF) Digital Audio Output
    Thanks in advance
    When I plug my computer into my TV via HDMI to get audio working I have to go to (in KDE)

    config desktop > multimedia > audio and video settings > audio hardware setup

    and change the profile.

    If I remeber correctly, I change it from analogue stereo duplex to one fo the HDMI options.
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  3. #3

    Default Re: How to Get HDMI Audio Output?

    Quote Originally Posted by HealingMindNOS View Post
    I would like to know how to setup the HDMI audio
    You've left out three crucial pieces of info:
    • which graphics adapter? ... from the output you've provided I can reasonably assume that its an AMD adapter we're talking about, but what exact one? (it does indeed matter)
    • which graphics driver stack are you using: the OSS drivers or the proprietary AMD drivers?
    • which DE are you using? gnome, kde, xfce....?

  4. #4
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question Re: How to Get HDMI Audio Output?

    Quote Originally Posted by farcusnz View Post
    When I plug my computer into my TV via HDMI to get audio working I have to go to (in KDE)

    config desktop > multimedia > audio and video settings > audio hardware setup

    and change the profile.

    If I remeber correctly, I change it from analogue stereo duplex to one fo the HDMI options.
    Thanks for your reply. I have played with the audio hardware set up under phonon. I applied and gave preference to the one HDMI output I have, but there is still no audio output, only video. It's a new cable from Fry's, but now I'm wondering since I got it cheap.

  5. #5
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question Re: How to Get HDMI Audio Output?

    Quote Originally Posted by Tyler_K View Post
    You've left out three crucial pieces of info:
    • which graphics adapter? ... from the output you've provided I can reasonably assume that its an AMD adapter we're talking about, but what exact one? (it does indeed matter)
    • which graphics driver stack are you using: the OSS drivers or the proprietary AMD drivers?
    • which DE are you using? gnome, kde, xfce....?
    Please tell me if I'm providing you with the correct info. Under KInfoCenter, I looked at graphical info>open gl>driver>vender: X.org; renderer: gallium 0.4 on AMD RS880.

    Please tell me how to look up the graphics driver stack.

    I'm using: KDE 4.10.5 "release 1" under 12.3. Thanks in advance.

  6. #6
    Join Date
    Mar 2008
    Location
    S.E.Asia
    Posts
    26,468
    Blog Entries
    36

    Default Re: How to Get HDMI Audio Output?

    Are you not using pulse audio volume control (pavucontrol) to control this ?

  7. #7

    Default Re: How to Get HDMI Audio Output?

    Quote Originally Posted by HealingMindNOS View Post
    Please tell me if I'm providing you with the correct info. Under KInfoCenter, I looked at graphical info>open gl>driver>vender: X.org; renderer: gallium 0.4 on AMD RS880.
    yes, that's fine ... tells us your using an RS880 based adapter (i.e. Radeon HD42xx )

    Please tell me how to look up the graphics driver stack.
    well, there are many ways by which it can by inferred, including what you provided above ... the presence of "gallium" in the output conveys the point that you're using the OSS driver stack

    I'm using: KDE 4.10.5 "release 1" under 12.3. Thanks in advance.
    okay, and it appears you already know where to make changes with that DE

    Now to the crux: add "radeon.audio=1" to your kernel boot line. Also see here for more info: http://forums.opensuse.org/showthrea...90#post2619490

  8. #8
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question Re: How to Get HDMI Audio Output?

    Quote Originally Posted by oldcpu View Post
    Are you not using pulse audio volume control (pavucontrol) to control this ?
    I just now looked this up in yast. I definitely do not have pavucontrol. Should I?

  9. #9
    Join Date
    Aug 2010
    Location
    California
    Posts
    190

    Question Re: How to Get HDMI Audio Output?

    Quote Originally Posted by Tyler_K View Post
    Now to the crux: add "radeon.audio=1" to your kernel boot line. Also see here for more info: http://forums.opensuse.org/showthrea...90#post2619490
    I really appreciate the info. BTW, how do I find the default setting in case I want to put it back?

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,536

    Default Re: How to Get HDMI Audio Output?

    If you followed the injunction the the thread just go to yast and remove radeon.audio=1 from the boot line

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •