Results 1 to 6 of 6

Thread: NvidiaG03 Treiber für GeForce GT 430 GF108?

  1. #1
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default NvidiaG03 Treiber für GeForce GT 430 GF108?

    Hallo,
    kann ich für meine Grafikkarte: NVIDIA GeForce GT 430 (GF108) unter openSUSE 13.1 den Treiber aus dem nvidiaG03 Packet verwenden?
    die Anleitungen die ich gefunden habe sehen nach dem hinzufügen des Repositorys noch vor einen speziellen Treiber zu installieren. Für das G03 Packet gilt ja : GeForce 8xxx and newer
    aber ich bin nicht sicher wo ich meine Karte hier einordnen soll. Die GT 430 kam ja mit den GTX Karten und die kamen ja nach der 8000er Serie oder irre ich mich hier?
    Last edited by sabo007; 19-Feb-2014 at 09:41. Reason: missed question mark in the title

  2. #2

    Default Re: NvidiaG03 Treiber für GeForce GT 430 GF108?

    Quote Originally Posted by sabo007 View Post
    Die GT 430 kam ja mit den GTX Karten und die kamen ja nach der 8000er Serie oder irre ich mich hier?
    Nein, das ist richtig.
    Die GT430 wird vom aktuellen G03 (331.xx) Treiber unterstützt.

    Allerdings würde ich raten, den Treiber mit YaST->Software installieren/löschen statt über den 1-click zu installieren. (das Repository kannst du in YaST->Sofware-Repositories->Hinzufügen->Community/Gemeinschafts-Repositories aktivieren falls noch nicht geschehen)
    Bitte darauf achten, dass folgende Pakete installiert werden (falls nicht, evtl. manuell die Auswahl ändern):
    nvidia-gfxG03-kmp-desktop (wenn kernel-desktop benutzt wird, ansonsten halt das entsprechende Paket), x11-video-nvidiaG03, nvidia-glG03, nvidia-computeG03

    Unter bestimmten Voraussetzungen könnte es nämlich passieren, dass das falsche kmp Paket installiert, bzw. nvidia-glG03 nicht installiert wird (das letztere benötigt man aber für 3D Unterstützung).

  3. #3
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default Re: NvidiaG03 Treiber für GeForce GT 430 GF108?

    Vielen Dank.
    den one click installer wollte ich sowieso nicht nutzen, ich wollte es via Zypper machen, wie hier beschrieben:
    https://en.opensuse.org/SDB:NVIDIA_d...repository_way

    Das heist, erst das Repository hinzufügen:
    Code:
    zypper ar -f ftp://download.nvidia.com/opensuse/13.1/ nvidia
    dann den Treiber via:
    Code:
    zypper install x11-video-nvidiaG03
    Meinst du ich sollte jetzt noch speziell den Desktop Treiber installieren?

  4. #4

    Default Re: NvidiaG03 Treiber für GeForce GT 430 GF108?

    Quote Originally Posted by sabo007 View Post
    Das heist, erst das Repository hinzufügen:
    Code:
    zypper ar -f ftp://download.nvidia.com/opensuse/13.1/ nvidia
    Wie gesagt, das kannst du auch via YaST machen, aber ganz wie du willst.
    Ist egal, zypper und YaST benutzen sowieso die gleichen Repos.

    dann den Treiber via:
    Code:
    zypper install x11-video-nvidiaG03
    Meinst du ich sollte jetzt noch speziell den Desktop Treiber installieren?
    Tja, wenn du nur x11-video-nvidiaG03 installierst, _könnte_ es die von mir angesprochenen Probleme geben. (das ist im Endeffekt genau das, was der 1-Click Install macht)

    Schau halt, dass die richtigen Pakete mit eingezogen werden (sh. Liste vorher).
    Notfalls gib die anderen im "zypper" Befehl mit an.

    Welches kmp Paket du brauchst, sollte "uname -a" sagen...

  5. #5
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default Re: NvidiaG03 Treiber für GeForce GT 430 GF108?

    Ich habs geschaft. Allerdings habe ich nur das Repository hinzugefügt und dann einfach rebooten lassen (ginge vielleicht auch ohne) danach habe ich einfach die Packete aktualisiert/geupdatet, dabei wurden automatisch die richtigen Packete/Treiber erkannt bzw. ausgewählt. In meinem Fall war es unter anderem der G03-Desktop Treiber.

  6. #6

    Default Re: NvidiaG03 Treiber für GeForce GT 430 GF108?

    Ich habs geschaft. Allerdings habe ich nur das Repository hinzugefügt und dann einfach rebooten lassen (ginge vielleicht auch ohne)
    Rebooten musst du nur _nach_ Installation des Treibers, damit er geladen wird.

    danach habe ich einfach die Packete aktualisiert/geupdatet, dabei wurden automatisch die richtigen Packete/Treiber erkannt bzw. ausgewählt. In meinem Fall war es unter anderem der G03-Desktop Treiber.
    Ja, normalerweise sollten automatisch die richtigen Pakete ausgewählt werden (abhängig von der verwendeten Grafikkarte und Kernel).
    Aber es gibt halt Situationen, in denen das nicht richtig funktioniert, ich wollte nur darauf hinweisen. Und es ist wahrscheinlich besser, die Pakete die installiert werden kurz zu kontrollieren, als dann Probleme zu haben.

    Aber freut mich, dass alles geklappt hat!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •