Results 1 to 2 of 2

Thread: MacBook Pro Keybord issues on openSUSE KDE

  1. #1
    Join Date
    Jan 2014
    Location
    Phx Az USA
    Posts
    7

    Default MacBook Pro Keybord issues on openSUSE KDE

    I installed openSUSE KDE 13.1 on my late 2011 MacBook Pro 13in screen (this has the Intel i7, and Intel 3000 graphics). Just about everything worked minus the Alt key and the keyboard backlight. After googling around I found out about pommed. Pommed helped the backlight issue (meaning the backlight came on but I could not adjust it, like I could the volume and display brightness with the fn + function keys), but still couldn't use the Alt button.

    My test for the Alt button was I map Ctrl+Alt and the arrow keys to switch workspaces.

    I saw in the repos pommed has some GUI controllers but I could not get them to load (I could see one of them was gtk).

    For now I am running openSUSE 13.1 Gnome (which works out of the box perfectly, minus installing the proper wifi driver, even the apple remote works on Gnome).

    Any ideas on fixing the Alt key issue?

    P.S. Upon adding tags to this post I see that macbook keyboard is a popular tag, so I will continue searching the form, any links and /or help is appreciated

  2. #2
    Join Date
    Jan 2014
    Location
    Phx Az USA
    Posts
    7

    Default Re: MacBook Pro Keybord issues on openSUSE KDE

    So I have it figured out. Referring to this thread (https://forums.opensuse.org/showthre...cbook+keyboard) I found that if you go to Configure Desktops>Input Devices>Keyboard, select the layouts tab. There you will see an input for 3Rd Level Short Cuts. Click that. Here you will See Any Alt Key checked. Uncheck this, and it should work.

    Please note that this may not work on all devices but worked for me

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •