Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: kwin global shortcuts disappear after apper update

Hybrid View

  1. #1

    Default kwin global shortcuts disappear after apper update

    Hello:

    After a re-boot and log-in here, opensuse 13.1 takes "forever" (I get up and get a snack) to settle down, during which time it cycles through all the desktops every time the mouse is moved or a desktop (any desktop, whichever one happens to be current at the moment) is clicked. When it finally settles down (after 2 or 3 min. or more) and stays on one desktop, kwin global shortcuts have disappeared. This has been plaguing me since the last major barrage of updates came in, when apper installed about 32 of them and effectively broke the system.

    I've read http://www.freetechie.com/blog/kde-4...ortcut-issues/ that this can be fixed, (if ever so temporarily - until the next boot, on this machine) by using the command [ #kwin --replace ]. Here is the response I get for the command:

    Code:
    # kwin --replace
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    X Error: BadWindow (invalid Window parameter) 3
      Major opcode: 20 (X_GetProperty)
      Resource id:  0x220001d
    kbuildsycoca4 running...
    X Error: BadWindow (invalid Window parameter) 3
      Major opcode: 20 (X_GetProperty)
      Resource id:  0x220001d
    X Error: BadWindow (invalid Window parameter) 3
      Major opcode: 20 (X_GetProperty)
      Resource id:  0x220001d
    QObject::connect: Cannot connect (null)::resourceScoreUpdated(QString, QString, QString, double) to NepomukPlugin::resourceScoreUpdated(QString, QString, QString, double)
    QObject::connect: Cannot connect (null)::recentStatsDeleted(QString, int, QString) to NepomukPlugin::deleteRecentStats(QString, int, QString)
    QObject::connect: Cannot connect (null)::earlierStatsDeleted(QString, int) to NepomukPlugin::deleteEarlierStats(QString, int)
    kactivitymanagerd(1849)/nepomuk (library): Could not find virtuoso to connect to. Aborting
    QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
    QFileSystemWatcher: failed to add paths: /root/.kde4/share/config/activitymanager-pluginsrc
    QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.7'
    OpenGL vendor string:                   X.Org
    OpenGL renderer string:                 Gallium 0.4 on AMD RS880
    OpenGL version string:                  3.0 Mesa 9.2.3
    OpenGL shading language version string: 1.30
    Driver:                                 R600G
    GPU class:                              R600
    OpenGL version:                         3.0
    GLSL version:                           1.30
    Mesa version:                           9.2.3
    X server version:                       1.14.3
    Linux kernel version:                   3.11.10
    Direct rendering:                       yes
    Requires strict binding:                no
    GLSL shaders:                           yes
    Texture NPOT support:                   yes
    Virtual Machine:                        no
    kbuildsycoca4 running...
    When it reaches that last line - "kbuildsycoca4 running..." - it simply stops, never seems to do anything more, never finishes whatever it's doing, and I have no keyboard nor mouse; I must push the button. When the system comes back up, I usually (not always) have my keyboard "shorts" back again until the next reboot, for whatever reason. It's a real pain in the tuchus.

    Regarding the result, above, of the [ #kwin --replace ] command, I wonder that kwin works at all, and what else is missing/broken that it's trying to connect with to "--replace" from.

    The bug report: https://bugs.kde.org/show_bug.cgi?id=216857 indicates that KDE thinks the problem is "upstream" with Qt, but that doesn't seem to do much to fix anything.

    Any thoughts on an opensuse fix for this?

    openSUSE-13.1-KDE-x86_64 | KDE 4.11.5 | sda=80GB Ext4 | sdb=500GB Ext4
    AMD Athlon II X4 640 3.0GHz | Gigabyte GA-880GA-UD3H (rev. 3.1) | DDR3-1333 8GB
    ATI Radeon HD 4250 graphics (DirectX10.1) | Firefox 27.0 | Thunderbird 24.3.0

  2. #2

    Default Re: kwin global shortcuts disappear after apper update

    Quote Originally Posted by Maximillium View Post
    The bug report: https://bugs.kde.org/show_bug.cgi?id=216857 indicates that KDE thinks the problem is "upstream" with Qt, but that doesn't seem to do much to fix anything.
    That bug report is 4 years old! Apparently there was a bug in Qt between 4.6.0 and 4.6.1, we are at 4.8.5 now and this has long been fixed.
    So ignore that bug report please.

    Apparently you have a problem with kded.
    Try to disable all services in "Configure Desktop" (systemsettings)->Startup and Shutdown->Service Management, except "Keyboard Shortcuts". (remember which ones were enabled)
    Does it work then? (after logout/login, or a reboot)

    If yes, enable them one-by-one again to see which one is causing this.

    The desktop cycling problem seems to be mouse/rouchpad related. By default the desktop is switched by using the mouse wheel on the desktop (this can be configured by right-clicking on the desktop and choosing "Default Desktop Settings" and clicking on "Mouse Actions" there).
    Are you using a touchpad? Then this could be caused by the synaptiks service and therefore be related to the first problem.

  3. #3

    Default Re: kwin global shortcuts disappear after apper update

    Quote Originally Posted by wolfi323 View Post
    That bug report is 4 years old! Apparently there was a bug in Qt between 4.6.0 and 4.6.1, we are at 4.8.5 now and this has long been fixed.
    So ignore that bug report please.

    Apparently you have a problem with kded.
    Try to disable all services in "Configure Desktop" (systemsettings)->Startup and Shutdown->Service Management, except "Keyboard Shortcuts". (remember which ones were enabled)
    Does it work then? (after logout/login, or a reboot)

    If yes, enable them one-by-one again to see which one is causing this.

    The desktop cycling problem seems to be mouse/rouchpad related. By default the desktop is switched by using the mouse wheel on the desktop (this can be configured by right-clicking on the desktop and choosing "Default Desktop Settings" and clicking on "Mouse Actions" there).
    Are you using a touchpad? Then this could be caused by the synaptiks service and therefore be related to the first problem.
    Thanks, Wolfi - I'll try that a bit later. It's 4 A.M. here and I'm crashing. I'll let you know what happens when I do....

  4. #4

    Default Re: kwin global shortcuts disappear after apper update

    Hello again:
    Quote Originally Posted by wolfi323 View Post
    Try to disable all services in "Configure Desktop" (systemsettings)->Startup and Shutdown->Service Management, except "Keyboard Shortcuts". (remember which ones were enabled)
    Does it work then? (after logout/login, or a reboot)
    Tried it with all but "Keyboard Shortcuts" disabled, even tried it with everything disabled. No change.
    Quote Originally Posted by wolfi323 View Post
    The desktop cycling problem seems to be mouse/touchpad related. By default the desktop is switched by using the mouse wheel on the desktop (this can be configured by right-clicking on the desktop and choosing "Default Desktop Settings" and clicking on "Mouse Actions" there).
    Are you using a touchpad? Then this could be caused by the synaptiks service and therefore be related to the first problem.
    I don't have synaptic loaded - that I know of - don't have a touchpad nor a mouse wheel. I use a Logitech 4-button trackball, not that I know what the other two buttons do. They haven't ever seemed to be supported in opensuse anyway.

    I have issues with the result of [#kwin --replace] anyway, as follows:
    Code:
    # kwin --replace 
    Connecting to deprecated signal
    Deprecated signal?

    Code:
    QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
    X Error: BadWindow (invalid Window parameter) 3
      Major opcode: 20 (X_GetProperty)
      Resource id:  0x1e0001d
    kbuildsycoca4 running...
    X Error: BadWindow (invalid Window parameter) 3
      Major opcode: 20 (X_GetProperty)
      Resource id:  0x1e0001d
    X Error: BadWindow (invalid Window parameter) 3
      Major opcode: 20 (X_GetProperty)
      Resource id:  0x1e0001d
    QDBusConnectionInterface and kbuildsycoca4 both have problems with window parameters?

    Code:
    QObject::connect: Cannot connect (null)::resourceScoreUpdated(QString, QString, QString, double) to NepomukPlugin::resourceScoreUpdated(QString, QString, QString, double)
    QObject::connect: Cannot connect (null)::recentStatsDeleted(QString, int, QString) to NepomukPlugin::deleteRecentStats(QString, int, QString)
    QObject::connect: Cannot connect (null)::earlierStatsDeleted(QString, int) to NepomukPlugin::deleteEarlierStats(QString, int)
    QObjects can't find the NepomukPlugin?

    Code:
    kactivitymanagerd(5577)/nepomuk (library): Could not find virtuoso to connect to. Aborting
    Could not find a virtuoso? I can find them all over youtube.

    Code:
    QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
    QFileSystemWatcher: failed to add paths: /root/.kde4/share/config/activitymanager-pluginsrc
    Hard to add a Path to something that ain't there. Why isn't it there?

    Code:
    QDBusConnection: name 'org.kde.kglobalaccel' had owner '' but we thought it was ':1.7'
    So whose is it?

    Code:
    OpenGL vendor string:                   X.Org
    OpenGL renderer string:                 Gallium 0.4 on AMD RS880
    OpenGL version string:                  3.0 Mesa 9.2.3
    OpenGL shading language version string: 1.30
    Driver:                                 R600G
    GPU class:                              R600
    OpenGL version:                         3.0
    GLSL version:                           1.30
    Mesa version:                           9.2.3
    X server version:                       1.14.3
    Linux kernel version:                   3.11.10
    Direct rendering:                       yes
    Requires strict binding:                no
    GLSL shaders:                           yes
    Texture NPOT support:                   yes
    Virtual Machine:                        no
    kbuildsycoca4 running...
    and running, and running, and then, after (Ctrl-C):

    Code:
    Object::connect: No such signal org::freedesktop::UPower::DeviceAdded(QDBusObjectPath)
    Object::connect: No such signal org::freedesktop::UPower::DeviceRemoved(QDBusObjectPath)
    then, after mousing to editor and back to konsole:

    Code:
    kglobalaccel(5581)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Not connected to server"
    kglobalaccel(5581)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Not connected to server"
    kglobalaccel(5581)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Not connected to server"
    No keyboard [alt-tab] between screens now. I think I'm lucky to have both programs already open and a mouse that still works.

    Booting again, now ... well, maybe.... No [Ctrl-Alt-F2] now, anything from keyboard only adds more "Not connected to server" lines to konsole like those above....

    Guys, regardless of the age of a bug report, I sincerely believe kwin is currently hosed. Either that or the environment around it is no longer compatible. The way it is now simply sucks, when the function that is supposed to replace/rebuild it can't find anything it looks for. The question is what to do about it now?

    Going for the reset button again....

  5. #5

    Default Re: kwin global shortcuts disappear after apper update

    Quote Originally Posted by Maximillium View Post
    I don't have synaptic loaded - that I know of - don't have a touchpad nor a mouse wheel. I use a Logitech 4-button trackball, not that I know what the other two buttons do. They haven't ever seemed to be supported in opensuse anyway.
    But the synaptiks service is activated by default AFAIK, so maybe that could have interfered (although it shouldn't if there is no touchpad present).

    I have issues with the result of [#kwin --replace] anyway, as follows:
    Code:
    # kwin --replace 
    Connecting to deprecated signal
    Deprecated signal?
    Right, that's strange. I don't see that here.

    Code:
    kactivitymanagerd(5577)/nepomuk (library): Could not find virtuoso to connect to. Aborting
    Could not find a virtuoso? I can find them all over youtube.
    Virtuoso is Nepomuk's database storage backend.

    Code:
    QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
    QFileSystemWatcher: failed to add paths: /root/.kde4/share/config/activitymanager-pluginsrc
    Hard to add a Path to something that ain't there. Why isn't it there?
    And why /root/.kde4/share/config/activitymanager-pluginsrc? Are you running it as root?

    Code:
    kglobalaccel(5581)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Not connected to server"
    kglobalaccel(5581)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Not connected to server"
    kglobalaccel(5581)/kdeui (KNotification) KNotification::slotReceivedIdError: Error while contacting notify daemon "Not connected to server"
    Could be because you disabled all kded services I guess.

    Booting again, now ... well, maybe.... No [Ctrl-Alt-F2] now, anything from keyboard only adds more "Not connected to server" lines to konsole like those above....
    Hm, Ctrl+Alt+F2 (to switch to a text console) has nothing to do with KDE. That's a feature of X directly.
    Or do you mean Alt+F2 to open krunner?

    Guys, regardless of the age of a bug report, I sincerely believe kwin is currently hosed. Either that or the environment around it is no longer compatible. The way it is now simply sucks, when the function that is supposed to replace/rebuild it can't find anything it looks for. The question is what to do about it now?
    Again, forget that bug report. That particular bug has been fixed ages ago (and only was in a pre-release version).
    And what you are experiencing is certainly _no_ general problem in kwin or anything, otherwise it would not be only you to experience this, no?
    Please try to create a new user (with YaST->Security and Users->User and Group Management f.e.), login as that user and see if the problem exists there, too.

    Maybe not all necessary packages got updated for some reason?
    Please try to run "sudo zypper up" manually in Konsole and post the output.

    And please also post the output of:
    Code:
    zypper lr -d
    Last edited by wolfi323; 19-Feb-2014 at 03:37.

  6. #6

    Default Re: kwin global shortcuts disappear after apper update

    Back to this, finally, had other business to attend (got through the income tax appointment)
    Quote Originally Posted by wolfi323 View Post
    But the synaptiks service is activated by default AFAIK, so maybe that could have interfered (although it shouldn't if there is no touchpad present).
    I have disabled synaptiks so irrelevant now.


    Virtuoso is Nepomuk's database storage backend.
    And why /root/.kde4/share/config/activitymanager-pluginsrc? Are you running it as root?
    Could be because you disabled all kded services I guess.
    libnepomukwidgets4, nepomuk-core, & python-kde4-nepomuk all show as installed in yast2
    I checked yast, see kded not even installed. Should it be?


    Hm, Ctrl+Alt+F2 (to switch to a text console) has nothing to do with KDE. That's a feature of X directly.
    Or do you mean Alt+F2 to open krunner?
    Nope - I was looking anything that would work to get out of the frozen condition after [kwin --replace] finished whatever it wasn't doing.


    Again, forget that bug report. That particular bug has been fixed ages ago (and only was in a pre-release version).
    And what you are experiencing is certainly _no_ general problem in kwin or anything, otherwise it would not be only you to experience this, no?
    Please try to create a new user (with YaST->Security and Users->User and Group Management f.e.), login as that user and see if the problem exists there, too.

    What bug report?
    I tried the "new user" but got same result. MY kwin is busted.

    Maybe not all necessary packages got updated for some reason?
    Please try to run "sudo zypper up" manually in Konsole and post the output.
    Code:
    ~>
    ~> sudo zypper up
    Loading repository data...
    Reading installed packages...
    
    The following 2 package updates will NOT be installed:
      k3b xine-ui
    
    Nothing to do.
    ~>
    And please also post the output of:
    Code:
    zypper lr -d
    Code:
    ~> sudo zypper lr -d
    root's password:
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                  | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+----------------------------------------------------------------------+--------
     1 | Fonts:_Version_13.1       | openSUSE-13.1-Fonts                | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/M17N:/fonts/openSUSE_13.1/ |        
     2 | ftp.gwdg.de-suse_2        | Packman Repository                 | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_13.1/             |        
     3 | opensuse-guide.org-repo   | libdvdcss repository               | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                 |        
     4 | repo-debug                | openSUSE-13.1-Debug                | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/       |        
     5 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | No      |   99     | rpm-md | http://download.opensuse.org/debug/update/13.1/                      |        
     6 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/              |        
     7 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/         |        
     8 | repo-oss                  | openSUSE-13.1-Oss                  | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/             |        
     9 | repo-source               | openSUSE-13.1-Source               | No      | No      |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/      |        
    10 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                            |        
    11 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                    |        
    chuck@PEGASUS:~>
    The diffuglety here is when I try to invoke [kwin --replace] to try to copy the result to this dialog, it locks me up and I have to to a hard reset to get back in. I would have sent this an hour ago but had to start over from scratch after the lock-up and re-boot logged me out of everything....
    openSUSE-LEAP 15.0 KDE-x86_64
    Gigabyte GA-F2A88X-D3HP (rev. 1.0) | 16GB DDR3-1866
    AMD 880G + SB850 Chipset | ATI Radeon HD 4250 (DirectX10.1)
    sda=80GB Ext4 | sdb&sdc=500GB Ext4 | sdd=1T Ext4
    Firefox 60.6.1esr(64-bit) | Thunderbird 60.6.1(64-bit)

  7. #7

    Default Re: kwin global shortcuts disappear after apper update

    Quote Originally Posted by Maximillium View Post
    libnepomukwidgets4, nepomuk-core, & python-kde4-nepomuk all show as installed in yast2
    I checked yast, see kded not even installed. Should it be?
    kded4 is part of kdelibs4. That's installed for sure, as without it you couldn't even run KDE...

    Nope - I was looking anything that would work to get out of the frozen condition after [kwin --replace] finished whatever it wasn't doing.
    Well, if Ctrl+Alt+F2 does not work, it's most likely a graphics driver issue. Nothing to do with KDE as I said already.

    Have you tried to boot to "Recovery Mode" (Advanced Options in the boot menu) already as a test?

    What bug report?
    The bug report you linked to in your first post already, about that global shortcut issue in Qt 4.6.0+.

    I tried the "new user" but got same result. MY kwin is busted.
    I doubt that kwin is busted.
    As kwin doesn't have anything to do with global shortcuts.

    It's more likely X itself acting up. Could you maybe post /var/log/Xorg.0.log (use http://susepaste.org), maybe that contains something interesting.

    Code:
    ~> sudo zypper lr -d
    Looks ok.

    The diffuglety here is when I try to invoke [kwin --replace] to try to copy the result to this dialog, it locks me up and I have to to a hard reset to get back in. I would have sent this an hour ago but had to start over from scratch after the lock-up and re-boot logged me out of everything....
    Try to kill kwin and then restart it:
    Code:
    killall -KILL kwin ; kwin
    But again, the next thing I'd suggest to try is to boot to "Recovery Mode".
    If that only brings you to text mode, try a normal boot with "nomodeset" added to the boot options.
    Press 'e' at the boot menu, search for a line starting with "linux" and append "nomodeset" at the end of the line. Then press 'F10' to boot.

  8. #8

    Default Re: kwin global shortcuts disappear after apper update

    Quote Originally Posted by wolfi323 View Post
    kded4 is part of kdelibs4. That's installed for sure, as without it you couldn't even run KDE...

    Well, if Ctrl+Alt+F2 does not work, it's most likely a graphics driver issue. Nothing to do with KDE as I said already.

    Have you tried to boot to "Recovery Mode" (Advanced Options in the boot menu) already as a test?
    Yup - tried that. No joy.


    The bug report you linked to in your first post already, about that global shortcut issue in Qt 4.6.0+.
    Heh heh - the one you told me to "forget about"?


    I doubt that kwin is busted.
    As kwin doesn't have anything to do with global shortcuts.
    Excuse me - but ["Configure Desktop" > "Common Appearance and Behavior" > "Shortcuts and Gestures" > "Global Keyboard Shortcuts" > "KDE Component dropdown" > "Kwin"] has nothing to do with "Kwin"? Now I AM confused.


    It's more likely X itself acting up. Could you maybe post /var/log/Xorg.0.log (use http://susepaste.org), maybe that contains something interesting.
    http://susepaste.org/9291765 - hope something shows up....


    Try to kill kwin and then restart it:
    Code:
    killall -KILL kwin ; kwin
    But again, the next thing I'd suggest to try is to boot to "Recovery Mode".
    If that only brings you to text mode, try a normal boot with "nomodeset" added to the boot options.
    Press 'e' at the boot menu, search for a line starting with "linux" and append "nomodeset" at the end of the line. Then press 'F10' to boot.
    Thanks, Wolfi, for hanging in with me here. I'm going to do the "kill" option next, and then try the "nomodeset" option. I fully expect to be locked up again within the next couple of minutes.
    openSUSE-LEAP 15.0 KDE-x86_64
    Gigabyte GA-F2A88X-D3HP (rev. 1.0) | 16GB DDR3-1866
    AMD 880G + SB850 Chipset | ATI Radeon HD 4250 (DirectX10.1)
    sda=80GB Ext4 | sdb&sdc=500GB Ext4 | sdd=1T Ext4
    Firefox 60.6.1esr(64-bit) | Thunderbird 60.6.1(64-bit)

  9. #9

    Default Re: kwin global shortcuts disappear after apper update

    Thanks, Wolfi, for hanging in with me here. I'm going to do the "kill" option next, and then try the "nomodeset" option. I fully expect to be locked up again within the next couple of minutes.
    Additional info at 7:45 PM, PST:

    http://susepaste.org/30749153 - after a regular shutdown & boot to "recovery mode". I never saw a place to enter an "e", so it was sans that option. Maybe next time I will see it.

    NOW I'll try the "kill" option....
    openSUSE-LEAP 15.0 KDE-x86_64
    Gigabyte GA-F2A88X-D3HP (rev. 1.0) | 16GB DDR3-1866
    AMD 880G + SB850 Chipset | ATI Radeon HD 4250 (DirectX10.1)
    sda=80GB Ext4 | sdb&sdc=500GB Ext4 | sdd=1T Ext4
    Firefox 60.6.1esr(64-bit) | Thunderbird 60.6.1(64-bit)

  10. #10
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,789

    Default Re: kwin global shortcuts disappear after apper update

    At grub you just type an e to go to edit mode for the current selected option. There is no "place" to do it just type it

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •