Results 1 to 7 of 7

Thread: need module audioop

  1. #1
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    584

    Default need module audioop

    To use papagayo i need.
    ImportError: No module named audioop

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,399

    Default Re: need module audioop

    You should realy be more talkative. We are not clairvoyant.

    What version of openSUSE. Where do you get that message (on installation, on usage)?
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    584

    Default Re: need module audioop

    Thought you could see which opensuse version I use.
    Opensuse 12.3 64 bits application papagayo .
    Audioop module is needed for python I think.
    Started python papagayo.py

  4. #4
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    584

    Default Re: need module audioop

    Code:
    anton@linux-ws:~/papagayo-master> python papagayo.py
    Traceback (most recent call last):
      File "papagayo.py", line 25, in <module>
        from LipsyncFrame import LipsyncFrame
      File "/home/anton/papagayo-master/LipsyncFrame.py", line 30, in <module>
        from WaveformView import WaveformView
      File "/home/anton/papagayo-master/WaveformView.py", line 29, in <module>
        from LipsyncDoc import *
      File "/home/anton/papagayo-master/LipsyncDoc.py", line 26, in <module>
        import SoundPlayer
      File "/home/anton/papagayo-master/SoundPlayer.py", line 2, in <module>
        import audioop
    ImportError: No module named audioop
    anton@linux-ws:~/papagayo-master>

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,244
    Blog Entries
    15

    Default Re: need module audioop

    On Tue 18 Feb 2014 03:16:01 PM CST, anton wrote:


    Code:
    --------------------
    anton@linux-ws:~/papagayo-master> python papagayo.py
    Traceback (most recent call last):
    File "papagayo.py", line 25, in <module>
    from LipsyncFrame import LipsyncFrame
    File "/home/anton/papagayo-master/LipsyncFrame.py", line 30, in
    <module> from WaveformView import WaveformView
    File "/home/anton/papagayo-master/WaveformView.py", line 29, in
    <module> from LipsyncDoc import *
    File "/home/anton/papagayo-master/LipsyncDoc.py", line 26, in <module>
    import SoundPlayer
    File "/home/anton/papagayo-master/SoundPlayer.py", line 2, in <module>
    import audioop
    ImportError: No module named audioop
    anton@linux-ws:~/papagayo-master>


    --------------------


    Hi
    The module is not compiled into python by default (seems to be a
    security risk), the version from here doesn't have it...
    http://www.lostmarble.com/papagayo/

    So you would need to re-comile python and enable audioop probably.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,244
    Blog Entries
    15

    Default Re: need module audioop

    On Tue 18 Feb 2014 04:11:29 PM CST, malcolmlewis wrote:

    On Tue 18 Feb 2014 03:16:01 PM CST, anton wrote:


    Code:
    --------------------
    anton@linux-ws:~/papagayo-master> python papagayo.py
    Traceback (most recent call last):
    File "papagayo.py", line 25, in <module>
    from LipsyncFrame import LipsyncFrame
    File "/home/anton/papagayo-master/LipsyncFrame.py", line 30, in
    <module> from WaveformView import WaveformView
    File "/home/anton/papagayo-master/WaveformView.py", line 29, in
    <module> from LipsyncDoc import *
    File "/home/anton/papagayo-master/LipsyncDoc.py", line 26, in <module>
    import SoundPlayer
    File "/home/anton/papagayo-master/SoundPlayer.py", line 2, in <module>
    import audioop
    ImportError: No module named audioop
    anton@linux-ws:~/papagayo-master>


    --------------------


    Hi
    The module is not compiled into python by default (seems to be a
    security risk), the version from here doesn't have it...
    http://www.lostmarble.com/papagayo/

    So you would need to re-comile python and enable audioop probably.

    Hi
    If you look at the build logs on OBS, you can see the module being
    removed,
    Code:
    rm /home/abuild/rpmbuild/BUILDROOT/python-2.7.6-10.1.i386/usr/lib/python2.7/lib-dynload/audioop.so
    It's also removed in the 2.7.5 version.

    Maybe raise a bug on this?

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  7. #7
    Join Date
    Jun 2008
    Location
    netherlands
    Posts
    584

    Default Re: need module audioop

    okay thanks good to know

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •