Results 1 to 5 of 5

Thread: Speaker Configuration

  1. #1

    Unhappy Speaker Configuration

    Hello Guys!

    I am using OpenSuse 13.1 with KDE and i have a small issue. First of all i cannot get any sound to play when i plug the audio system jack into the hdmi output of the soundcard. I do have sound when i am using the analog output but here's the issue: i can only get the sound on one of the two speakers and the subwoofer.
    I have specified the hdmi issue in the beggining of the post because i have tested the sound on Windows aswell just to see if there's a issue with the audio card or speakers and on Windows i can get the sound working an all the speakers only through the hdmi output.
    My question is, can i get the sound working properly on all the speakers , regardless of the output? ( i do not care if it's hdmi or analog as long as it gets the job done).


    System specs: AMD A4 CPU 5300 with AMD Radeon HD 7480D integrated, Audio: Realtek ALC887 integrated.


    aplay -l output:

    **** List of PLAYBACK Hardware Devices ****
    card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 1: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog]
    Subdevices: 0/1
    Subdevice #0: subdevice #0

    aplay -L


    Discard all samples (playback) or generate zero samples (capture)
    default
    Default ALSA Output (currently PulseAudio Sound Server)
    hdmi:CARD=HDMI,DEV=0
    HDA ATI HDMI, HDMI 0
    HDMI Audio Output
    sysdefault:CARD=Generic
    HD-Audio Generic, ALC887-VD Analog
    Default Audio Device
    front:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    Front speakers
    surround40:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    4.0 Surround output to Front and Rear speakers
    surround41:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=Generic,DEV=0
    HD-Audio Generic, ALC887-VD Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers


  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Speaker Configuration

    Typically the HDMI audio on PCs is associated with the graphic circuitry, which means the graphic driver is important , in addition to the alsa sound driver. In the case of AMD radeon hardware, by default with the open source graphic driver (radeon) the HDMI audio is disabled by default. This decision was taken because the audio portion of that driver was not considered sufficiently stable to enable permanently. If you wished to try HDMI with the open source radeon driver, you need to enable it upon boot, with the boot code:
    Code:
    radeon.audio=1
    please advise if you need help in being taught how to apply that boot code.

    I don't know if there is a proprietary driver for the HD 7480D , but assuming there is , then your HDMI audio should work with that proprietary graphic driver without the need for that boot code.

    Note there is an application that comes with pulse audio called pulse audio volume control (pavcontrol). In the case of KDE it is not installed by default and needs to be installed by users who wish more control over their audio device configuration. I believe with Gnome it is already installed < not sure > .

    There is some information on how to use pavucontrol in the following two blogs :




    Good luck, and I hope that helps.

  3. #3

    Default Re: Speaker Configuration

    Hello, thank you very much for your answer.
    I have applied the boot code in /etc/default/grub and i have a line that looks like this now :
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-id/ata-WDC_WD3200BEVT-00A0RT0_WD-WX31EC010937-part2 quiet splash radeon.audio=1
    I hope this is correct.
    I have also installed pavcontrol, and noticed that after changing the line in the grub file , i now have that bar moving, indicating that there is sound on the hdmi output when i'm randomly playing something on youtube, but i am still unable to hear the sound. although technically there should be.
    Also when i check the Sound menu under Yast i have 2 audio cards available, one that it is "ATI Technologies Inc" and one "AMD".
    If let's say i set AMD default, i can see the Volume options under the Other-Volume tab but for the secondary card that is disabled,never for the one that it is set up as default.


    Forgot to mention that in pavcontrol the hdmi port is marked as unplugged.

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,286

    Default Re: Speaker Configuration

    You probably need the propritary AMD driver then. I assume you are still using Radeon. If you do install that driver then you need remove the kernel parameters you entered If you made that change permanent. If you just edited the line in Grub then it is good only for that boot.

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Speaker Configuration

    Quote Originally Posted by mizaharia View Post
    I have also installed pavcontrol, and noticed that after changing the line in the grub file , i now have that bar moving, indicating that there is sound on the hdmi output when i'm randomly playing something on youtube, but i am still unable to hear the sound. although technically there should be.
    Also when i check the Sound menu under Yast i have 2 audio cards available, one that it is "ATI Technologies Inc" and one "AMD".
    If let's say i set AMD default, i can see the Volume options under the Other-Volume tab but for the secondary card that is disabled,never for the one that it is set up as default.

    Forgot to mention that in pavcontrol the hdmi port is marked as unplugged.
    Could you provide us the output of the command:
    Code:
    aplay -l
    note that is a lower case "L".

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •