Results 1 to 2 of 2

Thread: gramps: typelib-1_0-Gtk-3_0 vs typelib-1_0-Gtk-2_0

  1. #1

    Default gramps: typelib-1_0-Gtk-3_0 vs typelib-1_0-Gtk-2_0

    The recent gramps application depends on GTK 3 and it needs typelib-1_0-Gtk-3_0. If typelib-1_0-Gtk-2_0 is not installed (which breaks a lot of things so not recommended), gramps will work fine on my 13.1 amd64 machine. However, having typelib-1_0-Gtk-3_0 and typelib-1_0-Gtk-2_0, the command line
    Code:
    gramps -e blub -O blab
    produces the error
    Code:
    /usr/lib64/python2.7/site-packages/gi/overrides/Gtk.py:49: RuntimeWarning: You have imported the Gtk 2.0 module.  Because Gtk 2.0 was not designed for use with introspection some of the interfaces and API will fail.  As such this is not supported by the pygobject development team and we encourage you to port your app to Gtk 3 or greater. PyGTK is the recomended python module to use with Gtk 2.0
    How can I set the preferred libs?

    The strange thing is that I have an almost identical system (in the sense that I do not find a significant difference for the problem), where everything works....

    Thanks a lot for input!

  2. #2

    Exclamation Re: gramps: typelib-1_0-Gtk-3_0 vs typelib-1_0-Gtk-2_0

    Apparently, typelib-1_0-WebKit-3_0 has to be installed as well. With this package, the error does not occur.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •