Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: OpenSuse in Virtual Box no IP address

  1. #1

    Default OpenSuse in Virtual Box no IP address

    I'm running Open Suse 13.1 in an Oracle Virtual Box VM. I can't seem to get an IP address, hence I can't get the VM to get out to the Internet or ping anything.

    Right now, I have the Network Adapter set to NAT and it's on "Adapter Type" Intel Pro/1000 MT Desktop (82540EM). My desktop's real NIC is a wifi card. Don't know how that changes anything. (I've tried changing the interface from NAT to bridged, and it didn't make a difference.)

    In the VM, if I run an ifconfig -a, I get this...

    linux-nda2:/home/david # ifconfig -a
    enp0s3 Link encap:Ethernet HWaddr 08:00:27:2C:69:A8
    inet6 addr: fe80::a00:27ff:fe2c:69a8/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:4 errors:0 dropped:0 overruns:0 frame:0
    TX packets:66 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1322 (1.2 Kb) TX bytes:11971 (11.6 Kb)


    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:54 errors:0 dropped:0 overruns:0 frame:0
    TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:3356 (3.2 Kb) TX bytes:3356 (3.2 Kb)

    There is no inet address for the enp0s3 interface. And, two, I'm not sure why the interface is not called inet or something like that instead of enp0s3.

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSuse in Virtual Box no IP address

    On 2014-02-17 02:46, dorlow wrote:

    > There is no inet address for the enp0s3 interface.


    You could try

    Code:
    rcnetwork restart
    rcnetwork status
    Paste the result back here if it doesn't work, inside code tags, please.
    The '#' button - for command outputs and listings
    See how


    > And, two, I'm not
    > sure why the interface is not called inet or something like that instead
    > of enp0s3.


    Why should it be? This is Linux. Welcome! :-)

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: OpenSuse in Virtual Box no IP address


    This is openSUSE running systemd.
    One of the benefits of systemd is that you can use "systemctl" to manage any Unit file configured for any subsystem.

    Instead of learning the numerous commands for each subsystem, you can typically execute the same command for all, eg
    Code:
    # systemctl restart network
    And, if it fails, the result should spit out relevant information (hopefully).

    The reason why your NIC is named the way it is, is because the name is now built on the NIC's chipset/name... not some generic name. It's supposed to avoid confusion on multi-homed machines, but I think many are finding it just harder to type (I am).

    TSU

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSuse in Virtual Box no IP address

    On 2014-02-17 16:46, tsu2 wrote:
    >
    >
    > This is openSUSE running systemd.
    > One of the benefits of systemd is that you can use "systemctl" to manage
    > any Unit file configured for any subsystem.


    But also, this is openSUSE, and it happens to be an openSUSE policy that
    all services *must* have an rc file to start it.

    There was recent talk in factory about how to enforce this policy.

    > Instead of learning the numerous commands for each subsystem, you can
    > typically execute the same command for all, eg
    >
    > Code:
    > --------------------
    > # systemctl restart network
    > --------------------


    Thus if the above exists, mandatorily in openSUSE "rcnetwork restart"
    will also exist and work :-)


    No need to learn the names, either. You type "rc", hit {tab} twice, and
    you get the entire list ;-)

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  5. #5
    Join Date
    Dec 2008
    Location
    Brussels, Belgium
    Posts
    57

    Default Re: OpenSuse in Virtual Box no IP address

    I suspect the problem is on the host, something with the Wireless connection and the way Virtualbox interacts with it.

    As many have found (me included), opensuse 13.1 works in a VM and essentially they're all the same. So it's not there that the problem lies, unless the configuration you installed has some specific issues - installation of special software, low on memory or disk, etc...

    But if that's not the case it's on the host you must seek the solution, either in the settings of Virtualbox or in the network of the host: is it a plain vanilla 192.168.x.x with dhcp or is it something else?

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: OpenSuse in Virtual Box no IP address

    Quote Originally Posted by jdeca57 View Post
    I suspect the problem is on the host, something with the Wireless connection and the way Virtualbox interacts with it.

    As many have found (me included), opensuse 13.1 works in a VM and essentially they're all the same. So it's not there that the problem lies, unless the configuration you installed has some specific issues - installation of special software, low on memory or disk, etc...

    But if that's not the case it's on the host you must seek the solution, either in the settings of Virtualbox or in the network of the host: is it a plain vanilla 192.168.x.x with dhcp or is it something else?
    Actually, I've been seeing this quite regularly in VMware as well (Guest doesn't pick up a DHCP IP address on bootup).
    Am thinking about converting them to static IP addresses to see if it solves the problem.

    So far am not seeing this in any other OS but on the other hand approx. 90% of my Guests are openSUSE.

    TSU

  7. #7

    Default Re: OpenSuse in Virtual Box no IP address

    On 02/17/2014 01:28 PM, Carlos E. R. pecked at the keyboard and wrote:
    > On 2014-02-17 16:46, tsu2 wrote:
    >>
    >> This is openSUSE running systemd.
    >> One of the benefits of systemd is that you can use "systemctl" to manage
    >> any Unit file configured for any subsystem.

    > But also, this is openSUSE, and it happens to be an openSUSE policy that
    > all services *must* have an rc file to start it.
    >
    > There was recent talk in factory about how to enforce this policy.
    >
    >> Instead of learning the numerous commands for each subsystem, you can
    >> typically execute the same command for all, eg
    >>
    >> Code:
    >> --------------------
    >> # systemctl restart network
    >> --------------------

    > Thus if the above exists, mandatorily in openSUSE "rcnetwork restart"
    > will also exist and work :-)
    >
    >
    > No need to learn the names, either. You type "rc", hit {tab} twice, and
    > you get the entire list ;-)
    >

    Wouldn't it be great to type systemctrl restart <tab><tab> and get a
    list of running processes available for a restart or any other parameter
    for systemctrl?

    Ken

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSuse in Virtual Box no IP address

    On 2014-02-17 19:53, Ken Schneider wrote:
    > On 02/17/2014 01:28 PM, Carlos E. R. pecked at the keyboard and wrote:



    >> No need to learn the names, either. You type "rc", hit {tab} twice, and
    >> you get the entire list ;-)
    >>

    > Wouldn't it be great to type systemctrl restart <tab><tab> and get a
    > list of running processes available for a restart or any other parameter
    > for systemctrl?


    Did you try? it works here. :-)

    There is a bash completion module in systemd.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  9. #9
    Join Date
    Dec 2008
    Location
    Brussels, Belgium
    Posts
    57

    Default Re: OpenSuse in Virtual Box no IP address

    Quote Originally Posted by tsu2 View Post
    Actually, I've been seeing this quite regularly in VMware as well (Guest doesn't pick up a DHCP IP address on bootup).
    Am thinking about converting them to static IP addresses to see if it solves the problem.

    So far am not seeing this in any other OS but on the other hand approx. 90% of my Guests are openSUSE.

    TSU
    Of course, bridged networking and a static IP is the best solution. In my (limited) VB experience it always works but it requires more administration.

  10. #10

    Default Re: OpenSuse in Virtual Box no IP address

    On 02/17/2014 04:34 PM, Carlos E. R. pecked at the keyboard and wrote:
    > On 2014-02-17 19:53, Ken Schneider wrote:
    >> On 02/17/2014 01:28 PM, Carlos E. R. pecked at the keyboard and wrote:

    >
    >>> No need to learn the names, either. You type "rc", hit {tab} twice, and
    >>> you get the entire list ;-)
    >>>

    >> Wouldn't it be great to type systemctrl restart <tab><tab> and get a
    >> list of running processes available for a restart or any other parameter
    >> for systemctrl?

    > Did you try? it works here. :-)
    >
    > There is a bash completion module in systemd.
    >

    That works but I was hoping to only see running services when trying
    restart, instead it shows all services. But it does help for finding the
    name of the service. This does help to eliminate the need for the 'rc'
    links.

    Ken

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •