Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Can't adjust backlight in openSUSE 13.1 on eMachines e525

  1. #1
    Join Date
    Feb 2014
    Posts
    8

    Default Can't adjust backlight in openSUSE 13.1 on eMachines e525

    Hello,

    I've installed openSUSE 13.1 (32-bit) on my eMachines e525 last week.

    Unfortunately, the backlight cannot be adjusted.

    I had the same problem on Ubuntu 12.04 and Linux Mint 14–16, and was able to solve the problem by running
    Code:
    gksudo gedit /etc/default/grub
    finding the line

    Code:
    GRUB_CMDLINE_LINUX=""
    changing it to

    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=Linux"
    and then running

    Code:
    sudo update-grub

    as described here: http://ubuntuforums.org/showthread.p...1#post11567591

    I edited the same file in openSUSE and updated the grub.

    However, the backlight is still not adjustable. Is there anything I can do?

    Many thanks for your help!

    PS the related issue of the backlight not turning on, as described in the Ubuntu forums post cited above, is solved in openSUSE 13.1, as well as Mint 15/16 and Mageia 3.

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Can't adjust backlight in openSUSE 13.1 on eMachines e525

    Quote Originally Posted by zam View Post
    Hello, I've installed openSUSE 13.1 (32-bit) on my eMachines e525 last week. Unfortunately, the backlight cannot be adjusted. I had the same problem on Ubuntu 12.04 and Linux Mint 14–16, and was able to solve the problem by running
    Code:
    gksudo gedit /etc/default/grub
    finding the line
    Code:
    GRUB_CMDLINE_LINUX=""
    changing it to
    Code:
    GRUB_CMDLINE_LINUX="acpi_osi=Linux"
    and then running
    Code:
    sudo update-grub
    as described here: http://ubuntuforums.org/showthread.p...1#post11567591 I edited the same file in openSUSE and updated the grub. However, the backlight is still not adjustable. Is there anything I can do? Many thanks for your help! PS the related issue of the backlight not turning on, as described in the Ubuntu forums post cited above, is solved in openSUSE 13.1, as well as Mint 15/16 and Mageia 3.
    What command did you use to update Grub2? You should update Grub2 with one of:
    Code:
     grub-mkconfig -o /boot/grub/grub.cfg
    OR
    If your PC is UEFI-GPT Mode, this instead:
    Code:
     grub-mkconfig -o /boot/efi/EFI/GRUB/grub.cfg
    This will properly create an updated grub.cfg.

    You need to do this from Terminal - Super User Mode
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  3. #3
    Join Date
    Feb 2014
    Posts
    8

    Default Re: Can't adjust backlight in openSUSE 13.1 on eMachines e525

    Thanks, Gerry!

    Yes, I used

    Code:
    grub-mkconfig -o /boot/grub/grub.cfg
    after finding that update-grub didn't work in openSUSE.

    However, I'm still unable to change the screen brightness.

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Can't adjust backlight in openSUSE 13.1 on eMachines e525

    Quote Originally Posted by zam View Post
    Thanks, Gerry!

    Yes, I used

    Code:
    grub-mkconfig -o /boot/grub/grub.cfg
    after finding that update-grub didn't work in openSUSE.

    However, I'm still unable to change the screen brightness.
    Okay. You showed the other command, so I wasn't sure. So, the suggested fix doesn't work, it seems.

    I do not know the solution to your problem, but I do not see anyone else jumping in here, yet.

    So, I will suggest that you try the Recover mode to see what happens.

    When you boot and see the Grub boot menu, go to the line for Advanced

    In the next menu that pops up, choose the Recovery option.

    What happens then? Anything different?
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  5. #5
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Can't adjust backlight in openSUSE 13.1 on eMachines e525

    Looking back at the posts, I believe I have given you the wrong commands. openSUSE 13.1 uses Grub2, so you should be using the command:

    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    NOT

    Code:
    grub-mkconfig -o /boot/grub/grub.cfg
    Note the numeral 2 in the line.

    When booting, you can verify whether or not your changes actually made it to the command line.

    As soon as you see the first Grub menu, press the "e" key. You should see the command line with its parameters, and acpi_osi=Linux should be in there, no quotes.

    I suspect if you do that right now before trying to recreate it with the grub2-mkconfig line, you will see the parameter never did make it there.

    If not, you can test it before making the change permanent. While still in the edit mode for the boot command line, go to the end of the line, add a space, then add the parameter as I bolded above (no quotes, remember).

    Then, boot. It will boot this way once, then it will be gone again for next boot, so if it doesn't work, it won't be permanent.

    If it does work, then use the grub2-mkconfig command to make it permanent.

    =====

    I'm surprised that wolfi nor my friend robin_listas -- nor others here -- didn't spot my mistake!
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  6. #6

    Default Re: Can't adjust backlight in openSUSE 13.1 on eMachines e525

    You might want to have a look at this: https://wiki.ubuntu.com/Kernel/Debug...tic_Techniques

  7. #7
    Join Date
    Feb 2014
    Posts
    8

    Default Re: Can't adjust backlight in openSUSE 13.1 on eMachines e525

    Thanks!

    In fact, my error, I'm pretty sure I ran the command as

    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    already.

    Before I try anything more, I should point out that I'm in a dual-boot setup with Linux Mint 16, and I'm still getting the Mint grub at boot, even after updating the openSUSE grub. (That surprised me a bit).

    Further details: I installed Mint first, then openSUSE, but before trying to solve this current problem I had re-installed the Mint grub by running

    Code:
    sudo grub-install /dev/sda
    and then
    Code:
    sudo update-grub
    in the Mint side.

    Will this affect things? I'm surprised the openSUSE grub hasn't returned. Everything else appeared to work normally in Terminal when I updated grub, and it even detected Mint on the other partition.

    If I press the 'e' key upon seeing the grub, will it just give the the details for booting Mint? I have applied the same fix in my Mint install, and it works fine there.

    Thanks for your help

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: Can't adjust backlight in openSUSE 13.1 on eMachines e525

    Which Grub is control will depend on how you install things.

    Is this a UEFI machine or BIOS.If BIOS then it will depend on what is installed to the MBR. It may be generic code if so then the boot flag controls what gets booted if You did not install grub to MBR when you installed openSUSE then you probably have Mint code in the MBR.

    In UEFI it depends on what is set in the EFI configuration.

  9. #9

    Default Re: Can't adjust backlight in openSUSE 13.1 on eMachines e525

    Yeah this is a problem with eMachines laptops I have seen on various other linux distros.
    Especially in the later models under the gateway brand (seriously Gateway+linux=bad juju)

  10. #10
    Join Date
    Feb 2014
    Posts
    8

    Default Re: Can't adjust backlight in openSUSE 13.1 on eMachines e525

    Quote Originally Posted by gogalthorp View Post
    Which Grub is control will depend on how you install things.

    Is this a UEFI machine or BIOS.If BIOS then it will depend on what is installed to the MBR. It may be generic code if so then the boot flag controls what gets booted if You did not install grub to MBR when you installed openSUSE then you probably have Mint code in the MBR.

    In UEFI it depends on what is set in the EFI configuration.
    It's a BIOS machine.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •