Results 1 to 3 of 3

Thread: Lenovo W530 Microphone Problem

  1. #1

    Default Lenovo W530 Microphone Problem

    Realtec ALC269VC on 13.1 ..... Sound from internal speakers is fine but microphone is not recording.
    VU meter (Audacity or in Terminal) indicates significant 'white noise' reaching the driver but no added response to internal microphone.
    If I attach an external headphone set both in and out work fine.
    Alsamixer and Audio-Mixer both fully adjusted. Followed the audio troubleshooting help material to the best of my understanding.

    System data:
    http://www.alsa-project.org/db/?f=49...09d8c96ebb4aeb

    Help would be appreciated;

    David

  2. #2
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Lenovo W530 Microphone Problem

    David,

    Have you tried using alsamixer - and press 'F4' to access "Capture"? If you have not been able to unmute and/or enable the "Capture".
    There can be a problem with the kernel driver. I would recommend updating the kernel to kernel 3.13x.

    Add the repository below to Yast for updating:

    http://download.opensuse.org/reposit...able/standard/

    Alsamixer Help
    Code:
    │F1 Help                                
    │F2      System information               
    │F3      Show playback controls        
    │F4      Show capture controls               
    │F5      Show all controls                   
    │Tab     Toggle view mode (F3/F4/F5)   
    │F6 S    Select sound card                 
    │L       Redraw screen                 
    │                                                        
    │Left    Move to the previous control         
    │Right   Move to the next control                 
    │                                                                             
    │Up/Down    Change volume                           
    │+ -        Change volume                         
    │Page Up/Dn Change volume in big steps    
    │End        Set volume to 0%                         
    │0-9        Set volume to 0%-90%                     
    │Q W E     Increase left/both/right volumes    
    │Z X C      Decrease left/both/right volumes   
    │B          Balance left and right volumes        
    │                                   
    │M          Toggle mute                                        
    │< >        Toggle left/right mute            
    │                                                                                           
    │Space      Toggle capture                                        
    │; '        Toggle left/right capture
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Lenovo W530 Microphone Problem

    The microphone should just work.

    Can you explain a bit better as to what tests have you conducted that lead you to believe that that microphone is not working ? You noted VU meter (Audacity or in Terminal) indicated significant 'white noise' reaching the driver but no added response to internal microphone. And you also noted if you attach an external headphone set both in and out work fine. You make no reference to the docking station, so I assume you are NOT testing this with the docking station.

    From the above I deduce when not connected to the docking station, an external mic DOES work, but the internal mic does NOT work.

    The internal mic is typically a digital mic, and from a 'wiring' perspective it is typically associated with the webcam.

    I note capture at only 50% for the digital mic:
    Code:
    Simple mixer control 'Digital',0
      Capabilities: cvolume
      Capture channels: Front Left - Front Right
      Limits: Capture 0 - 120
      Front Left: Capture 60 [50%] [0.00dB]
      Front Right: Capture 60 [50%] [0.00dB]
    I also note the automute enabled:
    Code:
    Simple mixer control 'Auto-Mute Mode',0
      Capabilities: enum
      Items: 'Disabled' 'Enabled'
      Item0: 'Enabled'
    You could try disabling the auto mute, and also try increasing the % capture on the digital mic.

    I also note from the script you ran the following:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC269VC Analog [ALC269VC Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    From that it is clear that your recording device is hw:0,0

    When you were testing in a terminal, is this the command you used ?
    Code:
    arecord -vv -f S16_LE -c 2 -D hw:0,0 newrecording.wav
    That would record to the file newrecording.wav and you would need use <ctrl><c> to stop the recording. Then play back newrecording.wav in a text editor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •