Results 1 to 7 of 7

Thread: no password box resuming from idle sleep, no problem when user initiated sleep;kscreenlocker_greet

  1. #1
    Join Date
    Jun 2008
    Location
    Cambridge, UK
    Posts
    76

    Default no password box resuming from idle sleep, no problem when user initiated sleep;kscreenlocker_greet

    I'm running opensuse13.1-x86-64 on Intel-based Dell laptop (E7440, core-i5-4300u), and am using KDE.


    If I let the laptop idle eventually it sleeps; when I tap the power button it wakes up near instantly and I see the SuSE background. But I don't get a password/unlock greeting.

    ALT-TAB does nothing. I switch back to character console and login as root, and kill the process /usr/lib64/kde4/libexec/kscreenlocker_greet and flip back to the graphical window and I then see the password box once more; I can then unlock and everything is good once again.

    If I shut the lid, the laptop sleeps and resumes perfectly when I open the lid and I get asked to enter the password.


    Overall then this is not a disaster because I don't lose my logged-in session, but it is quite annoying.

    I tried googling for kscreenlocker_greet and variants but couldn't find a specific answer. Sorry if this has already been covered on this forum.
    --
    Cambridge geek, will code for gadgets

  2. #2

    Default Re: no password box resuming from idle sleep, no problem when user initiated sleep;kscreenlocker_gre

    Two threads about that have been opened recently, but unfortunately the posters didn't reply anymore for some time now.
    http://forums.opensuse.org/showthrea...ep-can-t-login
    http://forums.opensuse.org/showthrea...g-from-Standby

    As I would really be interested in what could cause this (and I cannot reproduce it myself), could _you_ please post the file ~/.kde4/share/config/kscreensaverrc?

    And please try to create a new user (in YaST->Security and Users->User Management f.e.), login as that, and check whether that user has the problem as well or not.

    PS: Never mind.
    Thanks to your detailed description, I _was_ able to reproduce now.
    This apparently only happens if you activate automatic suspend in KDE's power management settings.

    I will add that to the upstream bug report.

  3. #3

    Default Re: no password box resuming from idle sleep, no problem when user initiated sleep;kscreenlocker

    Quote Originally Posted by wolfi323 View Post
    I will add that to the upstream bug report.
    PS: This is the bug report:
    https://bugs.kde.org/show_bug.cgi?id=327947

  4. #4

    Default Re: no password box resuming from idle sleep, no problem when user initiated sleep;kscreenlocker_gre

    And see here for some workarounds:
    http://forums.opensuse.org/showthrea...01#post2625008

    Disabling "Lock screen on resume" in Configure Desktop (systemsettings)->Power Management->Advanced or disabling the screen locker/screen saver in Configure Desktop (systemsettings)->Display and Monitor->Screenlocker should prevent that problem as well.

  5. #5
    Join Date
    Jun 2008
    Location
    Cambridge, UK
    Posts
    76

    Default Re: no password box resuming from idle sleep, no problem when user initiated sleep;kscreenlocker_gre

    I don't have that file

    $ cat ~/.kde4/share/config/*screen*
    cat: /home/paulm/.kde4/share/config/*screen*: No such file or directory


    I haven't really touched screen saver, it's set to

    Code:
    [*] start after (4 minutes)
    [ ] require password after (60 seconds)
    (*) simple locker
    ( ) desktop widgets
    ( ) screen saver

    I changed the settings from the default, then back, then applied, and now the file exists:

    Code:
    $ cat ~/.kde4/share/config/*screen*
    [ScreenSaver]
    LegacySaverEnabled=false
    PlasmaEnabled=false
    --
    Cambridge geek, will code for gadgets

  6. #6
    Join Date
    Jun 2008
    Location
    Cambridge, UK
    Posts
    76

    Default Re: no password box resuming from idle sleep, no problem when user initiated sleep;kscreenlocker_gre

    aha, if I kill
    /usr/lib64/kde4/libexec/kscreenlocker_greet

    it restarts with
    /usr/lib64/kde4/libexec/kscreenlocker_greet --immediatelock

    --
    Cambridge geek, will code for gadgets

  7. #7
    Join Date
    Jun 2008
    Location
    Cambridge, UK
    Posts
    76

    Default Re: no password box resuming from idle sleep, no problem when user initiated sleep;kscreenlocker_gre

    I'll add this to the kde bug tracker
    --
    Cambridge geek, will code for gadgets

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •