Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Brightness Control

  1. #1

    Default Brightness Control

    Hi,
    brightness control keys doesn't work properly on my machine, Panasonic CF 53 i5 2.7 Ghz Intel 4000

    brightness is degreasing or increasing slowly without showing the scale on video, the sound control keys show it properly

    any suggestion?

    openSUSE 13.1 only (no Win) on SSD with discard e noatime, some hw disabled on bios

    Greetings

  2. #2

    Default Re: Brightness Control

    Try to add this kernel parameter: acpi_backlight=vendor acpi_osi=Linux
    Add it to the end of the GRUB_CMDLINE_LINUX variable in the /etc/default/grub file.
    Then run the grub2-mkconfig -o /boot/grub2/grub.cfg command ...

  3. #3

    Default Re: Brightness Control

    Quote Originally Posted by PiElle View Post
    Try to add this kernel parameter: acpi_backlight=vendor acpi_osi=Linux
    Add it to the end of the GRUB_CMDLINE_LINUX variable in the /etc/default/grub file.
    Then run the grub2-mkconfig -o /boot/grub2/grub.cfg command ...
    thanks, I've tried it, the bar is coming back but the the brightness is not decreasing or increasing even if the bar is showing it

  4. #4
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Brightness Control

    Try using this:
    Code:
    acpi_osi=
    Restart you laptop and then try Fn-F1,-F2.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  5. #5

    Default Re: Brightness Control

    I had the same problem with an older version of openSUSE and in Debian.
    I solved the problem with adding the following kernel parameter in /etc/default/grub

    Code:
    acpi_osi=\"!Windows 2012\"
    Followed by the
    Code:
     grub2-mkconfig -o /boot/grub2/grub.cfg 
    command.

    http://forums.opensuse.org/showthrea...85#post2538085

  6. #6

    Default Re: Brightness Control

    Quote Originally Posted by Romanator View Post
    Try using this:
    Code:
    acpi_osi=
    Restart you laptop and then try Fn-F1,-F2.
    Thanks Romanator. It works.

    I've tried many combination of the codes found on previous posts in the forum but nothing worked out.

    A funny thing, in the old panasonic cf 29 2004 (i915) is working perfectly and in the kernel the variable is empty...

  7. #7

    Default Re: Brightness Control

    Quote Originally Posted by Thor_Thenhammer View Post
    I had the same problem with an older version of openSUSE and in Debian.
    I solved the problem with adding the following kernel parameter in /etc/default/grub

    Code:
    acpi_osi=\"!Windows 2012\"
    Followed by the
    Code:
     grub2-mkconfig -o /boot/grub2/grub.cfg 
    command.

    http://forums.opensuse.org/showthrea...85#post2538085
    Thanks Thor, but that code is not working in this machine

  8. #8
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Brightness Control

    That's great to hear! When you get everything working please add your model to the Hardware database.

    Panasonic
    http://en.opensuse.org/HCLPanasonic_laptops
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

  9. #9

    Default Re: Brightness Control

    Quote Originally Posted by Romanator View Post
    That's great to hear! When you get everything working please add your model to the Hardware database.

    Panasonic
    http://en.opensuse.org/HCLPanasonic_laptops
    Hi Romanator,
    many things are off on my machine, some of them it may not easy to test because I've not chance to use it right now

    and I'm not so geek to understand how to add my model to that page...

  10. #10
    Join Date
    Jul 2008
    Location
    Toronto, Canada
    Posts
    1,255

    Default Re: Brightness Control

    Quote Originally Posted by cicerone View Post
    Hi Romanator,
    many things are off on my machine, some of them it may not easy to test because I've not chance to use it right now

    and I'm not so geek to understand how to add my model to that page...
    Take your time. It's a learning process.
    When I first starting adding entries it appearing a bit overwhelming. All you have to do is click on "Edit" and look at one the previous entries.
    Just copy and paste the previous entries below or above as it is in alphabetical and numerical order. Replace the model number with your number.
    Use the preview changes to see how it appears. Click on the "Save" button to add your model. There is no time limit as there is in the forum.

    Once you add and edit the wiki table two or three times you can get a handle on it.
    My Linux Box
    OS:
    openSUSE 52.2 - Plasma 5.18.9
    OS:
    Tumbleweed Plasma 5.22
    ASUS P5Q | Intel Quad 6600 @3.02 GHz | 8GB G.SKILL RAM | Nvidia GeForce 750 Ti

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •