Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Hide Windows Hidden Folders on Dolphin

  1. #1
    Join Date
    Dec 2013
    Location
    Indonesia
    Posts
    33

    Default Hide Windows Hidden Folders on Dolphin

    I have an external HDD that I use also with Windows which create "$RECYCLE.BIN" and "System Volume Information" folders everytime it mounted NTFS partition. How can we hide that folders on dolphin. I'm using device manager applet to auto mount the external HDD.

  2. #2

    Default Re: Hide Windows Hidden Folders on Dolphin

    Quote Originally Posted by airilsra View Post
    I have an external HDD that I use also with Windows which create "$RECYCLE.BIN" and "System Volume Information" folders everytime it mounted NTFS partition. How can we hide that folders on dolphin. I'm using device manager applet to auto mount the external HDD.
    See "man ntfs-3g":
    Code:
           hide_hid_files
                  Hide the hidden files and directories in directory listings, the
                  hidden files and directories being the ones whose NTFS attribute
                  have the hidden flag set.  The hidden files will not be selected
                  when  using wildcards in commands, but all files and directories
                  remain accessible by full name, for example you can always  dis-
                  play  the  Windows  trash  bin  directory  by  : "ls -ld '$RECY-
                  CLE.BIN'".
    To add that mount option for automounting, you would have to create an entry in /etc/fstab though I guess.
    AFAIK there's no way to add custom mount options to KDE's udisks2 backend.

    A line like this in /etc/fstab should do:
    Code:
    /dev/sdb1 /windows/C           ntfs-3g    users,hide_hid_files,nofail 0 0
    The drive should get mounted at boot then. If you don't want that, add "noauto" to the options:
    Code:
    /dev/sdb1 /windows/C           ntfs-3g    users,noauto,hide_hid_files,nofail 0 0
    Some more notes:
    You need to exchange /dev/sdb1 with the actual device name of the partition, and you have to create the mount point ("/windows/C") manually.
    You can also use YaST->System->Partitioner to create the entry in the fstab, this will create the mount point automatically.
    The "nofail" is important, otherwise your system won't boot when the external hard disk is not connected/powered on. It should not be necessary when specifying "noauto", but it should not harm either.

    In case of an external hard disk it would maybe be better to mount by id or label instead of by device.
    YaST should do that by default anyway, if you want to edit fstab manually have a look at /dev/disk/by-id or /dev/disk/by-label and use that path instead of /dev/sdb1...

  3. #3
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: Hide Windows Hidden Folders on Dolphin

    airilsra wrote:
    >
    > I have an external HDD that I use also with Windows which create
    > "$RECYCLE.BIN" and "System Volume Information" folders everytime it
    > mounted NTFS partition. How can we hide that folders on dolphin. I'm
    > using device manager applet to auto mount the external HDD.
    >
    >

    Did you already try this ?
    http://www.ubunturoot.com/2010/08/hi...em-volume.html
    --
    GNOME 3.10.2
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop

  4. #4
    Join Date
    Dec 2013
    Location
    Indonesia
    Posts
    33

    Default Re: Hide Windows Hidden Folders on Dolphin

    Before I auto mount external drive with /etc/fstab do I need to do something with this settings?

  5. #5

    Default Re: Hide Windows Hidden Folders on Dolphin

    Quote Originally Posted by vazhavandan View Post
    This only works with GNOME's nautilus, _not_ dolphin AFAIK.

  6. #6
    Join Date
    Dec 2013
    Location
    Indonesia
    Posts
    33

    Default Re: Hide Windows Hidden Folders on Dolphin

    Quote Originally Posted by vazhavandan View Post
    Did you already try this ?
    http://www.ubunturoot.com/2010/08/hi...em-volume.html
    --
    GNOME 3.10.2
    openSUSE 13.1 (Bottle) (x86_64) 64-bit
    Kernel Linux 3.11.6-4-desktop
    I did that with Ubuntu and it worked with nautilus but it is not working with dolphin.

  7. #7

    Default Re: Hide Windows Hidden Folders on Dolphin

    Quote Originally Posted by airilsra View Post
    Before I auto mount external drive with /etc/fstab do I need to do something with this settings?
    No, that should continue to work as before I think.

    Btw, you can find out the "best" line for fstab by mounting the drive as before, and then calling "mount" in Konsole. Please post the output.
    This should show the current mount options.

  8. #8

    Default Re: Hide Windows Hidden Folders on Dolphin

    Quote Originally Posted by airilsra View Post
    I did that with Ubuntu and it worked with nautilus but it is not working with dolphin.
    Right, that's a nautilus-only feature AFAIK.
    There is a feature request that KDE should respect this file as well here:
    https://bugs.kde.org/show_bug.cgi?id=246260
    But nothing has happened there for the last 3 years...

  9. #9
    Join Date
    Dec 2013
    Location
    Indonesia
    Posts
    33

    Default Re: Hide Windows Hidden Folders on Dolphin

    Quote Originally Posted by wolfi323 View Post
    No, that should continue to work as before I think.

    Btw, you can find out the "best" line for fstab by mounting the drive as before, and then calling "mount" in Konsole. Please post the output.
    This should show the current mount options.
    I just did as you told and it worked
    I'm using this line on fstab (use label because it is more readable)
    Code:
    LABEL="Backup"  /touro/backup   ntfs-3g         users,hide_hid_files,nofail     0       0
    I unmounted the partition and then
    Code:
    mount -a
    No error, partition auto mounted as it should and no more those folders.

    Thanks wolfi.

  10. #10

    Default Re: Hide Windows Hidden Folders on Dolphin

    Quote Originally Posted by airilsra View Post
    I just did as you told and it worked
    I'm using this line on fstab (use label because it is more readable)
    Code:
    LABEL="Backup"  /touro/backup   ntfs-3g         users,hide_hid_files,nofail     0       0
    I unmounted the partition and then
    Code:
    mount -a
    No error, partition auto mounted as it should and no more those folders.
    Since you're configured KDE to do auto-mounting anyway, you should try to add the "noauto" option as well I think.
    Otherwise it could slow down your boot when the drive is not connected, because the system tries to mount it and doesn't find it.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •