Results 1 to 4 of 4

Thread: HP Deskjet Ink Advantage 2545 Scanner

  1. #1
    grglsn NNTP User

    Default HP Deskjet Ink Advantage 2545 Scanner

    Hello,

    I was very pleased that when I purchased my new HP 2545, my opensuse
    13.1 system picked it up and installed it right away. It made things
    very easy.

    Now I am trying to get the scanner function working, and it is not very
    easy - perhaps someone can help tell me what to do.

    The first thing I did was I found that HP says the scanner function
    works with opensuse 13.1 on this device, based on this page:
    http://hplipopensource.com/hplip-web...40_series.html

    So I installed hplip from the repositories, and then I opened up yast2
    and went to the scanner configuration. It says it detected the scanner,
    but it was "not configured." So I hit the edit button and my specific
    model is not listed, but it took the generic hp all in one option. I
    picked that, and hit ok.

    Here on this image you can see what is listed under scanners in yast on
    my device:

    http://picpaste.com/scanner1-Ze95QCnU.jpg

    So I assumed that since the scanner is listed now and the driver is
    configured, it should be able to scan. I went to the kicker, typed in
    "scan", and it said it could not find any configured scanners. Here is a
    snapshot of what it gave:

    http://picpaste.com/scanner2-yC1asfiM.jpg

    Can anyone tell me what to do next? I would like to try and get this
    scanner to work if possible.

    Thanks in advance,
    George

    --
    G.O.
    Box #1: 13.1 | KDE 4.11 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 13.1 | KDE 4.11 | AMD Athlon X3 | 64 | 4GB
    Laptop: 13.1 | KDE 4.11 | Core i7-2620M | 64 | 8GB

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,320
    Blog Entries
    15

    Default Re: HP Deskjet Ink Advantage 2545 Scanner

    On Sat 15 Feb 2014 06:16:34 AM CST, grglsn wrote:

    Hello,

    I was very pleased that when I purchased my new HP 2545, my opensuse
    13.1 system picked it up and installed it right away. It made things
    very easy.

    Now I am trying to get the scanner function working, and it is not very
    easy - perhaps someone can help tell me what to do.

    The first thing I did was I found that HP says the scanner function
    works with opensuse 13.1 on this device, based on this page:
    http://hplipopensource.com/hplip-web...40_series.html

    So I installed hplip from the repositories, and then I opened up yast2
    and went to the scanner configuration. It says it detected the scanner,
    but it was "not configured." So I hit the edit button and my specific
    model is not listed, but it took the generic hp all in one option. I
    picked that, and hit ok.

    Here on this image you can see what is listed under scanners in yast on
    my device:

    http://picpaste.com/scanner1-Ze95QCnU.jpg

    So I assumed that since the scanner is listed now and the driver is
    configured, it should be able to scan. I went to the kicker, typed in
    "scan", and it said it could not find any configured scanners. Here is
    a snapshot of what it gave:

    http://picpaste.com/scanner2-yC1asfiM.jpg

    Can anyone tell me what to do next? I would like to try and get this
    scanner to work if possible.

    Thanks in advance,
    George

    Hi
    As root user run hp-setup, then as user run hp-toolbox

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    grglsn NNTP User

    Default Re: HP Deskjet Ink Advantage 2545 Scanner

    On 02/15/2014 02:37 PM, malcolmlewis wrote:
    >
    > On Sat 15 Feb 2014 06:16:34 AM CST, grglsn wrote:
    >
    >
    >
    >
    > Hi
    > As root user run hp-setup, then as user run hp-toolbox
    >


    I am running hp-toolbox, and it gives me a "Device communication error."
    Then if I go to print something, like from Libreoffice, the device
    communication error disappears. But then it comes back if I hit the
    refresh button on hp-toolbox.

    I hit the button on diagnose the hplip driver, and it had me install a
    bunch of new packages, which all installed ok. However, it had 2 sets of
    warnings written in red:

    Code:
    Checking for HPLIP updates....
    error: HPLIP upgrade is disabled by openSUSE for security reasons, see
    https://bugzilla.novell.com/show_bug.cgi?id=853405 - if you like to
    upgrade HPLIP, use an openSUSE software package manager like YaST or zypper.
    Completed..
    error: Failed to upgrade latest HPLIP. Is hp-upgrade already running
    (i.e. foreground or background)?
    I don't think that was a problem, because according to zypper I am
    running the latest hplip software.

    However, this one is a problem, though I don't know if it has anything
    to do with the scanner function:
    Code:
    ---------------------------------
    | INSTALLED CUPS PRINTER QUEUES |
    ---------------------------------
    
    
    Deskjet-2540-series
    -------------------
    Type: Printer
    Device URI: hp:/usb/Deskjet_2540_series?serial=CN39B2BHS205XK
    PPD: /etc/cups/ppd/Deskjet-2540-series.ppd
    PPD Description: HP Deskjet 2540 Series, hpcups 3.13.10
    Printer ready to printr Deskjet-2540-series is idle.  enabled since Sat
    15 Feb 2014 03:25:35 PM PHT
    error: Unable to communicate with device (code=12):
    hp:/usb/Deskjet_2540_series?serial=CN39B2BHS205XK
    error: Device not found
    error: Communication status: Failed
    I don't see anything on the hp-toolbox about the scanner function.

    My printer side works fine, even though the hp-toolbox says it has a
    communication error.


    --
    G.O.
    Box #1: 13.1 | KDE 4.11 | AMD Phenom IIX4 | 64 | 16GB
    Box #2: 13.1 | KDE 4.11 | AMD Athlon X3 | 64 | 4GB
    Laptop: 13.1 | KDE 4.11 | Core i7-2620M | 64 | 8GB

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: HP Deskjet Ink Advantage 2545 Scanner

    Code:
    error: Unable to communicate with device (code=12):
    This error may relate to not having the correct device permissions. Check that you are a member of the 'lp' and 'sys' groups. Confirm with
    Code:
    groups
    If not already a member of the groups, do the following
    Code:
    su -
    Enter root paasword when prompted, then do (using your username)
    Code:
    usermod -a -G sys <username>
    Code:
    usermod -a G lp <username>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •