Results 1 to 3 of 3

Thread: HISFILE setting not working

  1. #1

    Default HISFILE setting not working

    Hi,

    I am running below SLES11 server. I want to setup audit records of all user activities based on history command output.
    ==========
    SUSE Linux Enterprise Server 11 (x86_64)
    VERSION = 11
    PATCHLEVEL = 1

    ==========

    I have added below entries in /etc/profile.local file:
    ==========
    LOGNAME1=`who am i`
    DT=`date '+%m.%d.%Y-%M.%S'`
    HISTSIZE=500
    #HISTTIMEFORMAT="%a %b %Y %T %z "
    HISTFILE=/audit/hist_${LOGNAME1}_su_${DT}
    export HISTSIZE HISTFILE HISTTIMEFORMAT

    ==========

    But when I log into the system using my ID and then later do a "sudo su" to become root, it does not capture history logs output in /audit directory as per above configuration. The permission on /audit directory is set to all permissions. The logs don't get generated even if I select my home directory or /tmp to capture logs.

    Please help!

  2. #2
    Join Date
    May 2010
    Location
    Space Colony Lagrange Point 22° à, 77° Ƅ, 56° ɤ, 99° ɜ
    Posts
    3,166

    Default Re: HISFILE setting not working

    These are openSUSE forums. You need to visit SUSE forums https://forums.suse.com/forum.php
    GNOME Version 3.20.2
    openSUSE Leap 42.3 64-bit

    www.vazhavandan.blogspot.com

  3. #3

    Default Re: HISFILE setting not working

    Quote Originally Posted by vazhavandan View Post
    These are openSUSE forums. You need to visit SUSE forums https://forums.suse.com/forum.php
    Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •