Results 1 to 7 of 7

Thread: OpenSuse 13.1: Unable to switch back to traditional ifup method

  1. #1

    Unhappy OpenSuse 13.1: Unable to switch back to traditional ifup method

    OpenSuse 13.1 switched to NetworkManager mode. I don't know why. Now I try to switch back to traditional ifup mode in YAST network config but it doesn't save the settings! Does anyone know a way to switch back by terminal?

    Regards, Sven

  2. #2

    Default Re: OpenSuse 13.1: Unable to switch back to traditional ifup method

    On 02/13/2014 05:26 PM, svenwappler pecked at the keyboard and wrote:
    > OpenSuse 13.1 switched to NetworkManager mode. I don't know why. Now I
    > try to switch back to traditional ifup mode in YAST network config but
    > it doesn't save the settings! Does anyone know a way to switch back by
    > terminal?
    >
    > Regards, Sven
    >
    >


    Just in case you haven't.

    When you launch "Network Settings" in YaST you need to select the left
    most tab which is where the selection can be made.

    Ken

  3. #3

    Default Re: OpenSuse 13.1: Unable to switch back to traditional ifup method

    Yes, but this is exactly my problem. YaST doesn't save my choice. And know I have problems to bring my server online. That's why I asked for a way by terminal.

  4. #4

    Default Re: OpenSuse 13.1: Unable to switch back to traditional ifup method

    On 02/13/2014 09:16 PM, svenwappler pecked at the keyboard and wrote:
    > Yes, but this is exactly my problem. YaST doesn't save my choice. And
    > know I have problems to bring my server online. That's why I asked for a
    > way by terminal.
    >
    >


    On the terminal (CLI) use the ip command:

    Code:
    ip link set { dev DEVICE | group DEVGROUP } [ { up | down } ]
    
    ip link set dev eth0 up
    Sub your actual device for dev. And

    Code:
    ip link help
    is your friend.

    Ken

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: OpenSuse 13.1: Unable to switch back to traditional ifup method

    On 2014-02-14 03:16, svenwappler wrote:
    >
    > Yes, but this is exactly my problem. YaST doesn't save my choice. And
    > know I have problems to bring my server online. That's why I asked for a
    > way by terminal.


    Strange.

    You could try uninstall network manager.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6
    Join Date
    Sep 2012
    Posts
    7,098

    Default Re: OpenSuse 13.1: Unable to switch back to traditional ifup method

    Quote Originally Posted by svenwappler View Post
    Yes, but this is exactly my problem. YaST doesn't save my choice. That's why I asked for a way by terminal.
    Code:
    systemctl disable NetworkManager
    It may be useful to show output of "systemctl status network" before doing it. May be it is already done and you have some other issues.

  7. #7
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: OpenSuse 13.1: Unable to switch back to traditional ifup method

    Quote Originally Posted by svenwappler View Post
    Yes, but this is exactly my problem. YaST doesn't save my choice. And know I have problems to bring my server online. That's why I asked for a way by terminal.
    You can also type "yast" in a console (not yast2) and it should launch yast in ncurses mode (text mode) with the same ability to enable/disable Network Manager.

    TSU

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •