Results 1 to 9 of 9

Thread: Attaching USB

  1. #1

    Default Attaching USB

    Hi, I am having problem attaching a usb device. I tried to search the net on how but I am unable to since I am getting error.

    lsusb output
    Bus 002 Device 003: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
    my xml file.
    <hostdev mode='subsystem' type='usb'>
    <source>
    <vendor id='0x051d'/>
    <product id='0x0002'/>
    </source>
    </hostdev>
    Then after running virsh attac-device <domain> <xml file> I am getting below error.
    error: Path '/dev/bus/usb/000/000' is not accessible: No such file or directory
    KVM patterns version
    Name: efont-unicode-bitmap-fonts
    Version: 0.4.2-223.1.2

    Name: xorg-x11-fonts
    Version: 7.6-27.1.2

    Name: libvirt
    Version: 1.1.2-2.14.2

    Name: xorg-x11-fonts-core
    Version: 7.6-27.1.2

    Name: tftp
    Version: 5.2-7.1.2

    Name: virt-manager
    Version: 0.9.5-6.1.3

    Name: libvirt-daemon-qemu
    Version: 1.1.2-2.14.2

    Name: patterns-openSUSE-kvm_server
    Version: 13.1-13.6.1

    Name: virt-viewer
    Version: 0.5.7-3.1.4

    Name: xauth
    Version: 1.0.7-6.1.2

    Name: tightvnc
    Version: 1.3.10-14.2.1

    Name: fontconfig
    Version: 2.11.0-4.1

    Name: fonts-config
    Version: 20080121-82.2.1

    Name: bridge-utils
    Version: 1.5-16.1.2

    Name: vm-install
    Version: 0.7.8-4.1

    Name: kvm
    Version: 1.6.0-3.1.1
    Any help would be appreciated. Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Attaching USB


  3. #3

    Default Re: Attaching USB

    Quote Originally Posted by deano_ferrari View Post
    Yes, but according to those bug report. It has been fixed.

    Test with the latest libvirt build libvirt-1.1.1-15.el7.x86_64, this bug is fixed, change the status to "VERIFIED".
    And my libvirt version I think is much more current? I tried to add the repo Virtualization and tried updating all package on pattern kvm_server but to no avail and will give me more problems. So I am wondering if anyone is aware of this.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,698
    Blog Entries
    1

    Default Re: Attaching USB

    You may need to raise a bug report for this I guess

    The latest openSUSE security update announcement

    http://lists.opensuse.org/opensuse-u.../msg00004.html

    I also note that one of the RH bugs mentions patches pushed upstream and refers to libvirt-1.1.3.2-1, so maybe openSUSE has another update coming soon?

  5. #5

    Default Re: Attaching USB

    Quote Originally Posted by deano_ferrari View Post
    You may need to raise a bug report for this I guess

    The latest openSUSE security update announcement

    http://lists.opensuse.org/opensuse-u.../msg00004.html

    I also note that one of the RH bugs mentions patches pushed upstream and refers to libvirt-1.1.3.2-1, so maybe openSUSE has another update coming soon?
    Well hopefully so I can try it to my vga passthrough workstation since I am having problem with installing usb things instantly.

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Attaching USB

    Then after running virsh attac-device <domain> <xml file> I am getting below error.
    Code:
    error: Path '/dev/bus/usb/000/000' is not accessible: No such file or directory
    Will need the exact command you tried, not a description.

    Try running the command and copying that command and the response all at once (If you want, you can then edit for anything you feel is private)

    TSU

  7. #7

    Default Re: Attaching USB

    Quote Originally Posted by tsu2 View Post
    Will need the exact command you tried, not a description.Try running the command and copying that command and the response all at once (If you want, you can then edit for anything you feel is private)TSU
    Here's the exact command. Doing it as root.

    Welcome to virsh, the virtualization interactive terminal.


    Type: 'help' for help with commands
    'quit' to quit


    virsh # attach-device Win8 /etc/libvirt/qemu/usb_device.xml
    error: Failed to attach device from /etc/libvirt/qemu/usb_device.xml
    error: Path '/dev/bus/usb/000/000' is not accessible: No such file or directory


    virsh #
    Cheers!

  8. #8

    Default Re: Attaching USB

    Quote Originally Posted by syntaxx View Post
    Here's the exact command. Doing it as root.



    Cheers!
    Confirmed that it is a bug. See below
    https://bugzilla.novell.com/show_bug.cgi?id=863933#c2

  9. #9
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Attaching USB

    Cool!
    Hope that update appears upstream soon!

    TSU

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •