Results 1 to 7 of 7

Thread: boot hangs at : loading initial ramdisk

  1. #1
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default boot hangs at : loading initial ramdisk

    I installed some updates and after that Io restart system cause there was like too much libs used deleted files... and after that system won't boot it hangs at initial ramdisk loading I checked /var/log/messages - nothing important but
    /var/log/warn has sotething interesting and quite don't understand it properly. I' ve 13.1 KDE and my fielsystem is btrfs
    Code:
    2014-02-12T12:32:12.430897+01:00 linux-clui kernel: [182850.652248] EXT4-fs (sda2): unable to read superblock
    2014-02-12T12:32:12.432889+01:00 linux-clui kernel: [182850.654813] EXT4-fs (sda2): unable to read superblock
    2014-02-12T12:32:12.435891+01:00 linux-clui kernel: [182850.657235] EXT4-fs (sda2): unable to read superblock
    2014-02-12T12:32:12.437887+01:00 linux-clui kernel: [182850.659776] isofs_fill_super: bread failed, dev=sda2, iso_blknum=16, block=32
    2014-02-12T12:32:12.472899+01:00 linux-clui kernel: [182850.694577] REISERFS warning (device sda2): sh-2006 read_super_block: bread failed (dev sda2, block 8, size 1024)
    2014-02-12T12:32:12.472921+01:00 linux-clui kernel: [182850.694586] REISERFS warning (device sda2): sh-2006 read_super_block: bread failed (dev sda2, block 64, size 1024)
    2014-02-12T12:32:12.472924+01:00 linux-clui kernel: [182850.694589] REISERFS warning (device sda2): sh-2021 reiserfs_fill_super: can not find reiserfs on sda2
    2014-02-12T12:32:12.512971+01:00 linux-clui kernel: [182850.734199] XFS (sda2): bad magic number
    2014-02-12T12:32:12.513030+01:00 linux-clui kernel: [182850.734247] CPU: 0 PID: 143 Comm: kworker/0:1H Tainted: P           O 3.11.6-4-desktop #1
    2014-02-12T12:32:12.513034+01:00 linux-clui kernel: [182850.734251] Hardware name: LENOVO 27327UG/27327UG, BIOS 7YET79WW (3.09 ) 11/19/2009
    2014-02-12T12:32:12.513038+01:00 linux-clui kernel: [182850.734309] Workqueue: xfslogd xfs_buf_iodone_work [xfs]
    2014-02-12T12:32:12.513041+01:00 linux-clui kernel: [182850.734316]  0000000000000001 ffffffff815a9bd7 ffff880123ebe800 ffffffffa0aa44a6
    2014-02-12T12:32:12.513003+01:00 linux-clui kernel: [182850.734213] ffff880108a81000: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
    2014-02-12T12:32:12.513008+01:00 linux-clui kernel: [182850.734218] ffff880108a81010: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
    2014-02-12T12:32:12.513012+01:00 linux-clui kernel: [182850.734223] ffff880108a81020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
    2014-02-12T12:32:12.513016+01:00 linux-clui kernel: [182850.734228] ffff880108a81030: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  ................
    2014-02-12T12:32:12.513020+01:00 linux-clui kernel: [182850.734236] XFS (sda2): Internal error xfs_sb_read_verify at line 780 of file /home/abuild/rpmbuild/BUILD/kernel-desktop-3.11.6/linux-3.11/fs/xfs/xfs_mount.c.  Caller 0xffffffffa0aa17b5
    2014-02-12T12:32:12.513025+01:00 linux-clui kernel: [182850.734236] 
    2014-02-12T12:32:12.513045+01:00 linux-clui kernel: [182850.734326]  0000030c00000000 ffffffffa0aa17b5 ffff880108bf4e40 0000000000000016
    2014-02-12T12:32:12.513072+01:00 linux-clui kernel: [182850.734334]  ffff880123ebe800 ffffe8ffffc00800 ffffffffa0af85ed ffffffffa0aa17b5
    2014-02-12T12:32:12.513080+01:00 linux-clui kernel: [182850.734342] Call Trace:
    2014-02-12T12:32:12.513084+01:00 linux-clui kernel: [182850.734371]  [<ffffffff81004a18>] dump_trace+0x88/0x310
    2014-02-12T12:32:12.513088+01:00 linux-clui kernel: [182850.734383]  [<ffffffff81004d70>] show_stack_log_lvl+0xd0/0x1d0
    2014-02-12T12:32:12.513092+01:00 linux-clui kernel: [182850.734393]  [<ffffffff810061bc>] show_stack+0x1c/0x50
    2014-02-12T12:32:12.513096+01:00 linux-clui kernel: [182850.734406]  [<ffffffff815a9bd7>] dump_stack+0x50/0x89
    2014-02-12T12:32:12.513100+01:00 linux-clui kernel: [182850.734447]  [<ffffffffa0aa44a6>] xfs_corruption_error+0x56/0x80 [xfs]
    2014-02-12T12:32:12.513104+01:00 linux-clui kernel: [182850.734578]  [<ffffffffa0af85ed>] xfs_sb_read_verify+0xfd/0x120 [xfs]
    2014-02-12T12:32:12.513108+01:00 linux-clui kernel: [182850.734819]  [<ffffffffa0aa17b5>] xfs_buf_iodone_work+0x75/0x110 [xfs]
    2014-02-12T12:32:12.513111+01:00 linux-clui kernel: [182850.734873]  [<ffffffff8106ac48>] process_one_work+0x168/0x490
    2014-02-12T12:32:12.513115+01:00 linux-clui kernel: [182850.734885]  [<ffffffff8106b8e4>] worker_thread+0x114/0x3a0
    2014-02-12T12:32:12.513119+01:00 linux-clui kernel: [182850.734897]  [<ffffffff81071c0f>] kthread+0xaf/0xc0
    2014-02-12T12:32:12.513123+01:00 linux-clui kernel: [182850.734909]  [<ffffffff815b777c>] ret_from_fork+0x7c/0xb0
    2014-02-12T12:32:12.513130+01:00 linux-clui kernel: [182850.734971] XFS (sda2): SB validate failed with error 22.
    2014-02-12T12:32:12.522893+01:00 linux-clui kernel: [182850.744315] FAT-fs (sda2): bogus number of reserved sectors
    2014-02-12T12:32:12.513127+01:00 linux-clui kernel: [182850.734920] XFS (sda2): Corruption detected. Unmount and run xfs_repair
    2014-02-12T12:32:12.524867+01:00 linux-clui kernel: [182850.746651] FAT-fs (sda2): bogus number of reserved sectors
    2014-02-12T12:32:12.526892+01:00 linux-clui kernel: [182850.748939] MINIX-fs: unable to read superblock
    2014-02-12T12:32:12.529906+01:00 linux-clui kernel: [182850.751266] hfsplus: unable to find HFS+ superblock
    2014-02-12T12:32:12.531884+01:00 linux-clui kernel: [182850.753662] qnx4: wrong fsid in superblock.
    2014-02-12T12:32:12.533894+01:00 linux-clui kernel: [182850.755990] You didn't specify the type of your ufs filesystem
    2014-02-12T12:32:12.533909+01:00 linux-clui kernel: [182850.755990] 
    2014-02-12T12:32:12.533912+01:00 linux-clui kernel: [182850.755990] mount -t ufs -o ufstype=sun|sunx86|44bsd|ufs2|5xbsd|old|hp|nextstep|nextstep-cd|openstep ...
    2014-02-12T12:32:12.533915+01:00 linux-clui kernel: [182850.755990] 
    2014-02-12T12:32:12.533917+01:00 linux-clui kernel: [182850.755990] >>>WARNING<<< Wrong ufstype may corrupt your filesystem, default is ufstype=old
    2014-02-12T12:32:12.536886+01:00 linux-clui kernel: [182850.758160] hfs: can't find a HFS filesystem on dev sda2
    2014-02-12T12:32:16.420991+01:00 linux-clui systemd[1]: [/usr/lib/systemd/system/rtkit-daemon.service:32] Unknown lvalue 'ControlGroup' in section 'Service'
    2014-02-12T12:33:47.533614+01:00 linux-clui systemd[1]: [/usr/lib/systemd/system/rtkit-daemon.service:32] Unknown lvalue 'ControlGroup' in section 'Service'
    2014-02-12T12:33:47.946605+01:00 linux-clui systemd[1]: [/usr/lib/systemd/system/rtkit-daemon.service:32] Unknown lvalue 'ControlGroup' in section 'Service'
    2014-02-12T12:33:48.176750+01:00 linux-clui systemd[1]: [/usr/lib/systemd/system/rtkit-daemon.service:32] Unknown lvalue 'ControlGroup' in section 'Service'
    2014-02-12T12:33:48.430144+01:00 linux-clui systemd[1]: [/usr/lib/systemd/system/rtkit-daemon.service:32] Unknown lvalue 'ControlGroup' in section 'Service'
    2014-02-12T12:33:48.666914+01:00 linux-clui systemd[1]: [/usr/lib/systemd/system/rtkit-daemon.service:32] Unknown lvalue 'ControlGroup' in section 'Service'
    2014-02-12T12:33:48.688624+01:00 linux-clui systemd[1]: Cannot add dependency job for unit named.service, ignoring: Unit named.service failed to load: No such file or directory.
    2014-02-12T12:34:05.605943+01:00 linux-clui amavis[5903]: (!)Net::Server: 2014/02/12-12:34:05 Can't connect to TCP port 10024 on ::1 [Cannot assign requested address]\n  at line 68 in file /usr/lib/perl5/vendor_perl/5.18.1/Net/Server/Proto/TCP.pm
    2014-02-12T12:34:13.502210+01:00 linux-clui systemd[1]: [/usr/lib/systemd/system/klog.service:26] Unknown lvalue 'Names' in section 'Unit'
    2014-02-12T12:34:13.776077+01:00 linux-clui systemd[1]: [/usr/lib/systemd/system/lvm2-monitor.service:15] Executable path is not absolute, ignoring: "/sbin/lvm vgchange --monitor n --config 'global{use_lvmetad=0}'"
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,673
    Blog Entries
    3

    Default Re: boot hangs at : loading initial ramdisk

    Quote Originally Posted by roberto68 View Post
    I installed some updates and after that Io restart system cause there was like too much libs used deleted files... and after that system won't boot it hangs at initial ramdisk loading
    You should be able to boot to the previous kernel. At the grub menu, look for advanced boot options.

    If that works, then give us the output from:
    Code:
    df /boot
    My guess (and it is only a guess), is that you are out of disk space and the "initrd" was not properly built as a result of that.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: boot hangs at : loading initial ramdisk

    the problem is I don't see grub it immediately goes to that loading.... and like I do a clean installation and i can chroot from that clean install and thru snapper replace that libraries
    Code:
    /usr/lib/systemd/system/rtkit-daemon.service
    Code:
      or maybe /usr/lib/systemd/system/lvm2-monitor.service
    which may cause the issue
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  4. #4

    Default Re: boot hangs at : loading initial ramdisk

    roberto68,

    Quote Originally Posted by nrickert View Post
    You should be able to boot to the previous kernel. At the grub menu, look for advanced boot options.

    If that works, then give us the output from:
    Code:
    df /boot
    My guess (and it is only a guess), is that you are out of disk space and the "initrd" was not properly built as a result of that.
    You didn't reply to that.
    Where is your output of 'df' ?
    If you don't know how to get it, tell so!.

    Good luck

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: boot hangs at : loading initial ramdisk

    On 2014-02-12 19:36, roberto68 wrote:

    > /var/log/warn has sotething interesting and quite don't understand it
    > properly. I' ve 13.1 KDE and my fielsystem is btrfs


    Most of those messages simply indicate that the system is trying to
    mount sda2 without knowing in advance its type, and trying several
    types, that fail one after the other (because none of those is the
    correct type).

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: boot hangs at : loading initial ramdisk

    the df looks like that
    Code:
    Filesystem          1K-blocks     Used Available Use% Mounted on
    /dev/sda8            26624000  7176712  17921472  29% /
    devtmpfs              1977012       24   1976988   1% /dev
    tmpfs                 1991300     1112   1990188   1% /dev/shm
    tmpfs                 1991300     6352   1984948   1% /run
    tmpfs                 1991300        0   1991300   0% /sys/fs/cgroup
    tmpfs                 1991300     6352   1984948   1% /var/run
    tmpfs                 1991300     6352   1984948   1% /var/lock
    /dev/sda10             408292    91916    290776  25% /boot
    /dev/mapper/cr_home  18009416   161908  16909628   1% /home
    /dev/sda7            29357056   469128  26774192   2% /run/media/robert/suse1-home
    /dev/sda6            27261952 10235472  16076752  39% /run/media/robert/suse1
    /dev/sda1           205896396 99185412  96229016  51% /run/media/robert/data
    dev/sda6 - suse1 is the root partition and the sda2 is extended partition but the clean install looks fine, reboot fine but i can't find the old suse at the grub of that new, I knew that there's command for that like grub makemenuconfig or smth like that
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

  7. #7
    Join Date
    Apr 2013
    Location
    Modra, Slovakia
    Posts
    265

    Default Re: boot hangs at : loading initial ramdisk

    i've found it it is
    Code:
    grub2-mkconfig -o /boot/grub2/grub.cfg
    this command
    13.2 KDE 64bit tumbleweed
    Lenovo G500s, Thinkpad R500

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •