Results 1 to 5 of 5

Thread: Privoxy - automatischer Start nach Installation?

  1. #1

    Default Privoxy - automatischer Start nach Installation?

    Hallo,

    ich habe heute die Version 13.1/KDE installiert und anschließend Privoxy. Nur, wo ist nur der Privoxy-Prozess?

    Ich habe gesehen, dass es einen Bug gab (http://lists.opensuse.org/opensuse-b...13-11/all.html).

    Hat jemand eine Idee, wie man Privoxy üblicherweise automatisch mitstartet nach dem Booten?

    Ich finde auch keinen Menüeintrag, so dass man es evtl. händisch machen könnte.

    Bin kein Linux-Experte.


    LG
    Peter

    ps: mail noch nicht installiert.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,728

    Default AW: Privoxy - automatischer Start nach Installation?

    Zum Starten beim Systemstart:
    Code:
    systemctl enable privoxy.service
    Sowie die üblichen systemctl start|stop|restart xxxx.service zu systemd

  3. #3

    Default Re: AW: Privoxy - automatischer Start nach Installation?

    Quote Originally Posted by Sauerland View Post
    Zum Starten beim Systemstart:
    Code:
    systemctl enable privoxy.service
    Sowie die üblichen systemctl start|stop|restart xxxx.service zu systemd
    Danke für die schnelle Antwort.

    Ich hatte noch das hier gefunden ( http://lists.opensuse.org/opensuse-b.../msg04707.html ):
    This bugfix get privoxy to start, but it doesn't work!
    See this forum thread
    https://forums.opensuse.org/english/...-internet.html
    und diese Sache: ( https://forums.opensuse.org/showthre...r-installation )

    darin wird das empfohlen:
    su -
    systemctl enable privoxyd.service
    systemctl start privoxyd.service
    was allerdings nicht funktioniert hat.

    Du empfiehlst mehr oder weniger (fast) das gleiche (privoxyd <> privoxy):
    systemctl enable privoxy.service
    Ich versuche es trotzdem noch einmal ohne das zweite Kommando.
    D. h. ich rufe mit dem Konto "meinName" (s.u.) ein Terminal im Superuser-Mode auf und lande bei
    rw------- 1 root root 2067 Feb 12 13:59 .bash_history
    drwxr-xr-x 3 root root 4096 Feb 12 12:42 .config
    drwx------ 3 root root 4096 Feb 12 11:41 .dbus
    drwx------ 2 root root 4096 Sep 27 22:25 .gnupg
    drwxr-xr-x 2 root root 4096 Feb 12 11:40 .kbd
    drwxr-xr-x 3 root root 4096 Feb 12 11:51 .kde4
    drwxr-xr-x 3 root root 4096 Feb 12 12:00 .local
    -rw------- 1 root root 601 Feb 12 13:36 .viminfo
    -rw------- 1 root root 55 Feb 12 14:18 .xauthe8OY3o
    drwxr-xr-x 2 root root 4096 Sep 27 22:25 bin
    drwxr-xr-x 5 root root 4096 Feb 12 11:20 inst-sys


    linux-cont:/ # find -name .bash_history
    ./etc/skel/.bash_history
    find: ‘./var/run/user/1000/gvfs’: Permission denied
    find: ‘./run/user/1000/gvfs’: Permission denied
    ./root/.bash_history
    ./home/meinName/.bash_history
    linux-cont:/ #



    und da setze ich das Kommando
    systemctl enable privoxy.service
    und boote dann?

    habe ich gemacht:

    linux-cont:/home # systemctl enable privoxy.service
    ln -s '/usr/lib/systemd/system/privoxy.service' '/etc/systemd/system/multi-user.target.wants/privoxy.service'
    linux-cont:/home #

    boote jetzt und melde mich wieder (noch ist kein Prozess zu sehen...)




    LG
    Peter

  4. #4

    Default Re: AW: Privoxy - automatischer Start nach Installation?

    Quote Originally Posted by Duplexity View Post

    habe ich gemacht:

    linux-cont:/home # systemctl enable privoxy.service
    ln -s '/usr/lib/systemd/system/privoxy.service' '/etc/systemd/system/multi-user.target.wants/privoxy.service'
    linux-cont:/home #

    boote jetzt und melde mich wieder (noch ist kein Prozess zu sehen...)

    Funktioniert!
    Wer als Greenhorn Linux verwendet wird sehr, sehr, sehr, sehr demütig ;-)

    Danke + LG
    Peter

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,728

    Default AW: Re: AW: Privoxy - automatischer Start nach Installation?

    Quote Originally Posted by Duplexity View Post
    linux-cont:/home # systemctl enable privoxy.service
    ln -s '/usr/lib/systemd/system/privoxy.service' '/etc/systemd/system/multi-user.target.wants/privoxy.service'
    linux-cont:/home #

    boote jetzt und melde mich wieder (noch ist kein Prozess zu sehen...)

    Peter
    Ein
    Code:
    systemctl start privoxy.service
    hätte es auch getan.

    Ich hab nicht umsonst geschrieben:
    Sowie die üblichen systemctl start|stop|restart xxxx.service zu systemd
    Daher der Tip:
    Befasse Dich mit Deinem System, lese, lese und lese Dokus.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •