Results 1 to 5 of 5

Thread: SuseFirewall reagiert nicht auf Yast: alle Ports bleiben geschlossen (insbesondere für CUPS)

  1. #1
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default SuseFirewall reagiert nicht auf Yast: alle Ports bleiben geschlossen (insbesondere für CUPS)

    Hi,
    ich habe soeben openSUSE 13.1 frisch installiert, jetzt versuche ch gerade alles korrekt einzurichten, insbesondere möchte in Zugriff auf die (CUPS/Netzwerk-) Drucker in meinem Netzwerk haben.

    In der Druckerkonfiguration wurde ich auch schon gewarnt das die Firewall möglicherweise den CUPS-Dienst (eingehend, mein Rechner soll keine Druckerfreigeben) blockiert.
    Die Drucker werden in der Tat nicht gefunden, nmaps zeigt mir das in der Tat alle port geschlossen sind.

    Das merkwürdige ist, dass ich bei der Installation angegeben hatte, dass der SSH Port 22 geöffnet werden sollte. Noch merkwürdiger ist, dass der in der Yast Firewallkonfiguration tatsächlich auf geöffneter Port/Dienst unter den "Erlaubten Diensten" in der "Externen Zone" gelistet ist. Der CUPS Dienst ist hier leider nicht zu finden, also habe ich zusätzlich erstmal den Port 631/tcp unter den erweiterten Einstellungen freigegeben.

    Aber ich fasse nochmal zusammen, CUPS geht nicht trotz freigabe, SSH geht auch nicht trotz freigabe.
    rcSuSEFirewall2 und SuSEFirewall2 geben an das die Firewall aktiv ist (und keine Ports freigegeben sind!)

    Es scheint so, als würden die Yast Firewalleinstellungen ignoriert werden, selbst wenn ich die Firewall via Yast deaktiviere, sagt mir nmap, dass alle Ports geschlossen sind.

    Kann mir jemand sagen was hier los sein kann?

  2. #2

    Default Re: SuseFirewall reagiert nicht auf Yast: alle Ports bleiben geschlossen (insbesondere für CUPS)

    Quote Originally Posted by sabo007 View Post
    Kann mir jemand sagen was hier los sein kann?
    Laufen auch die entsprechenden Dienste?
    Nur die Ports in der Firewall öffnen reicht nicht, es muss ja auch jemand auf diesen Ports auf Anfragen warten.

    Den SSH-Dienst solltest du in YaST->System->Services Manager aktivieren können. (sshd)

    Bei CUPS gibts leider ein anderes Problem: seit dem letzten Update lauscht der nicht mehr auf den externen Ports.
    eine mögliche Lösung dafür ist, eine Datei /etc/systemd/system/cups.socket mit folgendem Inhalt anzulegen:
    Code:
    [Unit]
    Description=CUPS Printing Service Sockets
    
    [Socket]
    ListenStream=/var/run/cups/cups.sock
    ListenStream=631
    ListenDatagram=0.0.0.0:631
    BindIPv6Only=ipv6-only
    
    [Install]
    WantedBy=sockets.target
    Dadurch sollte cups.socket auch im Netzwerk lauschen.

    Oder du installierst die cups Pakete vom Printing repo, die haben diese sogenannte "Socket-Aktivierung" wieder deaktiviert und cups wird ganz normal beim Booten gestartet (evtl. cups.service in YaST aktivieren).
    http://download.opensuse.org/reposit...openSUSE_13.1/

  3. #3
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default Re: SuseFirewall reagiert nicht auf Yast: alle Ports bleiben geschlossen (insbesondere für CUPS)

    Der sshd Dienst war in der Tat nicht gestartet, ich ihn also einfach gestartet (via start) und noch enabled (via enable) ich gehe davon aus, dass das letzte für den autostart zuständig ist? Oben gab es noch eine runlevel Option (voreingestellt aus runlevel 5) dort etwas zu ändern brachte nichts, also habe ich es so gelassen, war das ok?

    Jedenfalls sagt mir der Portscanner jetzt das der Port 22 offen ist bzw. das dort ein Dienst "lauscht".

    Die cups.socket habe ich angelegt, aber noch nicht neugestartet, mir ist aber aufgefallen, das im Verzeichnis auch eine "cupsd.service" liegt ihr Inhalt ist:
    Code:
    [Unit]
    Description=CUPS Printing Service
    
    [Service]
    ExecStart=/usr/sbin/cupsd -f
    
    [Install]
    Alias=cupsd.service
    Also=cups.socket cups.path
    WantedBy=printer.target
    Muss das so sein?

  4. #4

    Default Re: SuseFirewall reagiert nicht auf Yast: alle Ports bleiben geschlossen (insbesondere für CUPS)

    Quote Originally Posted by sabo007 View Post
    Der sshd Dienst war in der Tat nicht gestartet, ich ihn also einfach gestartet (via start) und noch enabled (via enable) ich gehe davon aus, dass das letzte für den autostart zuständig ist?
    Ja. Wenn ein Dienst "enabled" ist, wird er automatisch beim Booten gestartet.

    Oben gab es noch eine runlevel Option (voreingestellt aus runlevel 5) dort etwas zu ändern brachte nichts, also habe ich es so gelassen, war das ok?
    runlevel5 ist ein grafisches System mit Netwerkunterstützung. (ist equivalent zu "graphical")
    Interessant wäre wohl nur noch runlevel3 wenn du das grafische System _nicht_ starten willst, also nur Textmodus haben willst.

    Die cups.socket habe ich angelegt, aber noch nicht neugestartet, mir ist aber aufgefallen, das im Verzeichnis auch eine "cupsd.service" liegt ihr Inhalt ist:
    ...
    Muss das so sein?
    Ja, ist normal.
    Die würde an sich den cups beim Booten starten, aber wie schon angedeutet, lauscht bei den Standard-Paketen nicht cups selber auf den Ports, sondern systemd über cups.socket (und per default macht der das nur auf localhost, nicht im Netzwerk).
    Durch die Änderung sollte systemd (cups.socket) auch im Netzwerk lauschen und bei Anfragen falls notwendig cups starten.
    Du kannst die Änderung ohne Neustart testen, indem du cups.socket neu startest:
    Code:
    systemctl restart cups.socket

  5. #5
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default Re: SuseFirewall reagiert nicht auf Yast: alle Ports bleiben geschlossen (insbesondere für CUPS)

    Alles klar und danke für die Hilfe, alles hat sofort funktioniert. SSH läuft und die Netzwerkdrucker werden auch alle angezeigt.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •