Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: The System Network Services are not compatible with this version

  1. #1
    Join Date
    Sep 2014
    Location
    Uttar Pradesh, India
    Posts
    7

    Default The System Network Services are not compatible with this version

    I have installed opensuse 13.1 in my laptop.
    My system configuration are:
    Processor- i5(4th gen)
    RAM - 8GB DDR3
    Network Adapter- Realtek R8168 Gigabit Adapter
    BCM43412 wireless lan

    All the network(ethernet and wireless) settings of the system are disabled. I have tried installing all the drivers and other solutions provided in different forums but nothing has fixed the problem. The network adapters are being detected but all the settings are disabled. When I open the network configuration, it always displays "The System Network Services are not compatible with this version".
    So, please somebody suggest a solution.
    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,371
    Blog Entries
    1

    Default Re: The System Network Services are not compatible with this version

    Did you just update from a previous version or clean install? In any case, can you please post the output of
    Code:
    cat /etc/NetworkManager/NetworkManager.conf

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,254
    Blog Entries
    2

    Default Re: The System Network Services are not compatible with this version

    Besides deano's question which would provide some interesting background info,

    I'd probably recommend doing a force repair using a 13.1 DVD (of course, verify its integrity).

    TSU

  4. #4
    Join Date
    Sep 2014
    Location
    Uttar Pradesh, India
    Posts
    7

    Default Re: The System Network Services are not compatible with this version

    Quote Originally Posted by deano_ferrari View Post
    Did you just update from a previous version or clean install? In any case, can you please post the output of
    Code:
    cat /etc/NetworkManager/NetworkManager.conf

    the output is as follows:
    [main]
    plugins=ifcfg-suse,keyfile

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,371
    Blog Entries
    1

    Default Re: The System Network Services are not compatible with this version

    Quote Originally Posted by rishabh_suse View Post
    the output is as follows:
    [main]
    plugins=ifcfg-suse,keyfile
    Okay, that checks out as expected.

  6. #6
    Join Date
    Sep 2014
    Location
    Uttar Pradesh, India
    Posts
    7

    Default Re: The System Network Services are not compatible with this version

    Quote Originally Posted by deano_ferrari View Post
    Okay, that checks out as expected.
    So, what should I do to fix the problem??

  7. #7

    Default Re: The System Network Services are not compatible with this version

    Quote Originally Posted by rishabh_suse View Post
    So, what should I do to fix the problem??
    Have you actually enabled NetworkManager in YaST?
    That's needed for the desktop's network configuration to work.

    Open YaST->Network Services->Network Settings->Global Options, and activate "User-controlled using NetworkManager".

    If that doesn't help, try to switch to ifup instead, does at least the wired network work then?

    [/COLOR]
    Quote Originally Posted by rishabh_suse View Post
    I have tried installing all the drivers and other solutions provided in different forums but nothing has fixed the problem.
    And which drivers have you installed in particular?
    Installing random drivers might actually _break_ everything...

    And please also post the output of "/sbin/lspci -nnk" to see what exact network devices you have,

  8. #8
    Join Date
    Sep 2014
    Location
    Uttar Pradesh, India
    Posts
    7

    Default Re: The System Network Services are not compatible with this version

    Quote Originally Posted by wolfi323 View Post
    Have you actually enabled NetworkManager in YaST?
    That's needed for the desktop's network configuration to work.

    Open YaST->Network Services->Network Settings->Global Options, and activate "User-controlled using NetworkManager".

    If that doesn't help, try to switch to ifup instead, does at least the wired network work then?

    [/COLOR]

    And which drivers have you installed in particular?
    Installing random drivers might actually _break_ everything...

    And please also post the output of "/sbin/lspci -nnk" to see what exact network devices you have,

    PROBLEM SOLVED.
    I activated "User-controlled using NetworkManager" and now ethernet is getting detected.
    Thanks wolfi323
    Now please tell , how can I switch on the wifi??

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,371
    Blog Entries
    1

    Default Re: The System Network Services are not compatible with this version

    Quote Originally Posted by rishabh_suse View Post
    Now please tell , how can I switch on the wifi??
    You might need to enable with 'rfkill' (you may need to install it first).

    Code:
    rfkill list
    Code:
    zypper unblock wifi

  10. #10

    Default Re: The System Network Services are not compatible with this version

    Quote Originally Posted by deano_ferrari View Post
    You might need to enable with 'rfkill' (you may need to install it first).
    And again, please post the output of lspci (see my previous post) to show which exact wireless device you really have and whiczh driver is in use.

    Only then can you get proper advise _which_ driver/firmware to install if necessary.

    Code:
    zypper unblock wifi
    ???
    I think there's something wrong with that line.
    Would be news to me that you can use zypper to configure/unblock the wireless...
    Last edited by wolfi323; 06-Sep-2014 at 02:41.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •