Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Simple chmod but not

  1. #1

    Default Simple chmod but not

    Got opensuse 13.1 and off the root I have a directory called bkps. right now the owner/group is root/users respectively. The permission is 755 and would like to change it to 766 and do so by the command "chmod -R 766 *" while running as root in a terminal window. No error message after the command and the permissions have not changed. What gives?

    Thanks!

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Simple chmod but not

    On 2014-02-10 00:46, svetter88 wrote:
    >
    > Got opensuse 13.1 and off the root I have a directory called bkps.
    > right now the owner/group is root/users respectively. The permission is
    > 755 and would like to change it to 766 and do so by the command "chmod
    > -R 766 *" while running as root in a terminal window. No error message
    > after the command and the permissions have not changed. What gives?


    Does the command "mount" give an entry for it?

    Wait. You do that chmod, sitting where?

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: Simple chmod but not

    Quote Originally Posted by svetter88 View Post
    Got opensuse 13.1 and off the root I have a directory called bkps. right now the owner/group is root/users respectively. The permission is 755 and would like to change it to 766 and do so by the command "chmod -R 766 *" while running as root in a terminal window. No error message after the command and the permissions have not changed. What gives?

    Thanks!
    I'm not sure what you did there with that "*" on the command line.

    I would have used
    Code:
    # cd bkps
    # chmod -R 766 .
    Notice the difference. I use "." for the current directory, and I cd to that directory first.

    If this directory happens to be on a Window file system, then the "chmod" probably won't do anything because Windows files systems don't support that operation.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4

    Default Re: Simple chmod but not

    Sorry, the "*" should have been \bkup and the command was at the root directory.

  5. #5

    Default Re: Simple chmod but not

    The mount command gives:
    /dev/sdb2 on /bkup type fuseblk (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Simple chmod but not

    On 2014-02-10 03:16, svetter88 wrote:
    >
    > The mount command gives:
    > /dev/sdb2 on /bkup type fuseblk
    > (rw,nosuid,nodev,noexec,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096)


    fuseblk. Thus, very probably not a Linux filesystem. Probably ntfs.
    Thus, you simply can not change permissions there, as nrickert told you.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Simple chmod but not

    On 2014-02-10 03:16, svetter88 wrote:
    >
    > Sorry, the "*" should have been \bkup and the command was at the root
    > directory.


    I hope you did not "chmod -R something *" while on your root directory,
    because if you did, you'd better start thinking of reinstalling your
    entire system...

    You gotta be careful what you do and what you tell us. No mistakes on
    either side, please.

    We can forgive, but the computer will take you at your word. And we need
    to know what that word exactly was.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  8. #8

    Default Re: Simple chmod but not

    Quote Originally Posted by robin_listas View Post
    On 2014-02-10 03:16, svetter88 wrote:
    >
    > Sorry, the "*" should have been \bkup and the command was at the root
    > directory.


    I hope you did not "chmod -R something *" while on your root directory,
    because if you did, you'd better start thinking of reinstalling your
    entire system...

    You gotta be careful what you do and what you tell us. No mistakes on
    either side, please.

    We can forgive, but the computer will take you at your word. And we need
    to know what that word exactly was.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))
    Yes, very careful when using an "*" when in root and also using the recursive option(did that ONCE in the DOS days).

    As it turns out it is formatted as NTFS.

  9. #9

    Default Re: Simple chmod but not

    Thank you one and all for your assistance.

    Scott

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Simple chmod but not

    On 2014-02-12 06:56, svetter88 wrote:

    > As it turns out it is formatted as NTFS.


    Then chmod will not work, nor chown. You can adapt the permissions in
    the mount options (with manual mount) in fstab, but it affects
    _all_files simultaneously.

    I think some permissions might work. Read-write permission flag, because
    MsDos has a similar one. I have not done this in many years, so my
    recollection is fuzzy. you will have to try. And ntfs vs fat are different.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •