Results 1 to 4 of 4

Thread: Font rendering suddenly stopped

  1. #1
    Join Date
    Feb 2014
    Posts
    2

    Unhappy Font rendering suddenly stopped

    Good day! Here's the standard "I'm new, I don't speak great english, this is my first post, and I love openSuSE!" intro

    Okay wonderful, I'm fairly new to the wonderful world of linux and tried a few distros before stumbling across this one (openSuSE with the KDE and everything) and so far haven't had a problem I couldn't sort out with information already on here! However, the other day I managed to screw up my font settings, and in trying to fix them have created a worse problem (although I still don't understand how)

    The other night my font rendering started to look... weak. There was little halos around all of the letters and this problem still exists on my window titles. To fix this I attempted to change my font to 'Droid Sans' and enable anti-aliasing a little, everything became a big mess of pixels. I 'restored to defaults' and everything is usable now, but the font is unusably and distractingly messy looking. To make things worse it is completely inconstant. The right side of bold words gets cut off, normal fonts are overlapping and bizarre, my window titles have strange halos and some (mostly larger) fonts look better than ever.

    I have a fairly virgin install, only normal repos and no drivers were needed (my computer only has on-board graphics)

    Attached is a screenshot showing the array of strange fonts as well as my (default) font settings (that I had been using perfectly fine until now)

    http://paste.opensuse.org/images/52868928.png

  2. #2
    Join Date
    Feb 2014
    Posts
    2

    Default Re: Font rendering suddenly stopped

    Hey everyone! I found a solution, there was a setting that was ticked in the 'anti-aliasing' configuring box titled 'exclude range' and this was excluding most common fonts I would run into. When setting up my antialiasing it chose the wrong sub pixel order (RGB) and that's what made my halos.

    Just putting this here if anybody else finds themselves lost like this. It appears that the "Defaults" button in the fonts settings box does not reset anti-aliasing settings as well.

  3. #3

    Default Re: Font rendering suddenly stopped

    You could try to remove/rename ~/.config/fontconfig/fonts.conf to get back the system's default font rendering settings.

  4. #4
    Join Date
    Feb 2014
    Location
    Brasil
    Posts
    1

    Default Re: Font rendering suddenly stopped

    Have you ever heard of Infinality, it makes fonts really beautiful. I would suggest you to try it under a VM install just to compare with openSUSE default font rendering.

    Howto:

    1. From the main openSUSE official repository, install the fontconfig-infinality

    2. Add the Infinality repository
    http://download.opensuse.org/reposit...openSUSE_13.1/

    OBS: Switch system packages to the versions in the Infinality/namtrac:subpixel repository

    3. Make sure your desktop environment’s font configuration for subpixel hinting is set to: “Use system settings” or something similar. (I do use this option here)
    Only if that option does not exist, set it to RGB order with slight hinting.

    [ ]s

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •