Results 1 to 8 of 8

Thread: Intel Centrino Wireless-N 1000 , wifi connected but intermittent to very slow

  1. #1

    Default Intel Centrino Wireless-N 1000 , wifi connected but intermittent to very slow

    Using a Thinkpad X220 with wireless chipset Intel Centrino Wireless-N 1000.
    Able to connect to wireless router but with intermittent (very slow) connection.


    Googled and noticed that this is a common issue but only able to locate one thread in opensuse forum here.
    Did as advised in the thread "iwlagn 11n_disable=0"


    Note that this device is using the iwlwifi firmware module located in kernel-firmware so "iwlagn 11n_disable=0" may not be suitable now.

    Anyone knows of the "correct" way to solve this problem?


    Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Intel Centrino Wireless-N 1000 , wifi connected but intermittentto very slow

    On 02/09/2014 06:16 AM, michalng wrote:
    >
    > Using a Thinkpad X220 with wireless chipset Intel Centrino Wireless-N
    > 1000.
    > Able to connect to wireless router but with intermittent (very slow)
    > connection.
    >
    >
    > Googled and noticed that this is a common issue but only able to locate
    > one thread in opensuse forum 'here' (http://tinyurl.com/m5mp5sy).
    > Did as advised in the thread "iwlagn 11n_disable=0"
    >
    >
    > Note that this device is using the iwlwifi firmware module located in
    > kernel-firmware so "iwlagn 11n_disable=0" may not be suitable now.
    >
    > Anyone knows of the "correct" way to solve this problem?


    Have you actually tried that command? The device has *always* used firmware, and
    disabling 11n operations probably still helps.

    Please provide the version of openSUSE that you are using. It makes a great deal
    of difference!



  3. #3

    Thumbs up Re: Intel Centrino Wireless-N 1000 , wifi connected but intermittent to very slow

    Please provide the version of openSUSE that you are using. It makes a great deal of difference!
    Using openSUSE 13.1 , KDE 32 bit , installation through KDE Live CD.



    Have you actually tried that command? The device has *always* used firmware, and disabling 11n operations probably still helps.
    Are you referring to
    Code:
    options iwlagn 11n_disable=1
    Didn't try it previously as I understand that the firmware in use is iwlwifi.

    They are different, right? Appreciate if you can help to clear my confusion.





    Out of desparation, what I've tried so far:

    Edited file /etc/modprobe.d/50-awlagn.conf to
    Code:
    options iwlagn 11n_disable=1
    Added file /etc/modprobe/iwlwifi.conf, containing
    Code:
    options iwlwifi 11n_disable=1
    Read somewhere that needs to run the command update-initramfs and reboot. However unable to run this command in openSUSE so just reinstalled kernel and kernel-firmware and anything that is related to iwlwifi and initramfs.


    As this is an intermittent problem happening once a few days, I will have to monitor for a week or so before updating the status here.


    If I am doing anything obviously wrong/redundant, please help to correct. Any pointers and help is greatly appreciated.

  4. #4
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Intel Centrino Wireless-N 1000 , wifi connected but intermittentto very slow

    On 02/09/2014 05:16 PM, michalng wrote:
    >
    >>
    >> Please provide the version of openSUSE that you are using. It makes a
    >> great deal of difference!
    >>

    >
    > Using openSUSE 13.1 , KDE 32 bit , installation through KDE Live CD.
    >
    >
    >
    >> Have you actually tried that command? The device has *always* used
    >> firmware, and disabling 11n operations probably still helps.

    >
    > Are you referring to
    > Code:
    > --------------------
    > options iwlagn 11n_disable=1
    > --------------------
    >
    > Didn't try it previously as I understand that the firmware in use is
    > iwlwifi.
    >
    > They are different, right? Appreciate if you can help to
    > clear my confusion.
    >
    >
    >
    >
    >
    > Out of desparation, what I've tried so far:
    >
    > Edited file /etc/modprobe.d/50-awlagn.conf to
    > Code:
    > --------------------
    > options iwlagn 11n_disable=1
    > --------------------
    >
    > Added file /etc/modprobe/iwlwifi.conf, containing
    > Code:
    > --------------------
    > options iwlwifi 11n_disable=1
    > --------------------
    >
    >
    > Read somewhere that needs to run the command -update-initramfs- and
    > reboot. However unable to run this command in openSUSE so just
    > reinstalled kernel and kernel-firmware and anything that is related to
    > iwlwifi and initramfs.
    >
    >
    > As this is an intermittent problem happening once a few days, I will
    > have to monitor for a week or so before updating the status here.
    >
    >
    > If I am doing anything obviously wrong/redundant, please help to
    > correct. Any pointers and help is greatly appreciated.


    There is a huge difference between firmware and a driver. The former is the code
    that runs in the on-board CPU on the board. The second runs on your computer.

    What driver is your device using? Once you know that, you can issue the command
    'modinfo <your_driver_name>' to see what options the driver will accept.

    On openSUSE, the command is mkinitrd, but there is no reason for you to need to
    use it in this case. That is only needed when the driver is embedded within
    /boot/initrd for your kernel *and* you have changed that driver. A driver must
    be in initrd if it is needed to be able to access the file system while the
    system is booting. That would be rare for wireless.

    With wireless, you can expect some drops. Suppose your AP gets busy and fails to
    send some response in time, there is an intermittent burst of 2.4 GHz radiation
    in your neighborhood, or there is some other kind of interference on the channel
    you have selected. In those cases, the connection might drop or become slow. If
    you absolutely cannot stand a connection drop, you need a wire.



  5. #5

    Default Re: Intel Centrino Wireless-N 1000 , wifi connected but intermittent to very slow

    lwfinger, many thanks for the help and clear explanation.


    If you absolutely cannot stand a connection drop, you need a wire.
    Understand that but I have several computers connecting to the same router wirelessly and only the Intel Wireless N1000 have this intermittent extreme slow speed. So quite sure this is something to that needs to be sorted out.


    Now knowing that Intel Centrino Wireless-N 1000 is using iwlwifi, am I right to say that

    options iwlagn 11n_disable=1
    is not the correct configuration to tweak,
    options iwlwifi 11n_disable=1 should be the correct configuration to change.

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: Intel Centrino Wireless-N 1000 , wifi connected but intermittentto very slow

    On 02/10/2014 04:46 AM, michalng wrote:
    >
    > lwfinger, many thanks for the help and clear explanation.
    >
    >
    >> If you absolutely cannot stand a connection drop, you need a wire.

    > Understand that but I have several computers connecting to the same
    > router wirelessly and only the Intel Wireless N1000 have this
    > intermittent extreme slow speed. So quite sure this is something to that
    > needs to be sorted out.
    >
    >
    > Now knowing that Intel Centrino Wireless-N 1000 is using iwlwifi, am I
    > right to say that
    > -*
    > options iwlagn 11n_disable=1*- is not the correct
    > configuration to tweak,
    > -*options iwlwifi 11n_disable=1 *-should be the correct
    > configuration to change.


    Well, 'lspci -nnv' will tell you exactly what driver is in use. The *name* of
    the file is not important. The name after the "options" part is what counts - it
    *must* match the driver name. You can check that the option is being applied by
    running the following command pair:

    Code:
    sudo /sbin/modprobe -rv <driver_name>
    sudo /sbin/modprobe -v <driver_name>
    None of us are experts on the Intel wireless hardware. I still think your
    expectations are unreasonable; however, if you still want help with that part,
    you will need to contact the Intel developers at linux-wireless@vger.kernel.org.
    You will need to be a lot more specific about the problem than you have been
    here. For instance, you will need to provide a complete list of what you have
    tried. Hearsay from unknown sources on the web is of no value. Supply as much
    documentation as possible from the dmesg output when the problem happens.

    I also suggest you try a new kernel from
    http://download.opensuse.org/reposit...able/standard/. The
    developers are now running kernel 3.14-rc1 and are working on changes to be
    applied in kernel 3.15. You should at least try 3.13.

  7. #7

    Default Re: Intel Centrino Wireless-N 1000 , wifi connected but intermittent to very slow

    lwfinger, thanks.

    Will wait and see it the "desparate" things that I've done so far solves the problem.

    If yes, will update here as solved.
    Hopefully the next person who is having the same problem will find this thread and is helpful to them too.


    Thanks again.

  8. #8

    Default Re: Intel Centrino Wireless-N 1000 , wifi connected but intermittent to very slow

    Just to report back ,

    > Edited file /etc/modprobe.d/50-awlagn.conf to
    > Code:
    > --------------------
    > options iwlagn 11n_disable=1
    > --------------------
    >
    > Added file /etc/modprobe/iwlwifi.conf, containing
    > Code:
    > --------------------
    > options iwlwifi 11n_disable=1
    > --------------------
    >


    one or both of these had solved my problem.

    no more intermittent, dropped connection, thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •