Hi all,
I cannot use my fn keys to set the brightness (when i press the keys, no bar appears by the way). I cannot even use command line tools to modify the brightness.
If I plug in my laptop, I get full brightness, otherwise on battery, the brightness is terribly low.

I tried the following solutions but none succeeded:
  • add to xorg.conf: Option "RegistryDwords" "EnableBrightnessControl=1"
  • add to boot options: acpi_osi=Linux acpi_backlight=vendor
  • echo 2800 > /sys/class/backlight/intel_backlight/brightness : folder /sys/class/backlight is empty
  • xrandr --output default --brightness 0.8: returns "xrandr: Gamma size is 0." and nothing happens
  • xbacklight -set 90: nothing happens. -get returns nothing. Anyway it's based on xrandr i think so nothing expected


I find a file named "brightness" in that folder: /sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/leds/phy0-led/brightness
But I can't modify it, neither by "echo xx > file" nor with vi command.

Any help appreciated
Regards,
Jeremie


FYI I have a hybrid system (ATI Radeon graphic card + intel embedded gpu)
jeremie@linux-40vc:~> /usr/sbin/hwinfo --gfxcard
09: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: _Znp.iyGQlLeawGC
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Model: "Intel VGA compatible controller"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x0166
SubVendor: pci 0x144d "Samsung Electronics Co Ltd"
SubDevice: pci 0xc0e6
Revision: 0x09
Memory Range: 0xf7800000-0xf7bfffff (rw,non-prefetchable)
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
I/O Ports: 0xf000-0xf03f (rw)
IRQ: 16 (141 events)
Module Alias: "pci:v00008086d00000166sv0000144Dsd0000C0E6bc03sc00i00"
Driver Info #0:
Driver Status: i915 is active
Driver Activation Cmd: "modprobe i915"
Config Status: cfg=no, avail=yes, need=no, active=unknown


20: PCI 100.0: 0380 Display controller
[Created at pci.319]
Unique ID: VCu0.far2GQ4KGFC
Parent ID: vSkL._YtGFNWW+i6
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: "ATI Display controller"
Vendor: pci 0x1002 "ATI Technologies Inc"
Device: pci 0x6821
SubVendor: pci 0x144d "Samsung Electronics Co Ltd"
SubDevice: pci 0xc0e6
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable,disabled)
Memory Range: 0xf7d00000-0xf7d3ffff (rw,non-prefetchable,disabled)
I/O Ports: 0xe000-0xefff (rw,disabled)
Memory Range: 0xf7d40000-0xf7d5ffff (ro,non-prefetchable,disabled)
IRQ: 255 (no events)
Module Alias: "pci:v00001002d00006821sv0000144Dsd0000C0E6bc03sc80i00"
Driver Info #0:
Driver Status: radeon is not active
Driver Activation Cmd: "modprobe radeon"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #8 (PCI bridge)


Primary display adapter: #9