Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Help with Energy Saving

  1. #1

    Default Help with Energy Saving

    Hello,

    I have a Asus K53T laptop. My system setup is Windows 7 dual booted with OpenSuse 13.1 x64.
    I noticed that windows consumes significantly less energy compared to OpenSuse, which is a bit surprising considering that windows loads a lot of **** aware plus an antivirus, things that are not running on OpenSuse.
    I am looking for advice on how to configure OpenSuse power options, so my battery lasts as long as it does on windows.

  2. #2
    Join Date
    Mar 2009
    Location
    United States
    Posts
    612

    Default Re: Help with Energy Saving

    Hi! There are a few good ways to save power. The largest boost I noticed is to install laptop-mode-tools. I am going to use some links to the arch-wiki to help you find more info, but aside from references to their package manager it should mainly work exactly the same on openSUSE.
    https://wiki.archlinux.org/index.php/Power_saving
    https://wiki.archlinux.org/index.php/Laptop_Mode_Tools

    You can use powertop to see how much energy you are using.

    I also recommend adding this line to /etc/sysctl.conf it should help to keep writes in bursts.
    Code:
    vm.dirty_writeback_centisecs = 1500

  3. #3

    Default Re: Help with Energy Saving

    Thanks for the suggestions
    I am reading trough Laptop Mode features. Is it mostly done automatically or do I actually need to configure something?
    I made sure that I have hdparm and cpupower installed.
    Also trying to interpret the results provided by powertop. I am getting around 450wakeup/s with the PC idle, but I don't really have anything to compare this to. I noticed that the CPU usage displayed by powertop is usually higher than the one displayed by System Monitor, but have no idea what conclusions to take out of this!

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Help with Energy Saving

    On 2014-02-08 15:56, drkdfndr wrote:
    >
    > Hello,
    >
    > I have a Asus K53T laptop. My system setup is Windows 7 dual booted with
    > OpenSuse 13.1 x64.


    Does it have an hybrid video setup, like Nvidia plus Intel graphics?
    Without the proper drivers, the Nvidia card will be powered even if not
    used.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  5. #5

    Default Re: Help with Energy Saving

    Hi,
    Yes, I have a dual graphics set up in my laptop. I have the AMD APU A6 CPU (integrated graphics) plus the AMD HD7670 dedicated card.
    I am already using the AMD proprietary drivers

  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Help with Energy Saving

    On 2014-02-10 16:06, drkdfndr wrote:
    >
    > Hi,
    > Yes, I have a dual graphics set up in my laptop. I have the AMD APU A6
    > CPU (integrated graphics) plus the AMD HD7670 dedicated card.
    > I am already using the AMD proprietary drivers


    Well, using the integrated graphics on the CPU uses much less power. How
    to disable the dedicated card, I do not know. I guess that the idea is
    to use the integrated g. on battery, and the card while on mains.
    Possibly Windows side handles this automatically and correctly.

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  7. #7
    Join Date
    Feb 2014
    Location
    Romania
    Posts
    87

    Default Re: Help with Energy Saving

    bingo....
    it seems that hybrid graphic is still a nightmare on linux.
    take a look on this man, maybe this will give you a clue:

    https://help.ubuntu.com/community/BinaryDriverHowto/AMD

    read the chapter 3.2.....

  8. #8

    Default Re: Help with Energy Saving

    Hi,
    I have followed all the suggestions, and my battery has been lasting a substantially higher amount of time.

    But I am having a problem that I believe is caused by laptop mode tools. Every time I use a USB mouse it gets switched off after a few seconds, and wakes-up if a press one of the mouse buttons, but not by moving it..
    For what I have read, I need to blacklist my USB mouse on "usb-autosuspend.conf".
    On that file I see the following entries.
    Code:
    AUTOSUSPEND_USBTYPE_BLACKLIST=""
    AUTOSUSPEND_USBID_BLACKLIST=""
    I think it would be best to use USBTYPE so I could blacklist all mouses (if that's possible?), I am just not sure on what should go there, to accomplish that.

  9. #9

    Default Re: Help with Energy Saving

    Still not sure what parameters to use
    (bump)

  10. #10
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Help with Energy Saving

    On 2014-03-11 16:56, drkdfndr wrote:
    >
    > Still not sure what parameters to use
    > (bump)


    I have an idea about this, but I need having a good look at my laptop,
    and then write it here. But I always forget when it is powered up. Sorry.
    I need to do some errands... perhaps when I come back.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 13.1 x86_64 "Bottle" at Telcontar)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •