Results 1 to 8 of 8

Thread: Amarok error towards end of song

  1. #1
    Join Date
    Nov 2012
    Location
    McMasterville, Québec, Canada
    Posts
    17

    Question Amarok error towards end of song

    Hi,

    When playing songs in Amarok, I have an error towards the end of song. This is the error I have ...

    /usr/bin/gst-install-plugins-helper requires an additional plugin for this operation
    file protocol source

    Can someone know how to resolve this error ?

    Thank You very much

    Patrick

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Amarok error towards end of song

    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Nov 2012
    Location
    McMasterville, Québec, Canada
    Posts
    17

    Default Re: Amarok error towards end of song

    Quote Originally Posted by caf4926 View Post
    caf4926,

    I used the openSUSE Community 1-click install (as one of the option mentionned at your link). So the repos are configured

    I already did a : zypper ref, zypper up, and zypper inr to be sure everything was up to date.

    So nothing changed, same problem. Any other idea ? Can you direct me to a log file I can see what's happening ?

    Thanks

    Pat

  4. #4
    Join Date
    Nov 2012
    Location
    McMasterville, Québec, Canada
    Posts
    17

    Default Re: Amarok error towards end of [song] playlist

    Quote Originally Posted by milpat View Post
    caf4926,

    I used the openSUSE Community 1-click install (as one of the option mentionned at your link). So the repos are configured

    I already did a : zypper ref, zypper up, and zypper inr to be sure everything was up to date.

    So nothing changed, same problem. Any other idea ? Can you direct me to a log file I can see what's happening ?

    Thanks

    Pat
    I noticed that the message was appearing toward the end of the playlist, not a song. Just a clarification.

    Thank You

    Pat

  5. #5
    Join Date
    Nov 2012
    Location
    McMasterville, Québec, Canada
    Posts
    17

    Default Re: Amarok error towards end of song

    I started Amarok from the command line and this is what I got ...

    QMap(("album", "The Road Less Travelled")("albumArtist", "Triosphere")("artist", "Triosphere")("chosenByUser", "1")("context", "")("duration", "291")("method", "Track.scrobble")("timestamp", "1391842552")("track", "Echoes"))
    ** Message: PackageKit: xid = 44040445
    ** Message: PackageKit: Codec nice name: FILE protocol source
    ** Message: PackageKit: non-structure: gstreamer(null)(urisource-file)()(64bit)
    " <lfm status="ok">
    <scrobbles ignored="0" accepted="1">
    <scrobble>
    <track corrected="0">Echoes</track>
    <artist corrected="0">Triosphere</artist>
    <album corrected="0">The Road Less Travelled</album>
    <albumArtist corrected="0">Triosphere</albumArtist>
    <timestamp>1391842552</timestamp>
    <ignoredMessage code="0"/>
    </scrobble>
    </scrobbles>
    </lfm>
    "
    Calling appendChild() on a null node does nothing.
    QMap(("method", "track.removeNowPlaying"))


    By the way, I also got a lot of this error before ...

    QPainter::begin: Paint device returned engine == 0, type: 2
    QPainter::setCompositionMode: Painter not active
    QPainter::end: Painter not active, aborted

  6. #6

    Default AW: Amarok error towards end of song

    Quote Originally Posted by milpat View Post
    /usr/bin/gst-install-plugins-helper requires an additional plugin for this operation
    file protocol source
    That's strange because the "file protocol source" should be included in the standard packages obviously. No need to install anything for that.

    Maybe your package versions do not work together well?
    Try to switch all your packages to Packman, see here:
    http://en.opensuse.org/SDB:Vendor_ch..._Vendor_change

    Try to remove the gstreamer plugins cache by deleting the directory ~/.gstreamer-0.10/ .

    If nothing helps, you can of course just switch to the VLC backend. You may need to install "phonon-backend-vlc" (included in the standard repos, so just search for it in YaST->Software Management). Then enter "Configure Desktop"->Multimedia->Audio and Video Settings (or click on "Configure Phonon" in Amarok's settings->"Playback"). On the "Backend" tab move VLC to the top.
    You should already have the necessary codecs for VLC, if not install the package "vlc-codecs".

  7. #7
    Join Date
    Nov 2012
    Location
    McMasterville, Québec, Canada
    Posts
    17

    Talking Resolved: Amarok error towards end of the playlist

    wolfi323,

    Removing the gstreamer cache (~\.gstreamer-0.10\registry.x86_64.bin) did the trick, no more error messages towards the end of the playlist.

    Do you have any idea why it happened ?

    Thank you very much for your help

    Patrick

  8. #8

    Default Re: Resolved: Amarok error towards end of the playlist

    Quote Originally Posted by milpat View Post
    Do you have any idea why it happened ?
    No, sorry.
    And I never had to remove the cache ever myself.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •