Page 1 of 6 123 ... LastLast
Results 1 to 10 of 56

Thread: wireless printer

  1. #1

    Default wireless printer

    The last step of the installation of my Brother HL-5370DW wireless printer gave an error message:

    Will you specify the Device URI? [Y/n] ->Y


    0: http
    1: https
    2: beh
    3: smb
    4: ipp
    5: socket
    6: ipps
    7: lpd
    8: hp
    9: parallel:/dev/lp0
    10 (I): Specify IP address.
    11 (A): Auto. (usb://dev/usblp0)

    select the number of destination Device URI. ->4

    lpadmin -p HL5370DW -v ipp -E
    lpadmin: Bad device-uri "ipp".
    Which URI option do I need and how can I correct it?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: wireless printer

    Hi mgl

    A very similar issue was discussed recently here in this thread

    https://forums.opensuse.org/showthre...92#post2619592

    Assuming you have your printer assigned with a static IP address, it is possible to use something like
    Code:
    socket://<printer IP address>
    However, the thread discussed the method(s) required to address the printer by its hostname instead.

    Refer post #23 of the same thread onwards. Thanks to advice by user kalten, it was possible to consider using SNMP to generate a manual URI with hostname used (rather than IP address). In post #26, I listed some commands that could be run to query the network-attached printer. For example, the 'snmp' backend can be called directly with

    Code:
    /usr/lib/cups/backend/snmp <printer hostname>.local
    assuming you know the hostname of your printer, or by its IP address.

    Let me know if you get stuck.

  3. #3

    Default Re: wireless printer

    Quote Originally Posted by deano_ferrari View Post
    Hi mgl A very similar issue was discussed recently here in this thread https://forums.opensuse.org/showthre...92#post2619592 Assuming you have your printer assigned with a static IP address, it is possible to use something like
    Code:
    socket://
    However, the thread discussed the method(s) required to address the printer by its hostname instead. Refer post #23 of the same thread onwards. Thanks to advice by user kalten, it was possible to consider using SNMP to generate a manual URI with hostname used (rather than IP address). In post #26, I listed some commands that could be run to query the network-attached printer. For example, the 'snmp' backend can be called directly with
    Code:
    /usr/lib/cups/backend/snmp 
    .local
    assuming you know the hostname of your printer, or by its IP address. Let me know if you get stuck.
    Yes, I'd like to avoid static IP. The snmp provided this:
    Code:
     misi@linux-hirq:~> /usr/lib/cups/backend/snmp 192.168.1.63 INFO: Using default SNMP Community public network lpd://BRW5CAC4C807987/BINARY_P1 "Brother HL-5370DW series" "Brother HL-5370DW series" "MFG:Brother;CMD:PJL,PCL,PCLXL,POSTSCRIPT;MDL:HL-5370DW series;CLS:PRINTER;" ""
    After the ipp has failed, how do I pick the lpd option? Do I have to go through the entire installation again? Also, how about the blanks in the printer's name, as I remember that Unix doesn't like them. Thanks!

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: wireless printer

    Quote Originally Posted by mgl View Post
    Yes, I'd like to avoid static IP. The snmp provided this:
    Code:
     misi@linux-hirq:~> /usr/lib/cups/backend/snmp 192.168.1.63 INFO: Using default SNMP Community public network lpd://BRW5CAC4C807987/BINARY_P1 "Brother HL-5370DW series" "Brother HL-5370DW series" "MFG:Brother;CMD:PJL,PCL,PCLXL,POSTSCRIPT;MDL:HL-5370DW series;CLS:PRINTER;" ""
    After the ipp has failed, how do I pick the lpd option? Do I have to go through the entire installation again? Also, how about the blanks in the printer's name, as I remember that Unix doesn't like them. Thanks!
    It might be as simple as editing /etc/cups/printers.conf as root so that 'Device URI' looks like this
    Code:
    DeviceURI lpd://BRW5CAC4C807987.local/BINARY_P1
    Then restart CUPS, and see if you can print.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: wireless printer

    BTW, as a test, you should get a response from this query too...
    Code:
    /usr/lib/cups/backend/snmp BRW5CAC4C807987.local

  6. #6

    Default Re: wireless printer

    Quote Originally Posted by deano_ferrari View Post
    BTW, as a test, you should get a response from this query too...
    Code:
    /usr/lib/cups/backend/snmp BRW5CAC4C807987.local
    I modified deviceURI and I got this:
    Code:
    misi@linux-hirq:/> /usr/lib/cups/backend/snmp BRW5CAC4C807987.local
    INFO: Using default SNMP Community public
    ERROR: Unable to scan "BRW5CAC4C807987.local"!

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: wireless printer

    For hostname resolution to work, you need to have avahi installed and active.

    Check the daemon status
    Code:
    systemctl status avahi-daemon.service
    and /etc/nsswitch.conf should contain an entry similar to this
    Code:
    hosts:          files mdns_minimal [NOTFOUND=return] dns
    *The mdns_minimal module handles queries for the .local top level domain.

    Other than that, I'm not sure what else to advise

  8. #8

    Default Re: wireless printer

    Quote Originally Posted by deano_ferrari View Post
    For hostname resolution to work, you need to have avahi installed and active.

    Check the daemon status
    Code:
    systemctl status avahi-daemon.service
    and /etc/nsswitch.conf should contain an entry similar to this
    Code:
    hosts:          files mdns_minimal [NOTFOUND=return] dns
    *The mdns_minimal module handles queries for the .local top level domain.

    Other than that, I'm not sure what else to advise
    This is what I got for the daemon status:
    Code:
    misi@linux-hirq:~> systemctl status avahi-daemon.service
    avahi-daemon.service - Avahi mDNS/DNS-SD Stack
       Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled)
       Active: active (running) since Mon 2014-02-10 21:41:16 EST; 7min ago
     Main PID: 574 (avahi-daemon)
       Status: "Server startup complete. Host name is linux-hirq.local. Local service cookie is 23286237."
       CGroup: /system.slice/avahi-daemon.service
               └─574 avahi-daemon: running [linux-hirq.local]
    ... and here is my nsswitch.conf file:

    Code:
    #
    # /etc/nsswitch.conf
    #
    # An example Name Service Switch config file. This file should be
    # sorted with the most-used services at the beginning.
    #
    # The entry '[NOTFOUND=return]' means that the search for an
    # entry should stop if the search in the previous entry turned
    # up nothing. Note that if the search failed due to some other reason
    # (like no NIS server responding) then the search continues with the
    # next entry.
    #
    # Legal entries are:
    #
    #       compat                  Use compatibility setup
    #       nisplus                 Use NIS+ (NIS version 3)
    #       nis                     Use NIS (NIS version 2), also called YP
    #       dns                     Use DNS (Domain Name Service)
    #       files                   Use the local files
    #       [NOTFOUND=return]       Stop searching if not found so far
    #
    # For more information, please read the nsswitch.conf.5 manual page.
    #
    
    # passwd: files nis
    # shadow: files nis
    # group:  files nis
    
    passwd: compat
    group:  compat
    
    hosts:          files mdns_minimal [NOTFOUND=return] dns
    networks:       files dns
    
    services:       files
    protocols:      files
    rpc:            files
    ethers:         files
    netmasks:       files
    netgroup:       files nis
    publickey:      files
    
    bootparams:     files
    automount:      files nis
    aliases:        files

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: wireless printer

    I'm not quite sure what is failing here. With your printer online, report the output from
    Code:
    CUPS_DEBUG_LEVEL=3 /usr/lib/cups/backend/snmp

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,699
    Blog Entries
    1

    Default Re: wireless printer

    I just remembered that I has a similar issue with querying a network printer via the office wireless network, but when I switched to wired ethernet, I was able to detect it. I wonder if you're experiencing the same. If possible, as a test try connecting the PC directly to the router via an ethernet cable, (and maybe the printer too).

    Avahi uses mDNS to discover the IP addresses of a given hostname. I have read that some wireless routers apparently need to be configured to allow multicast broadcasts.

Page 1 of 6 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •