Results 1 to 6 of 6

Thread: ata2 "Comreset error" and skipping with libata

  1. #1

    Default ata2 "Comreset error" and skipping with libata

    Hi,

    I was previously having this problem on Ubuntu, so it's not OpenSuse specific. I'm running OS 13.1on an Acer S3 and booting is delayed. The Comreset messages appear on the screen during boot (the below are taken from dmesg).

    Code:
    [    1.045021] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
    [    1.046185] ata1.00: ATA-8: Hitachi HTS543232A7A384, ES2OA90B, max UDMA/133
    [    1.046193] ata1.00: 625142448 sectors, multi 0: LBA48 NCQ (depth 31/32), AA
    [    1.047514] ata1.00: configured for UDMA/133
    [    6.406565] ata2: link is slow to respond, please be patient (ready=0)
    [   11.102567] ata2: COMRESET failed (errno=-16)
    [   16.462135] ata2: link is slow to respond, please be patient (ready=0)
    [   21.158137] ata2: COMRESET failed (errno=-16)
    [   26.517703] ata2: link is slow to respond, please be patient (ready=0)
    [   56.225026] ata2: COMRESET failed (errno=-16)
    [   61.280325] ata2: COMRESET failed (errno=-16)
    [   61.281355] ata2: reset failed, giving up
    [   61.587602] ata4: SATA link down (SStatus 0 SControl 310)
    [   61.892864] ata5: SATA link down (SStatus 0 SControl 310)
    A lot of people seem to have this problem, but there are not any really solid solutions. The one I think would work the best is to skip it checking somehow and to default to failure, so I don't have to wait for it to fail. Is this the right approach, and what command would I use? I am thinking there might be a libata option, perhaps...?

    Thanks
    MorayJ

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,316
    Blog Entries
    15

    Default Re: ata2 "Comreset error" and skipping with libata

    On Fri 07 Feb 2014 08:16:02 PM CST, MorayJ wrote:


    Hi,

    I was previously having this problem on Ubuntu, so it's not OpenSuse
    specific. I'm running OS 13.1on an Acer S3 and booting is delayed. The
    Comreset messages appear on the screen during boot (the below are taken
    from dmesg).


    Code:
    --------------------
    [ 1.045021] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl
    310) [ 1.046185] ata1.00: ATA-8: Hitachi HTS543232A7A384, ES2OA90B,
    max UDMA/133 [ 1.046193] ata1.00: 625142448 sectors, multi 0: LBA48
    NCQ (depth 31/32), AA [ 1.047514] ata1.00: configured for UDMA/133
    [ 6.406565] ata2: link is slow to respond, please be patient
    (ready=0) [ 11.102567] ata2: COMRESET failed (errno=-16)
    [ 16.462135] ata2: link is slow to respond, please be patient
    (ready=0) [ 21.158137] ata2: COMRESET failed (errno=-16)
    [ 26.517703] ata2: link is slow to respond, please be patient
    (ready=0) [ 56.225026] ata2: COMRESET failed (errno=-16)
    [ 61.280325] ata2: COMRESET failed (errno=-16)
    [ 61.281355] ata2: reset failed, giving up
    [ 61.587602] ata4: SATA link down (SStatus 0 SControl 310)
    [ 61.892864] ata5: SATA link down (SStatus 0 SControl 310)

    --------------------


    A lot of people seem to have this problem, but there are not any really
    solid solutions. The one I think would work the best is to skip it
    checking somehow and to default to failure, so I don't have to wait for
    it to fail. Is this the right approach, and what command would I use? I
    am thinking there might be a libata option, perhaps...?

    Thanks
    MorayJ


    Hi
    Update the firmware in your HDD/SSD? What is the SATA set to in the
    system BIOS?

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE 13.1 (Bottle) (x86_64) GNOME 3.10.2 Kernel 3.11.10-7-desktop
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3

    Default Re: ata2 "Comreset error" and skipping with libata

    Can't find a firware update for it (not from the manufacturer anyway, and always dubious about random download sites).

    Sata is set to AHCI - if I set it to IDE, boot fails and also fails for Windows.

    if it's going to fail it would be good if I could just fail instantly and not hold up the boot.

    Thanks for your interest though.

    Moray

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,316
    Blog Entries
    15

    Default Re: ata2 "Comreset error" and skipping with libata

    Hi
    OK, then try the grub entry in comment #2 here;
    https://bugzilla.kernel.org/show_bug.cgi?id=43196
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: ata2 "Comreset error" and skipping with libata

    Quote Originally Posted by malcolmlewis View Post
    Hi
    OK, then try the grub entry in comment #2 here;
    https://bugzilla.kernel.org/show_bug.cgi?id=43196


    Tried adding libahci.skip_host_reset=1 to the default in grub and that didn't do anything. I'm getting the idea that I might be stuck with
    this unless I get a new drive...but I'm going to have another look tomorrow. I think some people are talking about a patch which which allows
    syou to skip trying to do anything with that ata...

    Cheers
    Moray

  6. #6

    Default Re: ata2 "Comreset error" and skipping with libata

    Well, used it as an excuse to buy a new hard disk (ssd), but still getting the error. From googling, looks like there is something wrong on a board somewhere.

    Unfortunately libata, which is insisting on checking for this broken bit every time, doesn't have a skip feature at the moment. But this patch is doing the rounds...

    http://dev.gentoo.org/~robbat2/patch...by-param.patch

    I tried to apply it, and recompiled the kernel, but managed to bork my system (fresh install fortunately) so have added the skip command to grub in the hope that a libata update will make its way upstream and will come down in an OpenSuse update and all will be magically fixed!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •