Results 1 to 7 of 7

Thread: grub commands not found.

  1. #1

    Default grub commands not found.

    Hi,

    I want to update grub with params to fix intel g. cards brightness levels. but i cannot update grub from console or from yast cotrol panel.

    Code:
    erik@linux-rwt0:~> grub2-mkconfig -o /boot/grub2/grub.cfg
    Absolute path to 'grub2-mkconfig' is '/usr/sbin/grub2-mkconfig', so running it may require superuser privileges (eg. root).
    .......
    Absolute path to 'grub' is '/usr/sbin/grub', so running it may require superuser privileges (eg. root).erik@linux-rwt0:~> sudo grub -help
    sudo: grub: command not found
    erik@linux-rwt0:~> sudo update-grub -help
    sudo: update-grub: command not found
    erik@linux-rwt0:~> sudo grub-setup --version
    sudo: grub-setup: command not found
    erik@linux-rwt0:~> sudo ls /usr/sbin | grep grub
    grub
    grub2-bios-setup
    grub2-install
    grub2-mkconfig
    grub2-ofpathname
    grub2-once
    grub2-probe
    grub2-reboot
    grub2-set-default
    grub2-sparc64-setup
    grub-install
    grub-install.unsupported
    grub-md5-crypt
    grubonce
    erik@linux-rwt0:~> sudo grub2-mkconfig -o /boot/grub2/grub.cfg
    
    
    sudo: grub2-mkconfig: command not found
    erik@linux-rwt0:~>
    i have tried various commands. i ma usins opensuse 13.01 fully updated.

    Can somebody help me? I am new to opensuse, i never had this command not found problem with ubuntu based systems.

    Thankyou

  2. #2
    Join Date
    Sep 2012
    Posts
    7,104

    Default Re: grub commands not found.

    sudo /usr/sbin/grub2-mkconfig

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: grub commands not found.

    Using KDE?

    Menu => System => Terminal => Terminal - Super User Mode

    Enter root pw when prompted.

    grub2-mkconfig -o /boot/grub2/grub.cfg
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  4. #4

    Default Re: grub commands not found.

    Thanks for reply.

    1. I am using XFCE
    2. using yast -> boot loader -> commands its also does not work.
    3.
    Code:
    erik@linux-rwt0:~> sudo /usr/sbin/grub2-mkconfig  -o /boot/grub2/grub.cfgroot's password:
    /etc/default/grub: line 14: noresume: command not found
    erik@linux-rwt0:~>
    i am trying to add: acpi_backlight=vendor acpi_osi=Linux
    This will fix birghtnes levels

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: grub commands not found.

    On 2014-02-08 10:56, erikkubica wrote:
    >
    > Thanks for reply.
    >
    > 1. I am using XFCE
    > 2. using yast -> boot loader -> commands its also does not work.
    > 3.
    >
    > Code:
    > --------------------
    > erik@linux-rwt0:~> sudo /usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfgroot's password:
    > /etc/default/grub: line 14: noresume: command not found
    > erik@linux-rwt0:~>
    >
    > --------------------


    Using sudo for everything is an ubuntu thing. Here it works better to
    use "su -".

    Code:
    su -
    grub2-mkconfig ....

    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))

  6. #6

    Default Re: grub commands not found.

    I think its does not like my commands i have added.

    Code:
    erik@linux-rwt0:~> su -Password: 
    linux-rwt0:~ # grub2-mkconfig -o /boot/grub2/grub.cfg
    /etc/default/grub: line 14: noresume: command not found
    linux-rwt0:~ #

    Code:
    linux-rwt0:/etc/grub.d # cat /etc/default/grub
    # Modified by YaST2. Last modification on Sat Feb  8 10:59:03 CET 2014
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
    # For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange install order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader
    
    
    # If you change this file, run 'grub2-mkconfig -o /boot/grub2/grub.cfg' afterwards to update
    # /boot/grub2/grub.cfg.
    GRUB_DISTRIBUTOR="openSUSE 13.1"
    GRUB_DEFAULT=saved
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=8
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-id/ata-ST1000LM024_HN-M101MBB_S2SMJ9FD317526-part5 splash=silent quiet showopts acpi_backlight=vendor acpi_osi=Linux"
    # kernel command line options for failsafe mode
    GRUB_CMDLINE_LINUX_RECOVERY=""showopts apm=off noresume edd=off powersaved=off nohz=off highres=off"
    processor.max_cstate="1 nomodeset x11failsafe acpi_backlight=vendor acpi_osi=Linux""
    GRUB_CMDLINE_LINUX=""
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM=0x01234567,0xfefefefe,0x89abcdef,0xefefefef
    # Uncomment to disable graphical terminal (grub-pc only)
    GRUB_TERMINAL=gfxterm
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    GRUB_GFXMODE=auto
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_LINUX_RECOVERY=true
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"
    # Skip 30_os-prober if you experienced very slow in probing them
    # WARNING foregin OS menu entries will be lost if set true here
    GRUB_DISABLE_OS_PROBER=false
    GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
    GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/background.png
    --
    Cheers / Saludos,

    Carlos E. R.

    (from 13.1 x86_64 "Bottle" (Minas Tirith))[/QUOTE]

  7. #7

    Default Re: grub commands not found.

    My grub default was totally bad....

    i have cleaned up the config file removed comments, i have found wrong quotes on wrong places. I think it was bad by default because i does not added quotes to it. So it is maybe possible bug of installer or some update.

    Code:
    GRUB_DISTRIBUTOR="openSUSE 13.1"
    GRUB_DEFAULT=saved
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=8
    GRUB_CMDLINE_LINUX_DEFAULT=" resume=/dev/disk/by-id/ata-ST1000LM024_HN-M101MBB_S2SMJ9FD317526-part5 splash=silent quiet showopts"
    GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"
    GRUB_CMDLINE_LINUX="acpi_backlight=vendor acpi_osi=Linux"
    #GRUB_BADRAM=0x01234567,0xfefefefe,0x89abcdef,0xefefefef
    GRUB_TERMINAL=gfxterm
    GRUB_GFXMODE=auto
    #GRUB_DISABLE_LINUX_UUID=true
    #GRUB_DISABLE_LINUX_RECOVERY=true
    #GRUB_INIT_TUNE="480 440 1"
    GRUB_DISABLE_OS_PROBER=false
    GRUB_THEME=/boot/grub2/themes/openSUSE/theme.txt
    GRUB_BACKGROUND=/boot/grub2/themes/openSUSE/background.png
    Now everything works great, brightness and also it found my windows partition.

    Thank you very much for every reply, now i will use su - instead of sudo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •